VirtualBox

Ticket #13176 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

[PATCH] LONG64 properties misformatted in showvminfo output => Fixed in SVN

Reported by: lars Owned by:
Priority: major Component: other
Version: VirtualBox 4.3.12 Keywords: VBoxManage showvminfo machinereadable
Cc: Guest type: other
Host type: other

Description

When using the --machinereadable flag in VBoxManage's showvminfo command some of the resulting output is misformatted, e.g:

Time offset=0rtcuseutc="on"

The key part of TimeOffset is printed using its human-readable representation. Also, what should be two lines gets joined due to a missing newline.

This is caused by an error in the definition of the SHOW_LONG64_PROP macro. A simple patch (s/a_szHuman/a_szMachine/ plus addition of the '\n', basically) is attached to this report.

While the issue is mentioned in passing in 12073, the latter seems to be a more general enhancement request so I decided to create a new ticket for this.

Attachments

VBoxManage-showvminfo-fix-i64-mach-output.diff Download (636 bytes) - added by lars 3 years ago.

Change History

Changed 3 years ago by lars

comment:1 Changed 3 years ago by frank

  • Summary changed from [PATCH] LONG64 properties misformatted in showvminfo output to [PATCH] LONG64 properties misformatted in showvminfo output => Fixed in SVN

Thank you for this report. The fix will be part of the next maintenance release.

comment:2 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in 4.3.14.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use