VirtualBox

Ticket #13108 (new defect)

Opened 5 years ago

Last modified 11 months ago

Guest mouse cursor range limited without guest additions installed

Reported by: ErikW Owned by:
Component: other Version: VirtualBox 4.3.12
Keywords: mouse cursor pointer position range Cc:
Guest type: all Host type: Windows

Description

When using a guest OS without VirtualBox Guest Additions installed, the guest mouse cursor can only be moved within a part of the guest desktop. Before the guest mouse cursor reaches the edge of the desktop, the cursor suddenly jumps outside the guest window and appears on the host OS desktop.

The problem happens in version 4.3.12 and 4.2.24 as well as previous versions. The specific host OS is Windows 7 Professional SP1 and the guest OS is Windows XP SP3 (without guest additions). The same problem happens for other guest operating systems without guest additions installed.

The display resolution on the host OS is higher than that of the guest OS. The host OS resolution is 1680 x 1050. The guest OS resolution is 1024 x 768.

It appears that the mouse becomes un-captured when the (invisible) host cursor position moves outside the guest window. The cursor in the guest moves slower than in the host, so the guest cursor has not reached the edge of the guest desktop. Either the mouse should remain captured, or the mouse position in the host should be converted to the correct guest position based on the different screen resolutions.

The problem also happens in full screen mode. The guest display uses only a portion of the host screen, and the guest mouse cursor stops moving when the (invisible) host cursor moves outside the guest portion of the screen. The host mouse cursor reappears before the guest cursor has moved to the edge of the guest desktop.

This problem makes VirtualBox very difficult to use with boot CDs or operating systems not supported by guest additions. In some very old versions of VirtualBox (3.x) this problem did not occur. I frequently use VirtualBox to test boot CDs that I have created for backup, partitioning and encryption software.

Change History

comment:1 follow-ups: ↓ 3 ↓ 5 Changed 5 years ago by michael

This is not a problem we are aware of with Windows XP guests (we know of something similar for older Linux guests, such as Redhat Enterprise Linux 5 and derivatives). With XP guests VirtualBox normally emulates a USB tablet which ensures that the guest mouse position is always correct. Can you think about anything which might be different in your XP guest or the way you are using it? Are you able to test with a freshly installed XP guest?

comment:2 Changed 5 years ago by klaus

Also, please provide VBox.log - it provides key information which avoid wasting a lot of time by asking loads of questions.

comment:3 in reply to: ↑ 1 Changed 5 years ago by ErikW

Replying to michael:

This is not a problem we are aware of with Windows XP guests (we know of something similar for older Linux guests, such as Redhat Enterprise Linux 5 and derivatives). With XP guests VirtualBox normally emulates a USB tablet which ensures that the guest mouse position is always correct. Can you think about anything which might be different in your XP guest or the way you are using it? Are you able to test with a freshly installed XP guest?

What is unusual is that I am NOT using Guest Additions. In other words, the system is Windows Pre-installation Environment (Windows PE), rather than an "installed" XP system. I cannot "reinstall" Windows XP because it is not installed to the hard disk. I have used the same Windows PE boot disc with earlier versions of VirtualBox (V3.x) without having mouse positioning problems.

The problem does not appear to be specific to Windows XP. I see the problem with any boot disk using a standalone OS that has no special drivers for VirtualBox. It seems that VirtualBox only handles the mouse properly now with Guest Additions installed in a guest OS.

Since the Guest OS does not seem to matter I will test a Linux host OS to see if I have the same problem.

comment:4 Changed 5 years ago by ErikW

I tested on a Slackware 14.1 host OS with KDE 4.10 desktop. The problem did not occur with the Slackware host OS. So far I have only seen the problem with a Windows 7 host OS.

On Windows 7, I tested with a SteelSeries Kana mouse and a Microsoft Intellimouse Optical mouse. The problem happens with both mice.

The problem is worse when I move the mouse slowly inside the guest OS window. If I move the mouse quickly then the problem doesn't happen or the mouse cursor stops closer to the edge of the guest window.

When the mouse cursor reappears on the Host desktop, if I press the host key twice (to recapture the mouse) then the host cursor disappears and the guest cursor will reappear then continue to move to the edge of the guest OS window. It's acting like the mouse gets un-captured before the cursor reaches the edge of the guest's desktop. On Linux, the mouse never gets un-captured until I move the mouse way past the edge of the guest's desktop.

Could this have something to do with the fact that the virtual machine was running Guest Additions before I booted the CD that has no Guest Additions? Could mouse integration still be turned on in for virtual machine even though the guest does not support it?

Last edited 5 years ago by ErikW (previous) (diff)

comment:5 in reply to: ↑ 1 Changed 5 years ago by ErikW

Replying to michael:

... With XP guests VirtualBox normally emulates a USB tablet which ensures that the guest mouse position is always correct.

I double checked the settings for the virtual machines that are misbehaving. The mouse for them was set to "PS/2 Mouse", which is what VirtualBox used to emulate. I changed the setting to "USB Tablet", and that seems to have corrected the problem. I'm not sure what the solution is for operating systems that only support a PS/2 mouse.

So, the problem I am seeing only happens when emulating a PS/2 mouse in the guest OS. Most of my virtual machines are set that way, since I created them with previous versions of VirtualBox.

It may be less confusing to change the title of this bug report, or replace it with one that clearly defines the problem as "PS/2 mouse emulation without Guest Additions installed".

comment:6 follow-up: ↓ 7 Changed 5 years ago by michael

Interesting I remember seeing this years ago while installing certain OpenSUSE guest systems but never since. Can you provide us with a scenario to reproduce this using generally available software? I presume that your Windows PE environment is not something generally available (note: I am not a Windows specialist).

comment:7 in reply to: ↑ 6 Changed 5 years ago by ErikW

Replying to michael:

Interesting I remember seeing this years ago while installing certain OpenSUSE guest systems but never since. Can you provide us with a scenario to reproduce this using generally available software? I presume that your Windows PE environment is not something generally available (note: I am not a Windows specialist).

You can see the problem easily by installing either Windows 7 or Windows XP in in a Virtual Machine and not installing Guest Additions (or uninstalling Guest Additions). Then, set the "Pointing Device" to "PS/2 Mouse" in the System Settings for the VM. I saw the problem with the guest resolution set to 1024 x 768 and the host resolution set to 1680 x 1050. Other combinations of resolutions make the problem slightly better or worse.

I think that you will see the problem with other operating systems if you set the pointing device to a PS/2 mouse and then run the OS without Guest Additions Installed. I saw the problem that way on Linux and OS2.


Windows PE is actually a minimal installation of Windows (XP, Vista, 7, 8, etc.) designed to boot from a CD or other read-only volume. It uses a subset of drivers and services and minimal (or no) Windows desktop environment. A hard disk is not required for booting. Modified pages are not written to a page-file. The system runs from RAM or directly from the boot CD/DVD depending on how it was created. Microsoft uses that environment for Windows setup. That's what you see when you are installing Windows.

Microsoft provides tools for customizing the Windows PE (setup and installation) environment and creating boot discs. Their intention was that it be used for custom Windows deployment and installation. However, anyone with a licensed version of Windows can use their installation media to create a Windows PE boot disc. It is legal to do that if the boot disc is used on the same system where the Windows media is installed.

There are freeware tools such as Bart's PE Bilder or WinBuilder that allow a custom system to be created with extra drivers and programs plus more desktop features from Windows.

Many companies who sell rescue disks for their backup or partitioning utilities provide scripts to create a boot CD or DVD. In the past, they often provided the boot discs, but Microsoft changed the licensing so that users now have to build their own boot discs. I have found VirtualBox very useful for testing boot discs that I build and avoiding the delay of burning a CD and booting real hardware. Also, VirtualBox allows testing the backup, restore or partitioning software in a controlled environment. That is why I frequently boot host VMs containing Windows without Guest Additions installed.

I think you will see more companies using Windows PE because so many hardware vendors only provide Windows drivers and the Linux desktop environments are becoming more diverse. Also, there is the problem of accessing Microsoft's proprietary filesystems. Only Windows has fully function NTFS support, and newer Microsoft filesystems are only going to make the problem worse. However, Windows PE isn't perfect. Getting Volume Shadow Copy and access to the Boot Configuration Database to work with third party backup utilities and Windows PE can be difficult. Windows PE still remains primarily useful for installing Windows.

Sorry for the sermon. Mainly I wanted to point out why supporting Windows PE with or without Guest Additions might be advantageous. For all I know someone may have already written scripts for WinBuilder or Bart's PE Builder to install Guest Additions. I have never tried to create a Windows PE system with Guest Additions. In theory the drivers and services should work. The problem is copying the necessary files to the ISO image and creating the required registry entries for the Windows PE system.

comment:8 Changed 4 years ago by SuperHero

I have the same problem. But switching mouse mode to "USB tablet" didn't help. VB version - 5.0.3.

comment:9 Changed 11 months ago by Dsen

Is this still the issue with latest 5.2?

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use