VirtualBox

Ticket #13105 (closed defect: fixed)

Opened 3 years ago

Last modified 14 months ago

VirtualBox crash on bad sectors with rawvmdk

Reported by: Mr_KrzYch00 Owned by:
Priority: major Component: other
Version: VirtualBox 4.3.12 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

VirtualBox crashes when using rawdisk with bad sectors.

How to reproduce:

  1. Take some Hard Disk with unrecoverable bad sectors (in my case it was connected with USB->ATA adapter),
  2. Go to compmgmt.msc and make it offline (or diskpart) so windows won't try to access it while it's being mapped in VirtualBox. Also note down disk number,
  3. Run CMD as Admin and then run this command: VBoxManage internalcommands createrawvmdk -filename c:\rawdisk.vmdk -rawdisk \ \.\PhysicalDrive2 ,
  4. Run VirtualBox as Admin and add raw vmdk file as SATA 1 port,
  5. Run Virtual Machine (in my case it was CentOS 6.5 x86 and x64 minimal with Desktop group installed),
  6. Run terminal and then run this command: dd if=/dev/sdb conv=notrunc,noerror,sync | pv -cN RAW_HDD | lz4 -1 | pv -cN LZ4_IMAGE_FILE >image.img.lz4 ,
  7. VirtualBox Manager will display Windows' crash window when trying to read bad, unrecoverable sector. After closing it, running VirtualMachine(s?) window closes as well. Before closing it VirtualMachine(s?) is hanged.

What settings were used for my VM:
512MB and 3,5GB RAM (doesn't matter)
Enable I/O APIC turned ON
2 Threads shared
Both Virtualization accelerations ON
64MB display memory (no ACC)
IDE for CD and SATA for HDD storage with Cache turned OFF (Centos Image and rawdisk access VMDK there)
Extensions removed and USB controller turned OFF (did it just in case but still crashed)

Host running Windows 8.1 x64 standard edition for notebooks.

Expected results:

  • VirtualBox SHOULD NOT crash, it should pass bad sectors 1:1 to DD running in Linux Guest - if possible.
  • In worst case senario it should display some error message and let You safely close Virtual Machine (some exception in the code?).

Additional information:

  • This didn't happen when CentOS 6.5 32bit was running from pendrive (moved VM to pendrive) and HDD was connected to IDE/ATA port on desktop computer,
  • The disk was shared with similar command from /dev/sdb,
  • Hiren Boot CD was run in virualbox to access it and it performed defragmentation on whole HDD (22GB first partition, bad sectors are around ~7.38GB so it most likely damaged some data)
  • VirtualBox didn't crash on Linux (CentOS) Host and no errors were reported, though I'M NOT SURE if bad sectors were not actually marked as bad and skipped since it operated on File System, not RAW LBA layer.

HDD Raw Copy Tool 1.10 Disk Read Log to confirm damaged HDD (it didn't crash, nor did adapter, it could read correctly till the end sector just with 3 offset error messages):
2014-06-07 16:41:39 Locking device...
2014-06-07 16:41:39 Copying...
2014-06-07 16:45:54 Read Error occurred at offset 7,922,974,720; LBA 15,474,560 (Uncorrectable error)
2014-06-07 16:46:05 Read Error occurred at offset 7,927,169,024; LBA 15,482,752 (Uncorrectable error)
2014-06-07 16:46:16 Read Error occurred at offset 7,956,529,152; LBA 15,540,096 (Uncorrectable error)
2014-06-07 18:03:44 Average speed: 32,5 MB/s
2014-06-07 18:03:44 Task complete.

Error details:

Problem signature:

Problem Event Name: APPCRASH
Application Name: VirtualBox.exe
Application Version: 4.3.12.0
Application Timestamp: 5375fea0
Fault Module Name: VBoxDD.DLL
Fault Module Version: 0.0.0.0
Fault Module Timestamp: 5375fedb
Exception Code: 80000003
Exception Offset: 00000000000ba126
OS Version: 6.3.9600.2.0.0.768.101
Locale ID: 1045
Additional Information 1: d751
Additional Information 2: d751c23540855ee8a6f140c0aac1ee43
Additional Information 3: b74a
Additional Information 4: b74a7ae81f0afc902387134e3279c8f1

Attachments

VBox.log Download (51.2 KB) - added by mhanor 3 years ago.

Change History

comment:1 Changed 3 years ago by Mr_KrzYch00

Additional info:

Yes I can confirm it has marked 12KB as bad sectors when it was used in VBox with HirenBootCD guest and CentOS 6.5 host.

23157665 KB total disk space. 20404280 KB in 69898 files.

28924 KB in 8430 indexes.

12 KB in bad sectors.

267521 KB in use by the system.

65536 KB occupied by the log file.

2456928 KB available on disk.

comment:2 Changed 3 years ago by mhanor

I can reproduce the crash with Centos 6.5 x86 and Debian 7.5 x86. It crashes when dereferencing a pointer to a freed AHCIREQ data structure, in the ahciCancelActiveTasks() function. The pointer is present in the aCachedTasks array (the array is part of the AHCIPort structure).

This is how the stack looks like when it crashes (svn51648):

VBoxDD!ASMAtomicCmpXchgU32(unsigned int * pu32 = 0x00000000`25073f40, unsigned int u32New = 3, unsigned int u32Old = 2)+0x3a [c:\work_x64\vbox\include\iprt\asm.h @ 745]
VBoxDD!ahciCancelActiveTasks(struct AHCIPort * pAhciPort = 0x00000000`13d897f0, struct AHCIREQ * pAhciReqExcept = 0x00000000`1c9d2f40)+0xbe [c:\work_x64\vbox\src\vbox\devices\storage\devahci.cpp @ 5667]
VBoxDD!ahciProcessCmd(struct AHCIPort * pAhciPort = 0x00000000`13d897f0, struct AHCIREQ * pAhciReq = 0x00000000`1c9d2f40, unsigned char * pCmdFis = 0x00000000`1c9d2f74 "'???")+0xab4 [c:\work_x64\vbox\src\vbox\devices\storage\devahci.cpp @ 6382]
VBoxDD!ahciAsyncIOLoop(struct PDMDEVINS * pDevIns = 0x00000000`13d893e0, struct PDMTHREAD * pThread = 0x00000000`1f2d9f90)+0x848 [c:\work_x64\vbox\src\vbox\devices\storage\devahci.cpp @ 6691]
VBoxVMM!pdmR3ThreadMain(struct RTTHREADINT * Thread = 0x00000000`1f921730, void * pvUser = 0x00000000`1f2d9f90)+0x105 [c:\work_x64\vbox\src\vbox\vmm\vmmr3\pdmthread.cpp @ 779]
VBoxRT!rtThreadMain(struct RTTHREADINT * pThread = 0x00000000`1f921730, unsigned int64 NativeThread = 0x13c, char * pszThreadName = 0x00000000`1f921ff0 "Port0")+0xc2 [c:\work_x64\vbox\src\vbox\runtime\common\misc\thread.cpp @ 712]
VBoxRT!rtThreadNativeMain(void * pvArgs = 0x00000000`1f921730)+0xae [c:\work_x64\vbox\src\vbox\runtime\r3\win\thread-win.cpp @ 211]
MSVCR100!_callthreadstartex+0x17
MSVCR100!_threadstartex+0x7f
kernel32!BaseThreadInitThunk+0xd
ntdll!RtlUserThreadStart+0x1d

The AHCIREQ data structure (0x25073f40) got freed here:

MSVCR100!free
VBoxRT!RTMemFree+0x1c [c:\work_x64\vbox\src\vbox\runtime\r3\alloc.cpp @ 221]
VBoxDD!ahciProcessCmd+0xa9f [c:\work_x64\vbox\src\vbox\devices\storage\devahci.cpp @ 6382]
VBoxDD!ahciAsyncIOLoop+0x848 [c:\work_x64\vbox\src\vbox\devices\storage\devahci.cpp @ 6691]
VBoxVMM!pdmR3ThreadMain+0x105 [c:\work_x64\vbox\src\vbox\vmm\vmmr3\pdmthread.cpp @ 779]
VBoxRT!rtThreadMain+0x00000000000000c2
VBoxRT!rtThreadNativeMain+0x00000000000000ae
MSVCR100!_callthreadstartex+0x0000000000000017
MSVCR100!_threadstartex+0x000000000000007f
kernel32!BaseThreadInitThunk+0x000000000000000d
ntdll!RtlUserThreadStart+0x000000000000001d
Last edited 3 years ago by mhanor (previous) (diff)

comment:3 Changed 3 years ago by mhanor

Same issue: #11088

comment:4 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Hopefully fixed with VBox 4.3.16.

comment:5 Changed 3 years ago by mhanor

It's not fixed. The VM just exits, while the OS doesn't register a crash event.

comment:6 Changed 3 years ago by frank

  • Status changed from closed to reopened
  • Resolution fixed deleted

Please attach a new VBox.log file for such a VM session.

Changed 3 years ago by mhanor

comment:7 Changed 3 years ago by mhanor

The PC is low on RAM, but it's the only one that I can use to test the issue.

Crash stack for 4.3.16 x64 OSE, on the same PC:

VBoxDD!ASMAtomicCmpXchgU32(unsigned int * pu32 = 0x00000000`28720f40, unsigned int u32New = 3, unsigned int u32Old = 2)+0x3a [c:\work_x64\vbox\include\iprt\asm.h @ 749]
VBoxDD!ahciCancelActiveTasks(struct AHCIPort * pAhciPort = 0x00000000`188ba6d0, struct AHCIREQ * pAhciReqExcept = 0x00000000`28810f40)+0xde [c:\work_x64\vbox\src\vbox\devices\storage\devahci.cpp @ 5695]
VBoxDD!ahciProcessCmd(struct AHCIPort * pAhciPort = 0x00000000`188ba6d0, struct AHCIREQ * pAhciReq = 0x00000000`28810f40, unsigned char * pCmdFis = 0x00000000`28810f74 "'???")+0xabd [c:\work_x64\vbox\src\vbox\devices\storage\devahci.cpp @ 6419]
VBoxDD!ahciAsyncIOLoop(struct PDMDEVINS * pDevIns = 0x00000000`188b9f60, struct PDMTHREAD * pThread = 0x00000000`1f18ef90)+0x960 [c:\work_x64\vbox\src\vbox\devices\storage\devahci.cpp @ 6729]
VBoxVMM!pdmR3ThreadMain(struct RTTHREADINT * Thread = 0x00000000`1f580730, void * pvUser = 0x00000000`1f18ef90)+0x105 [c:\work_x64\vbox\src\vbox\vmm\vmmr3\pdmthread.cpp @ 779]
VBoxRT!rtThreadMain(struct RTTHREADINT * pThread = 0x00000000`1f580730, unsigned int64 NativeThread = 0xbc8, char * pszThreadName = 0x00000000`1f580ff0 "Port1")+0xc2 [c:\work_x64\vbox\src\vbox\runtime\common\misc\thread.cpp @ 712]
00000000`213df720 00000000`501d1d9f VBoxRT!rtThreadNativeMain(void * pvArgs = 0x00000000`1f580730)+0xae [c:\work_x64\vbox\src\vbox\runtime\r3\win\thread-win.cpp @ 211]
MSVCR100!_callthreadstartex+0x17
MSVCR100!_threadstartex+0x7f
KERNEL32!BaseThreadInitThunk+0xd
ntdll!RtlUserThreadStart+0x1d

The PAHCIREQ pointer (0x28720f40) has been freed here:

ntdll!RtlDebugFreeHeap+0x0000000000000034
ntdll!RtlpFreeHeap+0x000000000007908f
ntdll!RtlFreeHeap+0x0000000000000428
MSVCR100!free+0x000000000000001c
VBoxRT!RTMemFree+0x000000000000001c [c:\work_x64\vbox\src\vbox\runtime\r3\alloc.cpp @ 221]
VBoxDD!ahciProcessCmd+0x0000000000000aa8 [c:\work_x64\vbox\src\vbox\devices\storage\devahci.cpp @ 6419]
VBoxDD!ahciAsyncIOLoop+0x0000000000000960 [c:\work_x64\vbox\src\vbox\devices\storage\devahci.cpp @ 6729]
VBoxVMM!pdmR3ThreadMain+0x0000000000000105 [c:\work_x64\vbox\src\vbox\vmm\vmmr3\pdmthread.cpp @ 779]
VBoxRT!rtThreadMain+0x00000000000000c2 [c:\work_x64\vbox\src\vbox\runtime\common\misc\thread.cpp @ 712]
VBoxRT!rtThreadNativeMain+0x00000000000000ae [c:\work_x64\vbox\src\vbox\runtime\r3\win\thread-win.cpp @ 211]
MSVCR100!_callthreadstartex+0x0000000000000017
MSVCR100!_threadstartex+0x000000000000007f
KERNEL32!BaseThreadInitThunk+0x000000000000000d
ntdll!RtlUserThreadStart+0x000000000000001d

It's trying to dereference a freed pointer, if that wasn't clear.

Last edited 3 years ago by mhanor (previous) (diff)

comment:8 Changed 3 years ago by mhanor

I can reproduce the crash on my Ubuntu 14.04 x64 host, using VirtualBox 4.3.20, a live Lubuntu 14.04.1 x86 VM and a mapped device. Just run the commands below in a terminal. You'll need to logout after adding the user account to the disk group.

sudo usermod -a -G disk $USER
sudo dmsetup create bad_disk <<EOF
0 100000 zero
100000 1 error
100001 100000 zero
EOF
VBoxManage internalcommands createrawvmdk -filename bad_disk.vmdk -rawdisk /dev/mapper/bad_disk

Then create a Ubuntu x86 VM, add the bad_disk.vmdk to the SATA controller and mount the Lubuntu 14.04.1 ISO image, boot the live image, and run at the guest terminal:

sudo cat /dev/sda > /dev/null
Last edited 3 years ago by mhanor (previous) (diff)

comment:9 Changed 2 years ago by frank

This bug will be fixed in VBox 5.0.

comment:10 Changed 2 years ago by dgasaway

I believe this is the same issue reported in my bug. Glad to see a fix is coming. :) https://www.virtualbox.org/ticket/12572

comment:11 Changed 2 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Fix is part of VBox 5.0.

comment:12 Changed 14 months ago by Xeno

Somehow it is still not fixed (for OS X).

VM crashes on bad sector access in thread: AioMgr0 (somehow tries to free the wrong memory address?!)

Process:               VirtualBoxVM [2718]
Path:                  /Applications/VirtualBox.app/Contents/Resources/VirtualBoxVM.app/Contents/MacOS/VirtualBoxVM
Identifier:            org.virtualbox.app.VirtualBoxVM
Version:               5.1.6 (5.1.6)
Code Type:             X86-64 (Native)
Parent Process:        VBoxSVC [491]
Responsible:           VirtualBoxVM [2718]
User ID:               501

Date/Time:             2016-09-13 22:17:26.435 +0200
OS Version:            Mac OS X 10.12 (16A320)
Report Version:        12
Anonymous UUID:        C874521A-69D9-2B71-A6A9-1FFFBDCC168A


Time Awake Since Boot: 1500 seconds

System Integrity Protection: enabled

Crashed Thread:        23  AioMgr0-N

Exception Type:        EXC_CRASH (SIGABRT)
Exception Codes:       0x0000000000000000, 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

Application Specific Information:
abort() called
*** error for object 0x7f84fee06348: incorrect checksum for freed object - object was probably modified after being freed.
 

Thread 0:: Dispatch queue: com.apple.main-thread
0   libsystem_kernel.dylib        	0x00007fff8ecce41a mach_msg_trap + 10
1   libsystem_kernel.dylib        	0x00007fff8eccd867 mach_msg + 55
2   com.apple.CoreFoundation      	0x00007fff79b688d4 __CFRunLoopServiceMachPort + 212
3   com.apple.CoreFoundation      	0x00007fff79b67d61 __CFRunLoopRun + 1361
4   com.apple.CoreFoundation      	0x00007fff79b675b4 CFRunLoopRunSpecific + 420
5   com.apple.HIToolbox           	0x00007fff79108f6c RunCurrentEventLoopInMode + 240
6   com.apple.HIToolbox           	0x00007fff79108da1 ReceiveNextEventCommon + 432
7   com.apple.HIToolbox           	0x00007fff79108bd6 _BlockUntilNextEventMatchingListInModeWithFilter + 71
8   com.apple.AppKit              	0x00007fff777ff5f5 _DPSNextEvent + 1093
9   com.apple.AppKit              	0x00007fff77f0f8eb -[NSApplication(NSEvent) _nextEventMatchingEventMask:untilDate:inMode:dequeue:] + 1637
10  com.apple.AppKit              	0x00007fff777f3fbd -[NSApplication run] + 926
11  libqcocoa.dylib               	0x0000000110ad6e9d QCocoaEventDispatcher::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) + 2189
12  org.qt-project.QtCoreVBox     	0x000000010cce2f9d QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) + 381
13  org.qt-project.QtCoreVBox     	0x000000010cce5e7a QCoreApplication::exec() + 346
14  VirtualBox.dylib              	0x000000010c1f654a TrustedMain + 1290
15  org.virtualbox.app.VirtualBoxVM	0x000000010bd3ea88 0x10bd3b000 + 14984
16  libdyld.dylib                 	0x00007fff8eba7255 start + 1

...

Thread 23 Crashed:: AioMgr0-N
0   libsystem_kernel.dylib        	0x00007fff8ecd5dda __pthread_kill + 10
1   libsystem_pthread.dylib       	0x00007fff8edc0797 pthread_kill + 90
2   libsystem_c.dylib             	0x00007fff8ec3b440 abort + 129
3   libsystem_malloc.dylib        	0x00007fff8ed35fb1 szone_error + 626
4   libsystem_malloc.dylib        	0x00007fff8ed2bfbf tiny_free_list_remove_ptr + 292
5   libsystem_malloc.dylib        	0x00007fff8ed40963 tiny_free_no_lock + 1533
6   libsystem_malloc.dylib        	0x00007fff8ed410f3 free_tiny + 671
7   VBoxVMM.dylib                 	0x000000010decc0ee 0x10dd82000 + 1351918
8   VBoxRT.dylib                  	0x000000010be0c07c 0x10bd7c000 + 589948
9   VBoxRT.dylib                  	0x000000010be903d2 0x10bd7c000 + 1131474
10  libsystem_pthread.dylib       	0x00007fff8edbdabb _pthread_body + 180
11  libsystem_pthread.dylib       	0x00007fff8edbda07 _pthread_start + 286
12  libsystem_pthread.dylib       	0x00007fff8edbd231 thread_start + 13

Thread 24:: Port0
0   libsystem_kernel.dylib        	0x00007fff8ecd5686 __ioctl + 10
1   libsystem_kernel.dylib        	0x00007fff8ecd159f ioctl + 159
2   VBoxRT.dylib                  	0x000000010be9a58d 0x10bd7c000 + 1172877
3   VBoxRT.dylib                  	0x000000010be97967 SUPSemEventWaitNoResume + 135
4   VBoxDD.dylib                  	0x0000000139c8be71 0x139bbe000 + 843377
5   VBoxVMM.dylib                 	0x000000010dddddf3 0x10dd82000 + 376307
6   VBoxRT.dylib                  	0x000000010be0c07c 0x10bd7c000 + 589948
7   VBoxRT.dylib                  	0x000000010be903d2 0x10bd7c000 + 1131474
8   libsystem_pthread.dylib       	0x00007fff8edbdabb _pthread_body + 180
9   libsystem_pthread.dylib       	0x00007fff8edbda07 _pthread_start + 286
10  libsystem_pthread.dylib       	0x00007fff8edbd231 thread_start + 13

Thread 25:: HbdDA-Wrk
0   libsystem_kernel.dylib        	0x00007fff8ecce41a mach_msg_trap + 10
1   libsystem_kernel.dylib        	0x00007fff8eccd867 mach_msg + 55
2   com.apple.CoreFoundation      	0x00007fff79b688d4 __CFRunLoopServiceMachPort + 212
3   com.apple.CoreFoundation      	0x00007fff79b67d61 __CFRunLoopRun + 1361
4   com.apple.CoreFoundation      	0x00007fff79b675b4 CFRunLoopRunSpecific + 420
5   VBoxDD.dylib                  	0x0000000139ce54c5 0x139bbe000 + 1209541
6   VBoxRT.dylib                  	0x000000010be0c07c 0x10bd7c000 + 589948
7   VBoxRT.dylib                  	0x000000010be903d2 0x10bd7c000 + 1131474
8   libsystem_pthread.dylib       	0x00007fff8edbdabb _pthread_body + 180
9   libsystem_pthread.dylib       	0x00007fff8edbda07 _pthread_start + 286
10  libsystem_pthread.dylib       	0x00007fff8edbd231 thread_start + 13

Thread 26:: Port1
0   libsystem_kernel.dylib        	0x00007fff8ecd5686 __ioctl + 10
1   libsystem_kernel.dylib        	0x00007fff8ecd159f ioctl + 159
2   VBoxRT.dylib                  	0x000000010be9a58d 0x10bd7c000 + 1172877
3   VBoxRT.dylib                  	0x000000010be97967 SUPSemEventWaitNoResume + 135
4   VBoxDD.dylib                  	0x0000000139c8be71 0x139bbe000 + 843377
5   VBoxVMM.dylib                 	0x000000010dddddf3 0x10dd82000 + 376307
6   VBoxRT.dylib                  	0x000000010be0c07c 0x10bd7c000 + 589948
7   VBoxRT.dylib                  	0x000000010be903d2 0x10bd7c000 + 1131474
8   libsystem_pthread.dylib       	0x00007fff8edbdabb _pthread_body + 180
9   libsystem_pthread.dylib       	0x00007fff8edbda07 _pthread_start + 286
10  libsystem_pthread.dylib       	0x00007fff8edbd231 thread_start + 13

Thread 27:: ATA-0
0   libsystem_kernel.dylib        	0x00007fff8ecd5686 __ioctl + 10
1   libsystem_kernel.dylib        	0x00007fff8ecd159f ioctl + 159
2   VBoxRT.dylib                  	0x000000010be9a58d 0x10bd7c000 + 1172877
3   VBoxRT.dylib                  	0x000000010be97967 SUPSemEventWaitNoResume + 135
4   VBoxDD.dylib                  	0x0000000139be893a 0x139bbe000 + 174394
5   VBoxRT.dylib                  	0x000000010be0c07c 0x10bd7c000 + 589948
6   VBoxRT.dylib                  	0x000000010be903d2 0x10bd7c000 + 1131474
7   libsystem_pthread.dylib       	0x00007fff8edbdabb _pthread_body + 180
8   libsystem_pthread.dylib       	0x00007fff8edbda07 _pthread_start + 286
9   libsystem_pthread.dylib       	0x00007fff8edbd231 thread_start + 13

Thread 28:: ATA-1
0   libsystem_kernel.dylib        	0x00007fff8ecd5686 __ioctl + 10
1   libsystem_kernel.dylib        	0x00007fff8ecd159f ioctl + 159
2   VBoxRT.dylib                  	0x000000010be9a58d 0x10bd7c000 + 1172877
3   VBoxRT.dylib                  	0x000000010be97967 SUPSemEventWaitNoResume + 135
4   VBoxDD.dylib                  	0x0000000139be893a 0x139bbe000 + 174394
5   VBoxRT.dylib                  	0x000000010be0c07c 0x10bd7c000 + 589948
6   VBoxRT.dylib                  	0x000000010be903d2 0x10bd7c000 + 1131474
7   libsystem_pthread.dylib       	0x00007fff8edbdabb _pthread_body + 180
8   libsystem_pthread.dylib       	0x00007fff8edbda07 _pthread_start + 286
9   libsystem_pthread.dylib       	0x00007fff8edbd231 thread_start + 13

Thread 29:: NATRX
0   libsystem_kernel.dylib        	0x00007fff8ecd5c8a __psynch_cvwait + 10
1   libsystem_pthread.dylib       	0x00007fff8edbe97a _pthread_cond_wait + 712
2   VBoxRT.dylib                  	0x000000010be8e94b RTSemEventWait + 539
3   VBoxDD.dylib                  	0x0000000139cc7a6d 0x139bbe000 + 1088109
4   VBoxVMM.dylib                 	0x000000010dddddf3 0x10dd82000 + 376307
5   VBoxRT.dylib                  	0x000000010be0c07c 0x10bd7c000 + 589948
6   VBoxRT.dylib                  	0x000000010be903d2 0x10bd7c000 + 1131474
7   libsystem_pthread.dylib       	0x00007fff8edbdabb _pthread_body + 180
8   libsystem_pthread.dylib       	0x00007fff8edbda07 _pthread_start + 286
9   libsystem_pthread.dylib       	0x00007fff8edbd231 thread_start + 13

Thread 30:: NATURGRX
0   libsystem_kernel.dylib        	0x00007fff8ecd5c8a __psynch_cvwait + 10
1   libsystem_pthread.dylib       	0x00007fff8edbe97a _pthread_cond_wait + 712
2   VBoxRT.dylib                  	0x000000010be8e94b RTSemEventWait + 539
3   VBoxDD.dylib                  	0x0000000139cc7add 0x139bbe000 + 1088221
4   VBoxVMM.dylib                 	0x000000010dddddf3 0x10dd82000 + 376307
5   VBoxRT.dylib                  	0x000000010be0c07c 0x10bd7c000 + 589948
6   VBoxRT.dylib                  	0x000000010be903d2 0x10bd7c000 + 1131474
7   libsystem_pthread.dylib       	0x00007fff8edbdabb _pthread_body + 180
8   libsystem_pthread.dylib       	0x00007fff8edbda07 _pthread_start + 286
9   libsystem_pthread.dylib       	0x00007fff8edbd231 thread_start + 13

Thread 31:: HOSTRES
0   libsystem_kernel.dylib        	0x00007fff8ecd5c8a __psynch_cvwait + 10
1   libsystem_pthread.dylib       	0x00007fff8edbe97a _pthread_cond_wait + 712
2   VBoxRT.dylib                  	0x000000010be8e94b RTSemEventWait + 539
3   VBoxRT.dylib                  	0x000000010be09d52 RTReqQueueProcess + 146
4   VBoxDD.dylib                  	0x0000000139cc7b51 0x139bbe000 + 1088337
5   VBoxVMM.dylib                 	0x000000010dddddf3 0x10dd82000 + 376307
6   VBoxRT.dylib                  	0x000000010be0c07c 0x10bd7c000 + 589948
7   VBoxRT.dylib                  	0x000000010be903d2 0x10bd7c000 + 1131474
8   libsystem_pthread.dylib       	0x00007fff8edbdabb _pthread_body + 180
9   libsystem_pthread.dylib       	0x00007fff8edbda07 _pthread_start + 286
10  libsystem_pthread.dylib       	0x00007fff8edbd231 thread_start + 13

Thread 32:: NAT
0   libsystem_kernel.dylib        	0x00007fff8ecd7236 poll + 10
1   VBoxDD.dylib                  	0x0000000139cc7c94 0x139bbe000 + 1088660
2   VBoxVMM.dylib                 	0x000000010dddddf3 0x10dd82000 + 376307
3   VBoxRT.dylib                  	0x000000010be0c07c 0x10bd7c000 + 589948
4   VBoxRT.dylib                  	0x000000010be903d2 0x10bd7c000 + 1131474
5   libsystem_pthread.dylib       	0x00007fff8edbdabb _pthread_body + 180
6   libsystem_pthread.dylib       	0x00007fff8edbda07 _pthread_start + 286
7   libsystem_pthread.dylib       	0x00007fff8edbd231 thread_start + 13

Thread 33:: EhciFramer
0   libsystem_kernel.dylib        	0x00007fff8ecd5c8a __psynch_cvwait + 10
1   libsystem_pthread.dylib       	0x00007fff8edbe97a _pthread_cond_wait + 712
2   VBoxRT.dylib                  	0x000000010be8f461 0x10bd7c000 + 1127521
3   VBoxRT.dylib                  	0x000000010be8f1e3 0x10bd7c000 + 1126883
4   VBoxEhciR3.dylib              	0x000000013a4f34b1 VBoxDevicesRegister + 10609
5   VBoxVMM.dylib                 	0x000000010dddddf3 0x10dd82000 + 376307
6   VBoxRT.dylib                  	0x000000010be0c07c 0x10bd7c000 + 589948
7   VBoxRT.dylib                  	0x000000010be903d2 0x10bd7c000 + 1131474
8   libsystem_pthread.dylib       	0x00007fff8edbdabb _pthread_body + 180
9   libsystem_pthread.dylib       	0x00007fff8edbda07 _pthread_start + 286
10  libsystem_pthread.dylib       	0x00007fff8edbd231 thread_start + 13

Thread 34:: USBDevIo--1
0   libsystem_kernel.dylib        	0x00007fff8ecd5c8a __psynch_cvwait + 10
1   libsystem_pthread.dylib       	0x00007fff8edbe97a _pthread_cond_wait + 712
2   VBoxRT.dylib                  	0x000000010be8e94b RTSemEventWait + 539
3   VBoxDD.dylib                  	0x0000000139bc9d63 0x139bbe000 + 48483
4   VBoxDD.dylib                  	0x0000000139c65bcd 0x139bbe000 + 687053
5   VBoxDD.dylib                  	0x0000000139c62296 0x139bbe000 + 672406
6   VBoxRT.dylib                  	0x000000010be0c07c 0x10bd7c000 + 589948
7   VBoxRT.dylib                  	0x000000010be903d2 0x10bd7c000 + 1131474
8   libsystem_pthread.dylib       	0x00007fff8edbdabb _pthread_body + 180
9   libsystem_pthread.dylib       	0x00007fff8edbda07 _pthread_start + 286
10  libsystem_pthread.dylib       	0x00007fff8edbd231 thread_start + 13

Thread 35:: VUsbPeriodFrm
0   libsystem_kernel.dylib        	0x00007fff8ecd5c8a __psynch_cvwait + 10
1   libsystem_pthread.dylib       	0x00007fff8edbe97a _pthread_cond_wait + 712
2   VBoxRT.dylib                  	0x000000010be8f326 0x10bd7c000 + 1127206
3   VBoxDD.dylib                  	0x0000000139c5fcc3 0x139bbe000 + 662723
4   VBoxVMM.dylib                 	0x000000010dddddf3 0x10dd82000 + 376307
5   VBoxRT.dylib                  	0x000000010be0c07c 0x10bd7c000 + 589948
6   VBoxRT.dylib                  	0x000000010be903d2 0x10bd7c000 + 1131474
7   libsystem_pthread.dylib       	0x00007fff8edbdabb _pthread_body + 180
8   libsystem_pthread.dylib       	0x00007fff8edbda07 _pthread_start + 286
9   libsystem_pthread.dylib       	0x00007fff8edbd231 thread_start + 13

Thread 36:: nspr-3
0   libsystem_kernel.dylib        	0x00007fff8ecd5c8a __psynch_cvwait + 10
1   libsystem_pthread.dylib       	0x00007fff8edbe97a _pthread_cond_wait + 712
2   VBoxXPCOM.dylib               	0x000000010e07e5de PR_WaitCondVar + 254
3   VBoxXPCOM.dylib               	0x000000010e07ea8d PR_Wait + 61
4   VBoxXPCOMIPCC.dylib           	0x0000000110ca42c8 0x110c9a000 + 41672
5   VBoxXPCOM.dylib               	0x000000010e0542d9 0x10dff7000 + 381657
6   VBoxXPCOM.dylib               	0x000000010e080276 0x10dff7000 + 561782
7   VBoxRT.dylib                  	0x000000010be0c07c 0x10bd7c000 + 589948
8   VBoxRT.dylib                  	0x000000010be903d2 0x10bd7c000 + 1131474
9   libsystem_pthread.dylib       	0x00007fff8edbdabb _pthread_body + 180
10  libsystem_pthread.dylib       	0x00007fff8edbda07 _pthread_start + 286
11  libsystem_pthread.dylib       	0x00007fff8edbd231 thread_start + 13

Thread 37:: com.apple.audio.IOThread.client
0   libsystem_kernel.dylib        	0x00007fff8ecce41a mach_msg_trap + 10
1   libsystem_kernel.dylib        	0x00007fff8eccd867 mach_msg + 55
2   com.apple.audio.CoreAudio     	0x00007fff796f5f26 HALB_MachPort::SendMessageWithReply(unsigned int, unsigned int, unsigned int, unsigned int, mach_msg_header_t*, bool, unsigned int) + 122
3   com.apple.audio.CoreAudio     	0x00007fff796f5e9c HALB_MachPort::SendSimpleMessageWithSimpleReply(unsigned int, unsigned int, int, int&, bool, unsigned int) + 42
4   com.apple.audio.CoreAudio     	0x00007fff796f2cee HALC_ProxyIOContext::IOWorkLoop() + 1198
5   com.apple.audio.CoreAudio     	0x00007fff796f2667 HALC_ProxyIOContext::IOThreadEntry(void*) + 131
6   com.apple.audio.CoreAudio     	0x00007fff796f238b HALB_IOThread::Entry(void*) + 75
7   libsystem_pthread.dylib       	0x00007fff8edbdabb _pthread_body + 180
8   libsystem_pthread.dylib       	0x00007fff8edbda07 _pthread_start + 286
9   libsystem_pthread.dylib       	0x00007fff8edbd231 thread_start + 13

Thread 38:: AioMgr1-F
0   libsystem_kernel.dylib        	0x00007fff8ecd72de read + 10
1   VBoxRT.dylib                  	0x000000010be8846a RTFileRead + 58
2   VBoxVMM.dylib                 	0x000000010decbc1b 0x10dd82000 + 1350683
3   VBoxVMM.dylib                 	0x000000010decba1e 0x10dd82000 + 1350174
4   VBoxRT.dylib                  	0x000000010be0c07c 0x10bd7c000 + 589948
5   VBoxRT.dylib                  	0x000000010be903d2 0x10bd7c000 + 1131474
6   libsystem_pthread.dylib       	0x00007fff8edbdabb _pthread_body + 180
7   libsystem_pthread.dylib       	0x00007fff8edbda07 _pthread_start + 286
8   libsystem_pthread.dylib       	0x00007fff8edbd231 thread_start + 13

Thread 39:
0   libsystem_kernel.dylib        	0x00007fff8ecd64e6 __workq_kernreturn + 10
1   libsystem_pthread.dylib       	0x00007fff8edbd632 _pthread_wqthread + 1023
2   libsystem_pthread.dylib       	0x00007fff8edbd221 start_wqthread + 13

Thread 40:
0   libsystem_kernel.dylib        	0x00007fff8ecd64e6 __workq_kernreturn + 10
1   libsystem_pthread.dylib       	0x00007fff8edbd632 _pthread_wqthread + 1023
2   libsystem_pthread.dylib       	0x00007fff8edbd221 start_wqthread + 13

Thread 23 crashed with X86 Thread State (64-bit):
  rax: 0x0000000000000000  rbx: 0x0000000000000006  rcx: 0x0000700007200b08  rdx: 0x0000000000000000
  rdi: 0x0000000000011017  rsi: 0x0000000000000006  rbp: 0x0000700007200b30  rsp: 0x0000700007200b08
   r8: 0x00000000fffffff0   r9: 0x00007fff53ec4c20  r10: 0x0000000008000000  r11: 0x0000000000000206
  r12: 0x0000000000000001  r13: 0x000000010e1c9000  r14: 0x0000700007201000  r15: 0x000000010bd4b000
  rip: 0x00007fff8ecd5dda  rfl: 0x0000000000000206  cr2: 0x00007fffa0cea936
  
Logical CPU:     0
Error Code:      0x02000003
Trap Number:     133

...

External Modification Summary:
  Calls made by other processes targeting this process:
    task_for_pid: 1
    thread_create: 0
    thread_set_state: 0
  Calls made by this process:
    task_for_pid: 0
    thread_create: 0
    thread_set_state: 0
  Calls made by all processes on this machine:
    task_for_pid: 1322
    thread_create: 0
    thread_set_state: 0

VM Region Summary:
ReadOnly portion of Libraries: Total=313.0M resident=0K(0%) swapped_out_or_unallocated=313.0M(100%)
Writable regions: Total=1.4G written=0K(0%) resident=0K(0%) swapped_out=0K(0%) unallocated=1.4G(100%)
 
                                VIRTUAL   REGION 
REGION TYPE                        SIZE    COUNT (non-coalesced) 
===========                     =======  ======= 
Accelerate framework               768K        4 
Activity Tracing                   256K        2 
CG backing stores                 23.0M        6 
CG image                            28K        4 
CG raster data                     148K        3 
CoreUI image data                 1052K        9 
CoreUI image file                  156K        4 
Dispatch continuations            16.0M        2 
Image IO                           268K        4 
Kernel Alloc Once                    8K        2 
MALLOC                             1.3G      108 
MALLOC guard page                   48K       11 
Memory Tag 242                      12K        2 
STACK GUARD                       56.2M       42 
Stack                             24.9M       42 
VM_ALLOCATE                       37.1M      198 
__DATA                            32.2M      279 
__GLSLBUILTINS                    2588K        2 
__IMAGE                            528K        2 
__LINKEDIT                       118.7M       42 
__TEXT                           194.2M      272 
__UNICODE                          556K        2 
mapped file                      567.6M      166 
shared memory                     16.4M       12 
===========                     =======  ======= 
TOTAL                              2.3G     1196 


Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use