VirtualBox

Ticket #13073 (reopened defect)

Opened 4 years ago

Last modified 15 months ago

Video Captures are Blank / Green

Reported by: Hashpling Owned by:
Priority: major Component: other
Version: VirtualBox 4.3.12 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

When using the Video Capture in Vbox, nothing is recorded. There is only a "Green Screen".

Guest Additions are installed

libvpx is installed

This occurs with or without 3D Acceleration enabled.

Host: Ubuntu Gnome 14.04, Virtualbox 4.3.12 r93733 Guest: Lubuntu 14.04

Attachments

VBox.log Download (89.4 KB) - added by Hashpling 4 years ago.
Lubuntu 14.04.webm.tests.zip Download (7.5 KB) - added by Hashpling 4 years ago.
These are the "Green" Video Captures
vbox.log Download (2.1 KB) - added by LewisR 3 years ago.
VBox.2.log Download (80.6 KB) - added by Randi 3 years ago.
Log
FreeDOS.webm.gz Download (7.6 KB) - added by Randi 3 years ago.
Video
Screenshot from 2016-09-08 16-56-31.png Download (55.8 KB) - added by Waldyd 15 months ago.

Change History

Changed 4 years ago by Hashpling

Changed 4 years ago by Hashpling

These are the "Green" Video Captures

comment:1 Changed 4 years ago by tvjudge

I am running saucy and since the last updat I have same exact issue. I can add logs but they would be the same

comment:2 Changed 4 years ago by Hashpling

This also occurs in Fedora 20 w/GNOME Shell 3.10.4

comment:3 Changed 3 years ago by flip pipe

This is also happen to me (in Fedora).

And when I try to play the video in Videos (former totem) I get the message:

An error occurred
Could not demultiplex stream.

comment:4 Changed 3 years ago by nadrimajstor

Same issue here. :(

      Host: Ubuntu 14.04.1 LTS x86_64
VirtualBox: 4.3.14r95030
   Desktop: MATE 1.8.1
     Guest: ubuntu-mate-14.10
    libvpx: 1.3.0-2

comment:5 Changed 3 years ago by HannaH

Host: Ubuntu 14.04 VirtualBox: 4.3.14r95030 Guest Xubuntu 14.04

Video Capture gives only a Green screen, and that's a pity.

comment:6 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Hopefully fixed with VBox 4.3.16.

comment:7 Changed 3 years ago by Slonny

VirtualBox 4.3.18 r96516 Guest OS: Windows Xp Host OS: Linux Mint 3.13.0-24-generic #46-Ubuntu SMP Thu Apr 10 19:11:08 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

Totem video player message: Could not demultiplex stream. At VLC 2.1.4, Chrome 38.0.2125.104 (64-bit), Firefox 33.0 green rectangle.

comment:8 Changed 3 years ago by LewisR

Seeing a similar issue here, under openSuSE 13.1 x64 / VirtualBox 4.3.18 r96516.

Trying to capture an eComStation 2.1 guest, I get a small .webm file, which displays blank (green), yet lists the correct timecodes (Firefox 33.0).

System has:

Information for package libvpx1:
--------------------------------
Repository: Packman Repository
Name: libvpx1
Version: 1.3.0-51.1
Arch: x86_64
Vendor: http://packman.links2linux.de
Installed: Yes
Status: up-to-date
Installed Size: 1.7 MiB
Summary: VP8 codec library

vbox.log snippet, attached.

Changed 3 years ago by LewisR

comment:9 Changed 3 years ago by brunofin

I am running VirtualBox 4.3.20 r96996 on Linux Mint 17.1 Cinnamon 64-bits, this problem still persists. Is there any extra info I can provide from my system to help close this ticket?

comment:10 Changed 3 years ago by brunofin

  • Status changed from closed to reopened
  • Resolution fixed deleted

Changed 3 years ago by Randi

Log

Changed 3 years ago by Randi

Video

comment:11 Changed 3 years ago by Randi

Sorry, my english isn't good =(

I'am running VirtualBox 4.3.20 r96996 too. Host: Linux Fedora 19 Kernel 3.14.27-100.fc19.i686 32Bit Guest: FreeDOS This problem still persists.

comment:12 Changed 3 years ago by redaMakhchan

Same issue ubuntu14.04 with virtualBox 4.3

comment:13 Changed 3 years ago by _madworm_

Same thing here.

Host:

  • openSUSE 13.1 [3.11.10-25]
  • x11-video-nvidiaG04-346.35-4.1.x86_64
  • VirtualBox-4.3-4.3.24_98716_openSUSE123-1.x86_64

Guest: openSUSE 13.2

comment:14 Changed 3 years ago by brunofin

Still happens with the new version 4.3.24 r98716 with VirtualBox Extension Pack installed, on the same system as my previous comment.

comment:15 Changed 3 years ago by BastardSysop

Same issue, using latest opensuse version from virtualbox.org with extensions.

  • Opensuse Tumbleweed
  • Virtualbox 4.3.26_98988_openSUSE123-1
  • Native Intel driver xorg-x11-driver-video 7.6_1-15.1

Had this same issue on Ubuntu 15.04 using native drivers and the oracle virtualbox with extensions.

comment:16 Changed 3 years ago by jgrocha

Same here.

  • Virtualbox 4.3.26 r98988
  • Virtualbox 4.3.28 r100309
  • Host: Ubuntu 14.04.2 LTS
  • Guest: Ubuntu 14.04.2 LTS

Tested with both intel and nvidia drivers.

Last edited 3 years ago by jgrocha (previous) (diff)

comment:17 Changed 3 years ago by _madworm_

The issue seems to be caused by a libvpx incompatibility, at least on openSUSE 13.1.

 https://forums.opensuse.org/showthread.php/496523-Virtualbox-video-capture-not-working?p=2641225#post2641225

comment:18 Changed 2 years ago by JavaGcclinux

Hello,

I am using Ubuntu 14.04 and having the same issue but not seen any resolution anywhere.

comment:19 Changed 15 months ago by Waldyd

Hello,

same problem with totem on fedora 23. (mplayer works just find).

Changed 15 months ago by Waldyd

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use