VirtualBox

Ticket #12838 (closed enhancement: duplicate)

Opened 9 years ago

Last modified 6 years ago

Add checks for zero-size VirtualBox.xml and VM.vbox -> duplicate of #10851

Reported by: socratis Owned by:
Component: GUI Version:
Keywords: Cc:
Guest type: other Host type: other

Description

There are several cases where either by accident or by error one of the VirtualBox.xml or VM.vbox becomes corrupted, usually at 0 bytes. Since there is a .xml-prev and a .vbox-prev, should a suggestion to restore the previous versions be added?

  • Check if the file in question size is zero.
  • Check if file-prev exists (and passes some checks?).
  • Inform the user and suggest to restore the previous version.

Change History

comment:1 Changed 6 years ago by michael

  • Status changed from new to closed
  • Resolution set to duplicate
  • Summary changed from Add checks for zero-size VirtualBox.xml and VM.vbox to Add checks for zero-size VirtualBox.xml and VM.vbox -> duplicate of #10851

Duplicate of #10851.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use