VirtualBox

Ticket #12782 (closed defect: fixed)

Opened 18 months ago

Last modified 17 months ago

After upgrading to 4.3.8, missing environment for command prompt started using vboxmanage guestcontrol exec command

Reported by: smokey Owned by:
Priority: major Component: guest control
Version: VirtualBox 4.3.8 Keywords: guestcontrol exec environment
Cc: Guest type: Windows
Host type: Windows

Description

I am running a VM with Windows 7 x32 as the guest OS and Windows 7 x64 as the host OS.

I execute the following command to start a command prompt in the VM:

vboxmanage guestcontrol "Win 7 - 32" exec --verbose --image cmd.exe --username user --password password --wait-stdout --wait-stderr -- "/C start cmd"

The command completes successfully and the prompt is started. But, the environment setup for the command prompt is incorrect. It does not contain anywhere close to all the defined variables that should be present.

Following is the output when a "set" command is run in the prompt:


C:\Windows\system32>set
COMSPEC=C:\Windows\system32\cmd.exe
PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.JS;.WS;.MSC
PROMPT=$P$G

C:\Windows\system32>


This issue was not present when I was running 4.3.6 (VirtualBox and Guest Additions). I started seeing this problem only after upgrading to 4.3.8.

I run a automated build environment in the VM and having the right environment set is important for the build to succeed.

As there is no crash I have not included any log files. If they are needed I can upload them.

Any/all help will be appreciated.

Change History

comment:1 Changed 18 months ago by frank

Already reported elsewhere and fixed. Here is a test build of the fixed Additions. Please confirm the fix.

comment:2 Changed 18 months ago by smokey

Thanks, tried the fixed version and works perfectly! Sorry for reporting a duplicate, did not find the original when I searched. Do you have an ETA on the release?

comment:3 Changed 17 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 4.3.10.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use