VirtualBox

Ticket #12734 (closed defect: fixed)

Opened 13 months ago

Last modified 12 months ago

4.3.8: VERR_CPUM_TOO_MANY_CPUID_SUBLEAVES when launching VM [FIXED in SVN]

Reported by: mmcginnis Owned by:
Priority: major Component: other
Version: VirtualBox 4.3.8 Keywords: Too many cpuid subleaves
Cc: Guest type: Windows
Host type: Windows

Description

I just installed VirtualBox on a Lenovo T410 with Hyper-V enabled. Upon launching a VM I get the lowwing error: Failed to open a session for the virtual machine XP Virtual.

Couldn't find the end of CPUID sub-leaves. (VERR_CPUM_TOO_MANY_CPUID_SUBLEAVES).

Result Code: E_FAIL (0x80004005) Component: Console Interface: IConsole {8ab7c520-2442-4b66-8d74-4ff1e195d2b6}

Attachments

VBox.log Download (39.5 KB) - added by mmcginnis 13 months ago.
log file
VBox.2.log Download (36.6 KB) - added by dhognert 13 months ago.
VBox.log

Change History

Changed 13 months ago by mmcginnis

log file

comment:1 Changed 13 months ago by dhognert

Same issue here. Lenovo T430S running Windows 8.

Changed 13 months ago by dhognert

VBox.log

comment:2 Changed 13 months ago by bird

  • Summary changed from When launching a VM on Win 8.1 64bit, I get the error VERR_CPUM_TOO_MANY_CPUID_SUBLEAVES to 4.3.8: VERR_CPUM_TOO_MANY_CPUID_SUBLEAVES when launching VM [FIXED in SVN]

Thanks to your reports we've been able to come up with a workaround to deal with this unspecified CPUID behavior. We'll try get the fix out ASAP.

comment:3 Changed 13 months ago by mmcginnis

I found another fix for me. My laptop had Hyper-V enabled in the BIOS (I am unable to disable it due to corporate limitations). I found that doing the following and rebooting my laptop allows the VM's to run:

Hope this helps....

  1. Open Hyper-V manager and "stop service" on the right panel,
  1. Start a command prompt with administrator rights and execute the following command:

to disable hyper-v bcdedit /set hypervisorlaunchtype off

to enable hyper-v bcdedit /set hypervisorlaunchtype auto

  1. Both Operations require restarting your computer.

Reference:  https://forums.virtualbox.org/viewtopic.php?f=6&t=41258#p236620

comment:4 Changed 13 months ago by frank

Please could you confirm that this build fixes your problem?

comment:5 Changed 13 months ago by tucaz

I had the same problem and can confirm that the build 4.3.9-92650 fixed the problem.

comment:6 Changed 13 months ago by pcaenaro

I am running build 4.3.8 r92456, but the update says I am running the latest version. I have the same problem as reported here, how to I get the latest build?

comment:7 Changed 13 months ago by frank

4.3.8 is the latest released build. If you want to test the test build, see comment 4.

comment:8 Changed 13 months ago by bambitlaw

Just confirming, I had the same issue and build 4.3.9-92650 fixed it. Lenov idea pad, windows 8.1 64bit

comment:9 Changed 12 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 4.3.10.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use