VirtualBox

Ticket #12666 (closed defect: fixed)

Opened 16 months ago

Last modified 15 months ago

Video Capture with 3D acceleration enabled with Debian "Jessie" fails after gdm3 start => Fixed in SVN

Reported by: imr Owned by:
Priority: trivial Component: 3D support
Version: VirtualBox 4.3.6 Keywords: 3D acceleration, debian, video capture
Cc: Guest type: Linux
Host type: Windows

Description

Host: Windows 7 / 6.1.7601 Service Pack 1 Build 7601 Guest: Debian GNU/Linux testing (Jessie) Guest Kernel: 3.12-1-amd64 #1 SMP Debian 3.12.6-2 (2013-12-29) x86_64 GNU/Linux

When 3D acceleration is enabled, video capture for guest Debian Jessie works only in the console mode. When GDM3 starts, the video goes black. I did disabled the 3D acceleration and tested again - everything worked fine this time. I've also tested this with Mint and Kali Linux with 3D acceleration enabled but there was no issue with those guests.

Logs from 3D enabled and disabled modes are attached.

I'm marking this as trivial since it involves Debian 'testing' version and most probably won't affect many users.

Attachments

3dEnabled.log Download (105.0 KB) - added by imr 16 months ago.
3D Enabled / Debian testing (Jessie)
3ddisabled.log Download (91.4 KB) - added by imr 16 months ago.
3D Disabled / Debian testing (Jessie)

Change History

Changed 16 months ago by imr

3D Enabled / Debian testing (Jessie)

Changed 16 months ago by imr

3D Disabled / Debian testing (Jessie)

comment:1 follow-up: ↓ 2 Changed 16 months ago by frank

This was a general problem: 3D content was not added to the captured content. We think we fixed the problem. Please could you test this package if screen capturing works for you for 3D content? Thank you!

comment:2 in reply to: ↑ 1 Changed 16 months ago by imr

Replying to frank:

This was a general problem: 3D content was not added to the captured content. We think we fixed the problem. Please could you test this package if screen capturing works for you for 3D content? Thank you!

Hello Frank,

Thank you very much for your reply. I can confirm that the bug has been fixed. Video capture works fine with version 4.3.7-92034.

comment:3 Changed 16 months ago by frank

  • Summary changed from Video Capture with 3D acceleration enabled with Debian "Jessie" fails after gdm3 start to Video Capture with 3D acceleration enabled with Debian "Jessie" fails after gdm3 start => Fixed in SVN

Thanks for the feedback!

comment:4 Changed 15 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 4.3.8.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use