VirtualBox

Ticket #1266 (reopened defect)

Opened 6 years ago

Last modified 6 years ago

Slow response while in seamless or fullscreen mode

Reported by: megaloman Owned by:
Priority: major Component: GUI/seamless
Version: VirtualBox 1.5.6 Keywords:
Cc: Guest type: other
Host type: other

Description

Fedora 8 with Desktop Effects enabled (Compiz):

when virtual machine is in seamless or fullscreen mode, it has slow response to mouse clicks - when I click, it takes around second to take action. while I am working in windowed mode, it doesn't happen.

my laptop is Core 2 Duo 2.2 GHz, 2GB RAM with Nvidia graphics card

Change History

comment:1 Changed 6 years ago by Tainted

I am getting this problem also!!! Running Vista or XP as guest.

Running the following FC8 - full update Compiz-Fusion Core2Duo Q6600 @ 3.6ghz 4gb 1066mhz ram. Nvidia 8800GTS INTEL-VT enabled

When it's a window it feels almost native. Very anoying and looking at other options if this cant come right.

comment:2 Changed 6 years ago by iscrow

Indeed. Exactly the same issue here. I have a ThinkPad T Series T61 (64607EU) Intel Core 2 Duo T7300(2.00GHz) NVIDIA Quadro NVS 140M. Intel VT enabled. The mouse movement is not a problem. The VM sees the mouse moving with no delay. Clicks however take a while to register. This only occurs in fullscreen mode. I don't have this problem in windowed mode (normal or maximized). I don't have the problem in seamless mode either.

comment:3 Changed 6 years ago by jesse_kahtava

Enabling "Unredirect Fullscreen Windows" should do the trick.

In Compiz Config Settings:

General Options --> Unredirect Fullscreen Windows

If you don't have Compiz Config (ONLY if you don't) then use gconf-editor:

apps --> compiz --> screen0 --> options --> Select unredirect_fullscreen_windows

comment:4 Changed 6 years ago by megaloman

unfortunately it didn't help :(

comment:5 Changed 6 years ago by megaloman

it's funny actually

I had this option set by default and it didn't work. when I unselected box - it didn't work either, so I wrote "unfortunately it didn't help" - but when I select this box again, it does help :)

comment:6 Changed 6 years ago by megaloman

but now I do have a black screen for a couple of microseconds while rotating my screen (when I am entering a vm or leaving it)...

comment:7 Changed 6 years ago by jesse_kahtava

Yeah I have that as well, but I wouldn't consider it a problem. The quick flicker causes no performance or usability issue.

comment:8 Changed 6 years ago by umoeller

  • Status changed from new to closed
  • Resolution set to worksforme

From the comments I gather that the problem has been resolved. If not, please reopen!

comment:9 Changed 6 years ago by megaloman

  • Status changed from closed to reopened
  • Resolution worksforme deleted

I don't think the problem is solved.

I have an option "Unredirect Fullscreen Windows" enabled by default in my compiz settings.

When I start VirtualBox - problem still exists, noticeable delay in vm response while in fullscreen or seamless mode.

Now, when I disable and enable this option again, I get 50% chance, that it will work fine. Randomly it works, but usually it does not help :-/

comment:10 Changed 6 years ago by greggh

I also have this problem as and I am running VirtualBox 1.6.2 and Suse10.3 with a XP guest. (2.6.22.5-31-bigsmp #1 SMP 2007/09/21 22:29:00 UTC i686 i686 i386 GNU/Linux).

I have "Unredirect Fullscreen Windows" enabled, and it makes no difference.

comment:11 Changed 6 years ago by brianmiller

I had the exact same issue. I was able to correct it by disabling "Windows shadowing" under the Decorator settings in CCSM (With Compiz enabled).

instead of "any" for the allowed windows to be shadowed use "!any".

-Brian

comment:12 Changed 6 years ago by alvarezp

It also happens to me, however, it does even in Windowed mode. It happens also when releasing a drag on some place, and the system actually dropping it on another.

comment:13 Changed 6 years ago by frank

  • Component changed from other to GUI/seamless
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use