VirtualBox

Ticket #12657 (closed defect: fixed)

Opened 18 months ago

Last modified 17 months ago

ERROR_SUCCESS when importing OVA => Fixed in SVN

Reported by: WarpinWolf Owned by:
Priority: major Component: OVF
Version: VirtualBox 4.3.6 Keywords: OVA ERROR_SUCCESS
Cc: Guest type: other
Host type: other

Description

When importing a certain OVA file into VirtualBox

  • the software reports: ERROR_SUCCESS
  • the disk image is not extracted/created
  • the virtual machine definition is not created

This is reproducible with this image:  https://www.dropbox.com/s/ns3n47gewrbnhzy/Piratenverwaltung%200.9.3.ova

It has been discussed in the forum here:  https://forums.virtualbox.org/viewtopic.php?f=1&t=59858

The file CAN be untared and the resulting VDMK image CAN be used - so it is not a case of data corruption.

The assumption is that the EXPORT procedure stores the image size in a 32 bit field as UNSINGED INT and that the IMPORT procedure interprets this as a SIGNED INT - the size of the image being 2,345,184,768 bytes.

-> check/fix import bug (alternatively export procedure) -> fix error message - ERROR_SUCCESS is really strange...

Ticket 12345 seems to be unrelated to me. All other open OVF tickets seem to be unrelated to me.

Thanks Wolf

Change History

comment:1 Changed 18 months ago by frank

  • Summary changed from ERROR_SUCCESS when importing OVA to ERROR_SUCCESS when importing OVA => Fixed in SVN

Actually the problem is that the "VBox OS Type" in that appliance is set to "Mageia" which isn't a valid VBox OS type. The next VBox maintenance release will provide the correct error message in that case.

To be able to import this appliance, use a hex editor and replace 'Mageia' by 'Linux'.

comment:2 Changed 17 months ago by frank

Could you test  VBox 4.3.8 RC1?

comment:3 Changed 17 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 4.3.8.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use