VirtualBox

Ticket #12647 (closed defect: obsolete)

Opened 5 years ago

Last modified 3 years ago

[3D acceleration] Elasto Mania (video game) virtualization slowness

Reported by: twipley Owned by:
Component: other Version: VirtualBox 4.3.6
Keywords: Cc:
Guest type: Windows Host type: Linux

Description

Host: Ubuntu; guest: XP.

Experimental 3D-acceleration drivers have been installed, and then set to "enabled" in the VirtualBox machine video settings. The game (demo version, from  http://www.elastomania.com/elma.exe) has been installed on a fresh system install.

As is the case with native XP machines, there is some frame choppiness present. In other words, things are not as smooth as they should be, and some frames are (as a rule) dropped here and there. Virtualization, therefore, is representative of the original experience in this regard.

The problem lies in the experience produced using the "unsmoothness" fix, which works wonders in native XPs. This fix (links are provided in the next paragraph) can be applied by running the ElmaXP exefile from the game folder. It works, the author said (although he said no more than that), by "tuning the system timer on game start, then tuning it back to its normal state on game-process close."

 http://nh.gorodok.net/ElmaXP.zip (elmaxp file inside);  http://zworqy.com/elmaguide/files/ElmaXP.zip (elmaxp file inside);  http://kopasite.net/up/0/ElmaXP.exe.txt (remove the .txt extension).

The problem is this: using the fix (so the game can run smoothly on post-98 systems), makes it run in slow motion (the speed of the timer, for example, is more than halved).

To recapitulate, without ElmaXP.exe under virtualization, there is choppiness (therefore, same behavior as before). However, with ElmaXP.exe under virtualization, the game is significantly slowed down (unexpected behavior).

How come? (I am curious.)

Notes:

I have tried various vboxmanage commands, such as: VBoxManage setextradata "VM name" "VBoxInternal/TM/TSCTiedToExecution" 1 (did not change anything); VBoxManage setextradata "VM name" "VBoxInternal/TM/WarpDrivePercentage" 200 (sped up elma.exe, as expected, although did not change much of the slowness of the good [smooth] version, being elmaxp.exe); VBoxManage setextradata "VM name" "VBoxInternal/Devices/VMMDev/0/Config/GetHostTimeDisabled" (did not change anything either).

Disabling vertical synchronization did not solve the issue (nor did it change anything).

Attachments

VBox.log Download (112.6 KB) - added by twipley 5 years ago.
VBox.2.log Download (95.8 KB) - added by twipley 5 years ago.

Change History

Changed 5 years ago by twipley

Changed 5 years ago by twipley

comment:1 Changed 5 years ago by twipley

The right log file is the second one.

comment:2 Changed 5 years ago by twipley

The issue is present either (host-side) using the default xserver-xorg-video-nouveau, or the nvidia-319-recommended, driver (and restarting the host after the change, as it is needed to take effect).

comment:3 Changed 3 years ago by aeichner

  • Status changed from new to closed
  • Resolution set to obsolete

Please reopen if still relevant with a recent VirtualBox release.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use