VirtualBox

Ticket #12624 (closed defect: duplicate)

Opened 15 months ago

Last modified 15 months ago

HGCM VERR_INVALID_PARAMETER if you try to start a VM with saved state, where the temporary shared folder was added.

Reported by: Steph Owned by:
Priority: major Component: shared folders
Version: VirtualBox 4.3.6 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

My host is Windows Vista 32 bit and the guest it Windows XP 32 bit, but I don’t think that this is important in this case. I describe the steps to reproduce the issue.

1) I have a Windows XP VM, with no shared folders at all, and one snapshot. This VM wasn’t shut down previously, the state was saved. I don’t know if this may be important, so I simply mention it.

2) In the VM I add a temporary shared folder to existing folder in the host. After using this share over the Windows network in Explorer, I later turn the VM off by saving the state once again. I don’t remove the temporary shared folder from VM manually, and this is the point, which triggers all following events.

3) If I try to start this VM later, it restores the state till the 100% and quits with following error message: HGCM VERR_INVALID_PARAMETER Also see the log file. The folder is still here on the host.

If you look in the properties of the VM at this moment, you can see that the shared folder is still here, but any attempt to change or delete it ends with an error message. If you look at the XML file of the VM, you will see that there are no shared folders in it, neither in the machine nor in the snapshot section. This is probably a source of the issue: the VM file has no shared folders in it, but the saved state does.

My steps to repair the state, because I don’t like to drop the saved state and goes to the snapshot every time this happens.

1) Of course you shouldn’t forget to manually remove the temporary shared folder from VM before saving the state. I don’t think that this can happens with permanent one.

2) If you already forgot to remove the folder and see the error message, but also don’t like to drop the current state, then do what I do in this case. Turn the VB of and open the XML of this VM, find the shared folders of the machine itself, not from any of snapshots. Add the shared folder entry for the missing share here, like this for example:

from

<SharedFolders/>

to

<SharedFolders>
    <SharedFolder name="xxx" hostPath="/data/xxx" writable="true"/>
</SharedFolders>

then start VB and start the VM. You can only remove the share from the started VM, not from the properties of the suspended one.

I think that this issue came with 4.3.x, because I done this before, I mean closing the VM with newly added shared folder by saving its state, and it wasn’t a problem before.

The #2583 looks kind of similar, but isn’t exactly the same.

Attachments

VBox.log Download (73.6 KB) - added by Steph 15 months ago.
log with error messages during the issue

Change History

Changed 15 months ago by Steph

log with error messages during the issue

comment:1 Changed 15 months ago by Steph

Also the #6314 looks very similar, but in my case the physical folder in the host is still there, it wasn’t deleted or moved or renamed. There were no changes on it. Looks like the only source of the problems in my case is a difference between the saved state and VM file information.

comment:2 Changed 15 months ago by sunlover

  • Status changed from new to closed
  • Resolution set to duplicate
  • Component changed from other to shared folders

Thanks for the report. This is actually a known bug and it will be fixed in the next VBox release. See #12578 (comment 6) for a link to a VBox build with the fix.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use