VirtualBox

Ticket #12613 (closed enhancement: fixed)

Opened 4 years ago

Last modified 3 years ago

segfault in VBoxDDU.so if a registered virtual drive is on an unmounted host-device => fixed in SVN

Reported by: iber Owned by:
Priority: major Component: VM control
Version: VirtualBox 4.3.6 Keywords: segfault VBoxDDU
Cc: Guest type: Linux
Host type: Linux

Description

i have a diskimage on a partition which is not automaticly mounted.

running VirtuaBox results in

2014-01-14T22:42:49.543157+01:00 server kernel: [ 6436.857488] nspr-5[3407]: segfault at 0 ip 00007f9c96f19674 sp 00007f9c915ff3b0 error 4 in VBoxDDU.so[7f9c96efc000+56000]

the same issue in version 4.2.18 (opensuse 13.1) and 4.2.20 (community repo)

this looks like an unchecked null-pointer. at least a warning about wrong path or missing image file would be nice

i can try to write a patch if the source-code is available.

mounting the missing device and restarting VirtualBox works.

i.b.

Change History

comment:1 Changed 4 years ago by frank

The source code is freely available (see here) but for now it would be sufficient if you could provide a few more information. Because we cannot reproduce your problem. According to your description it should be sufficient to take a valid VM configuration and change the path of a virtual disk image to a non-existent path. This doesn't work -- I get a proper error message that the image cannot be found.

Please also attach the VM config file as well as the global ~/.VirtualBox/VirtualBox.xml file.

comment:2 Changed 4 years ago by mma

Just has happend the same to me... few days ago I renamed a folder where I stored disk image for one of the VMs and then cannot understand why I see very strange VirtualBox behaviour. The about box in the GUI shows release r0, I see following message, but there is no hint about the virtual disk cannot be mounted. When realized that the folder was renamed I fixed the disk path in the VMs vbox file and everything is OK again.

kernel: nspr-2[11521]: segfault at 0 ip 00007f3c97b87424 sp 00007f3c93c1a4f0 error 4 in VBoxDDU.so[7f3c97b68000+56000]

Not sure if that matters, the missing disk image is in QED format, VirtualBox 4.3.12_OSE r93733.

comment:3 Changed 4 years ago by frank

Sorry but you still did not provide the information I requested in my last comment. As you are running VBox OSE it might also help if you install the debug symbols for your VBox build and provide the backtrace corresponding to the core dump.

comment:4 Changed 4 years ago by aeichner

  • Summary changed from segfault in VBoxDDU.so if a registered virtual drive is on an unmounted host-device to segfault in VBoxDDU.so if a registered virtual drive is on an unmounted host-device => fixed in SVN

Thanks for the report, I was able to reproduce the issue. It should be fixed in the next maintenance release.

comment:5 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 4.3.14.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use