Ticket #12577 (closed defect: fixed)

Opened 23 months ago

Last modified 21 months ago

ESXi no longer installs with 4.3, worked fine with 4.2

Reported by: jarwin-dosling Owned by:
Priority: major Component: other
Version: VirtualBox 4.3.6 Keywords: ESXi no longer installs
Cc: Guest type: other
Host type: other


VirtualBox 4.3 no longer installs VMware ESXi as a guest OS. However this works wine with 4.2 I tried this in 2 OS's - in both Windows 7 running VirtualBox and Linux Mint running VirtualBox. I just downgraded Mint from 4.3 to 4.2 and now it installs. I did not try Windows 7 running 4.2, just know that 4.3 doesn't work. If you want to try it yourself, you can easily obtain the ESXi image from here: or also from VMware itself since it is free.

Please note: when you first try it, it looks like it works, for the first minute or so. But then it goes to a BLACK SCREEN where you cannot see anything the installer is doing. If I run VirtualBox 4.2, there is no problems, but running VirtualBox 4.3 then the ESXi install leads to a BLACK SCREEN during the install where you cannot see anything going on. This behavior is both in Windows 7 and Linux Mint hosts OS's.

I customized the following settings after googling many sites and watching YouTube videos or people getting ESXi to run in VirtualBox 4.2: Selected Linux OS (In 4.2 there is only one "LInux other" choice, in 4.3 there is a 32-bit and 64-bit inux other choice, tried them both, no luck). Also increased processors to 2, made sure there was at least 2 gigs of RAM (I used 4 gigs or RAM), and I increased video memory to 128. Also in 4.2 had to enable IO APIC but pretty sure that was default in 4.3, and I changed the NIC to Intel PRO/1000 MT Server, which multiple sources said was needed for ESXi to recognize the NIC.

In 4.2 I can install VMWare ESXi 5.1 as a guest OS it works. But in 4.3.6 neither works. Please kindly look into this issue, this is definitely a bug.


VBox.log Download (53.9 KB) - added by jarwin-dosling 23 months ago.

Change History

comment:1 Changed 23 months ago by frank

I miss a VBox.log file of such a VM session.

comment:2 Changed 23 months ago by frank

And it could also make sense to install the test build provided in #12544 (perhaps the same problem).

comment:3 Changed 23 months ago by jarwin-dosling

Please kindly see attached VBox.log. I am running Linux Mint Host OS and with the latest VirtualBox 4.3.6 r91406.

I am trying to install ESXI 5.5 and it soon goes to a black screen and nothing happens. However it installs fine with VirtualBox 4.2. The same happens with installing eSXI 5.1

Last edited 23 months ago by jarwin-dosling (previous) (diff)

Changed 23 months ago by jarwin-dosling

comment:4 Changed 23 months ago by frank

In that case it's indeed the same problem as #12544 and will be fixed with the next 4.3.x maintenance release. Could you install this test build and verify that it fixes your problem? Thank you!

comment:5 Changed 22 months ago by Marvin_

i have the same Problem with Virtualbox 4.3.6 and VMWare 5.X. I use openSuse 12.3 64bit as basesystem, pls can you provide also an build for that plattform?

Or when will the official Fix/new version released?

comment:6 Changed 22 months ago by frank

Could you test  VBox 4.3.8 RC1?

comment:7 Changed 21 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

VBox 4.3.8 was just released, closing.

Note: See TracTickets for help on using tickets.
ContactPrivacy policyTerms of Use