VirtualBox

Ticket #12556 (closed task: invalid)

Opened 7 years ago

Last modified 7 years ago

Debian Jessie VB - failed: /usr/lib/x86_64-linux-gnu/libXfixes.so.3: undefined symbol: _XEatDataWords

Reported by: WiseElder Owned by:
Component: installer Version: VirtualBox 4.3.6
Keywords: installer, error, libXfixes.so.3, debian jessie Cc:
Guest type: Windows Host type: Linux

Description

I've tried installing both Jessie distribution, and Oracle's distribution but both give the same message

when trying to launch VB. Both give the following message:

VirtualBox: supR3HardenedMainGetTrustedMain: dlopen("/opt/VirtualBox/VirtualBox.so",) failed: /usr/lib/x86_64-linux-gnu/libXfixes.so.3: undefined symbol: _XEatDataWords

The VB module builds, and installs...indicating started.

I also removed, and reinstalled libXext-dev....still get the same error message.

I tried googling the error message but didn't find any relevant answers.

System Information:

AuthenticAMD; 2 CPUs Kernel-3.11-2-amd64 GCC-4.8 (x86_64-linux-gnu) VirtualBox-4.3.6-91406-Linux_amd64.run Memory Total: 7752 MiB SWAP Total: 15867 MiB HardDrive: 1 Terabye libxext-dev libxfixes6-dev Xorg-1.14.5 (13 December 2013 10:12:53AM)

I've been trying to trouble shoot this for 3 days, any help...or suggestions would be greatly appreciated.

Attachments

VBox.log Download (92.4 KB) - added by WiseElder 7 years ago.
VBox.log

Change History

Changed 7 years ago by WiseElder

VBox.log

comment:1 Changed 7 years ago by frank

  • Status changed from new to closed
  • Resolution set to invalid

To me this looks like an installation problem of your Linux distribution rather than a bug in VirtualBox. Jessie is not a stable Linux distribution, therefore there is no direct support for VirtualBox on your setup. But VirtualBox runs without any problems here on Debian/Sid. The missing symbols you enumerated come from /usr/lib/x86_64-linux-gnu/libX11.so.6. I assume that the libraries libX11 and libXfixes in Debian/Testing currently don't fit together. Just wait for the next update.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use