VirtualBox

Ticket #12483 (closed defect: obsolete)

Opened 7 years ago

Last modified 5 years ago

Titlebar + Application Borders are not painted in Windowblinds

Reported by: RealRaven Owned by:
Component: GUI Version: VirtualBox 4.3.4
Keywords: Theming Cc:
Guest type: all Host type: Windows

Description

I am running vbox under Windows 7 Professional with Windowblinds installed. No matter what theme I use or even if I excluded skinning for virtualbox, it is probably trying to paint its titlebar itself and fails very badly at it. The titlebar shows: the application icon at top left; a black title on a completely transparent background which is blurred. There is no background color to the titlebar, the minimize, restore, maximize and close buttons are invisible (so I have to guess about their location if I want to click any of them). Also, no borders are painted around the window, which makes resizing difficult as well.

In Windowblinds, it is possible to completely exclude applications from skinning, (which usually makes them show in Windows95 style) but this does not make not any difference. I am running a lot of different software & development environments (I also code for Mozilla, Fx & Thunderbird Addons) but I haven't seen this particular problem with any other software.

Change History

comment:1 follow-up: ↓ 2 Changed 7 years ago by mhanor

Have you tried to run other Qt-based GUI software, to check if the problem is related to Qt and WindowBlinds, and not to VirtualBox itself?

comment:2 in reply to: ↑ 1 Changed 7 years ago by RealRaven

Replying to mhanor:

Have you tried to run other Qt-based GUI software, to check if the problem is related to Qt and WindowBlinds, and not to VirtualBox itself?

I don't know, what is Qt? I have just upgraded to 4.3.6 and the problem is still persistent. I am running a lot of software on this PC, but I have never seen this issue with any other software so far.

 http://img819.imageshack.us/img819/1426/m9qw.png

I think this regression was introduced in the previous version (4.3.4). Before it I had version 4.2.6 installed where it worked fine. btw is there any way to be notified via email if the ticket is answered?

comment:3 Changed 7 years ago by RealRaven

just to test your theory I have installed the qt based windows version of this editor:

 http://qt-apps.org/content/show.php/CuteMarkEd?content=158801

which I believe was updated on Nov19th and it does not have this issue.

comment:4 Changed 7 years ago by mhanor

Try a Qt4 based application. About the e-mail notification, search your spam folder.

Last edited 7 years ago by mhanor (previous) (diff)

comment:5 Changed 7 years ago by RealRaven

Just a heads up, I just installed v 4.3.10 and the problem is still ongoing. interestingly it also affects the installer: completely transparent titlebars with no window controls (min / max / close).

Also, I tried "disable visual themes" but this doesn't make any difference.

comment:6 Changed 5 years ago by aeichner

  • Status changed from new to closed
  • Resolution set to obsolete

Please reopen if still relevant with a recent VirtualBox release.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use