VirtualBox

Ticket #12480 (reopened defect)

Opened 4 months ago

Last modified 7 weeks ago

Invalid number of CPU cores detected => Fixed in SVN

Reported by: Rafcio Owned by:
Priority: minor Component: other
Version: VirtualBox 4.3.4 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

I'm getting "Invalid settings detected" message is the Settings dialog. It says that more virtual CPUs are assigned than the number of physical CPUs. The laptop has 4 cores, which I believe are equivalent to stand alone CPUs. However, the message indicates that only 2 physical CPUs are detected. This is strange, because on the processor tab the green bar ends at 4 CPUs, and that is exactly how many are assigned to the VM.

Attachments

vbox.tar.gz Download (98.5 KB) - added by Rafcio 4 months ago.
Logs
vbox-procmon.PNG Download (18.2 KB) - added by mizzao 3 months ago.
task manager CPU info
vbox-invalid.PNG Download (25.6 KB) - added by mizzao 3 months ago.
warning in vbox 4.3.6
Ora_VM_4.2.22_r91556.zip Download (23.7 KB) - added by PepeN 8 weeks ago.
previous version
Ora_VM_4.3.8_r92456.zip Download (13.4 KB) - added by PepeN 8 weeks ago.
current version

Change History

Changed 4 months ago by Rafcio

Logs

comment:1 Changed 4 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Sorry to say but your CPU has only 2 physical cores, see  here. Hyperthreads don't count.

comment:2 Changed 4 months ago by Rafcio

  • Status changed from closed to reopened
  • Resolution fixed deleted

You are correct. My employer is a cheap one and the new laptops it provides are lousy. I thought there were 4 single threaded cores, but my assumption was incorrect. Anyway, why is the green bar on the processor tab up to 4 CPUs? This is inconsistent. If only physical CPUs (cores) count, then this fact should be reflected on the processor tab as well. Green means good, right? Perhaps 3 colors should be used? Green for the number of actual CPUs (cores), yellow for the available threads and red (pink?) for whatever that color is used for now.
I'm not trying to be a pain..., but clearly a green setting shouldn't generate a warning. I'm just pointing this out and making a suggestion. Go ahead and close the ticket again.

comment:3 Changed 4 months ago by frank

  • Summary changed from Invalid number of CPU cores detected to Invalid number of CPU cores detected => Fixed in SVN

You are right, the colors are not consistent to the actual warnings. The reason is that in 4.3.x we don't use the number of physical processors consistently in the VM settings dialog. This will be fixed in the next maintenance release and there is no additional color change necessary.

comment:4 Changed 4 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Fix is part of VBox 4.3.6.

Changed 3 months ago by mizzao

task manager CPU info

Changed 3 months ago by mizzao

warning in vbox 4.3.6

comment:5 Changed 3 months ago by mizzao

  • Status changed from closed to reopened
  • Resolution fixed deleted

I'm using VBox 4.3.6 and this is not fixed.

I have a dual-core processor with hyperthreading (pretty common these days.) I have a Windows 8.1 64-bit host and a Linux guest. If I select four processors, I get the warning, but the Linux guest works normally (a native installation would show four listings in 'cat /proc/cpuinfo'). If I select two processors, the Linux guest sees two cores but I don't think it has access to the hyper-threads.

Anyway, this warning should be fixed for different numbers of cores and hyperthreads. Screenshots of processor monitor and virtualbox attached.

comment:6 Changed 3 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

No, that works like intended. Passing 4 virtual CPUs on a dual-core machine with 2 hyperthreads per machine does not make sense. VirtualBox does not emulate hyperthreads but only physical cores.

comment:7 Changed 8 weeks ago by PepeN

Hi,

I'm install 4.3.8.

I have 2 x Intel® Xeon® Processor L5420 ( http://ark.intel.com/products/33929/Intel-Xeon-Processor-L5420-12M-Cache-2_50-GHz-1333-MHz-FSB)

  • of Cores ‡ 4
  • Intel® Hyper-Threading Technology ‡ No

system have 2 x 4 = 8 physical CPUs cores

but VBox detect:

number of physical CPUs on the host system (2) - not physical CPUs cores (8)

comment:8 Changed 8 weeks ago by frank

  • Status changed from closed to reopened
  • Resolution fixed deleted

PepeN, please attach the VBox.log file of a VM session. It will provide all information I need.

Changed 8 weeks ago by PepeN

previous version

Changed 8 weeks ago by PepeN

current version

comment:9 Changed 8 weeks ago by PepeN

Frank, I hope this information will help.

comment:10 Changed 7 weeks ago by frank

Thanks for these logs. Could you also attach the output of the following commands:

uname -a
ls -ld /sys/devices/system/cpu/cpu*
cat /sys/devices/system/cpu/cpu*/topology/core_id
cat /sys/devices/system/cpu/cpu*/topology/physical_package_id

Thank you!

comment:11 Changed 7 weeks ago by PepeN

I apologize for the carelessness. My mistake, I have

Host type: Windows
Guest type: Linux

My information relates (https://www.virtualbox.org/ticket/12726)

comment:12 Changed 7 weeks ago by frank

The problem is that on Windows we depend on the GetLogicalProcessorInformation() which apparently returns wrong information on your host. The VBox source code for the Windows function can be found here.

comment:13 follow-ups: ↓ 14 ↓ 15 Changed 7 weeks ago by mhanor

PepeN, I think this may be relevant to your host OS (win2003) and the GetLogicalProcessorInformation issue:
 http://support.microsoft.com/kb/932370

Last edited 7 weeks ago by mhanor (previous) (diff)

comment:14 in reply to: ↑ 13 Changed 7 weeks ago by frank

Replying to mhanor:

PepeN, I think this may be relevant to your host OS (win2003) and the GetLogicalProcessorInformation issue:
 http://support.microsoft.com/kb/932370

Very right, thanks for pointing this out!

comment:15 in reply to: ↑ 13 Changed 7 weeks ago by PepeN

Replying to mhanor:

PepeN, I think this may be relevant to your host OS (win2003) and the GetLogicalProcessorInformation issue:
 http://support.microsoft.com/kb/932370

Yes, you were right! Thank you!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use