VirtualBox

Ticket #12411 (closed defect: wontfix)

Opened 5 months ago

Last modified 5 months ago

MS LifeCam HD-3000 USB cam + Skype video freezes VirtualBox

Reported by: efagerho Owned by:
Priority: major Component: USB
Version: VirtualBox 4.3.4 Keywords:
Cc: Guest type: Windows
Host type: all

Description

The following causes the VirtualBox 4.3.2/4.3.4 to completely freeze on a Fedora host with a Windows 7 x64 guest with all updates applied:

  1. Start win7 VM
  2. Plug in MS LifeCam HD-3000 USB webcam
  3. Connect webcam to VBox
  4. Start Skype
  5. Goto Tools->Options->General->Video settings

At this point Skype starts recording on the webcam. However, instead of getting a picture, VirtualBox freezes completely. It's even impossible to close the VirtualBox Manager window.

I also have Guest Additions installed. I haven't tried to reproduce this on another host OS than Fedora. When the crash happens, I see this in my dmesg:

[ 2169.262200] xhci_hcd 0000:00:14.0: ERROR Transfer event for disabled endpoint or incorrect stream ring [ 2169.262204] xhci_hcd 0000:00:14.0: @0000000036c07540 d817bb30 00000000 0d000430 03038000

Nothing in VBox logs.

Attachments

dmesg.log Download (69.5 KB) - added by efagerho 5 months ago.
VBox.log Download (104.9 KB) - added by efagerho 5 months ago.
lsmod.log Download (4.6 KB) - added by efagerho 5 months ago.

Change History

Changed 5 months ago by efagerho

Changed 5 months ago by efagerho

Changed 5 months ago by efagerho

comment:1 Changed 5 months ago by efagerho

I suspect that this is yet another bug in the Linux USB 3.0 implementation. Putting USB into legacy mode in BIOS and blacklisting xhci_hcd, the computer does not freeze anymore. Now the only problem is that wherever Skype is supposed to output the video image, instead I just see random garbage from the framebuffer, which looks like pieces of other application windows. I assume that this is some problem with graphics acceleration.

Downloading a version of Skype 4.2 from 2010, the video also shows up normally, so Skype works as it should. They must have done something to use fancier graphics features between then and know. Only problem is that the video image lags behind by about 2 seconds, which is pretty annoying when talking to someone.

It seems like the original bug reported is not the fault of VirtualBox and the video lag is a different issue.

comment:2 Changed 5 months ago by sunlover

  • Status changed from new to closed
  • Resolution set to wontfix

According to the log, you were using USB-passthrough for the webcam. It does not work reliably with webcams.

Please use WebCam-passthrough instead:

 http://www.virtualbox.org/manual/ch09.html#idp60128224

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use