VirtualBox

Ticket #1240 (closed defect: fixed)

Opened 6 years ago

Last modified 5 years ago

VM crash while installing AsteriskNOW -> fixed in SVN

Reported by: vezult Owned by:
Priority: major Component: VMM/RAW
Version: VirtualBox 2.1.0 Keywords: rPath Anaconda installation crash
Cc: david@… Guest type: Linux
Host type: other

Description

When attempting to install AsteriskNOW (rPath linux + Anaconda), I always reach a point (seemingly random) where the VM crashes. I have little indication of the problem source other than what the Logs contain.

Host info


OS: Debian GNU/Linux "Lenny" Kernel: 2.6.22-3-686

I've attached the VM sesssion log.

Attachments

AsteriskNOW-2008-02-25-11-51-20.log Download (154.8 KB) - added by vezult 6 years ago.
VM Session Log
AsteriskNOW-2008-02-29-17-30-35.log Download (33.2 KB) - added by vezult 6 years ago.
Successful boot log
VBox.log Download (141.8 KB) - added by SKrause 6 years ago.
Log File from SKrause
VBox.png Download (11.4 KB) - added by SKrause 6 years ago.
PNG File from SKrause
AsteriskNOW-2008-04-11-15-39-13.log Download (156.4 KB) - added by vezult 6 years ago.
Continued failure using virtualbox svn r7848
greggh_1240.tar.gz Download (56.4 KB) - added by greggh 6 years ago.
Logs with VT and without VT enabled.
AsteriskNOW-2008-07-11-15-54-35.log Download (154.8 KB) - added by vezult 6 years ago.
failure using version 1.6.2 OSE with AMD-V enabled.
Screenshot-1.png Download (146.8 KB) - added by vezult 6 years ago.
AMD-V enabled, according to GUI
VBox.2.log Download (171.9 KB) - added by phasemaster 6 years ago.
Crash log with VB 2.0.0 while installing AsteriskNOW-1.0.2.1-x86 on Vista
VBox.2.png Download (54.5 KB) - added by phasemaster 6 years ago.
Crash log with VB 2.0.0 while installing AsteriskNOW-1.0.2.1-x86 on Vista

Change History

Changed 6 years ago by vezult

VM Session Log

comment:1 Changed 6 years ago by vezult

The installer seems to be running kernel version 2.6.22.16-0.1.gcc3.4.x86.i686. The crash occurs in graphical and text mode installers, and it seems to happen at one of two places; while loading the installer, or right after (or at the end of) installing all software packages. Its unclear what is happening on the guest OS at those points.

comment:2 Changed 6 years ago by vezult

A friend of mine was able to install AsteriskNOW using vbox 1.5.6, but he also got the crashes most of the time. He claimed to have got it to work (the installer kernel at least) using kernel options: noacpi noapic nofb text

When I attempt to run the installed system on my virtualbox (v1.5.4), it (virtualbox) continues to crash every time it tries to boot - at one of 2 places: following "Initializing hardware..." or following "Checking for new hardware" regardless of what kernel options i supply

comment:3 Changed 6 years ago by vezult

The vm _does_ boot occasionally. I was just able to boot, having changed nothing from the last attempt.

Changed 6 years ago by vezult

Successful boot log

Changed 6 years ago by SKrause

Log File from SKrause

Changed 6 years ago by SKrause

PNG File from SKrause

comment:4 Changed 6 years ago by SKrause

I am also experiencing random crashes, mostly at the begging of the install. I have attached the log/pic files.

comment:5 in reply to: ↑ description Changed 6 years ago by vezult

Just to be clear, this issue DOES apply to the latest version of virtualbox (1.5.6). The problem is very consistent.

I am using an AMD64 processor with virtualization extensions. The problem occurs regardless of whether VT-x/AMD-V is turned on or off.

Changed 6 years ago by vezult

Continued failure using virtualbox svn r7848

comment:6 Changed 6 years ago by frank

This problem is reproducible and even 1.6.0 does not contain a fix, sorry.

comment:7 Changed 6 years ago by frank

  • Version changed from VirtualBox 1.5.4 to VirtualBox 1.6.0

comment:8 Changed 6 years ago by frank

This should work fine with 1.6.2 and VT-x or AMD-V enabled.

comment:9 Changed 6 years ago by greggh

I also have this problem. I am running VirtualBox 1.6.2. with Suse 10.3 (2.6.22.5-31-bigsmp #1 SMP 2007/09/21 22:29:00 UTC i686 i686 i386 GNU/Linux).

I have tried VT-x or AMD-V enabled without success. I have tried changing many of the settings. Recreated new VM's, but no luck.

comment:10 Changed 6 years ago by frank

Are you sure that your host supports VT-x or AMD-V? Please attach a VBox.log file of 1.6.2 when you enabled hardware virtualization.

Changed 6 years ago by greggh

Logs with VT and without VT enabled.

comment:11 Changed 6 years ago by frank

gregh, actually VT-x was not enabled (this can be clearly seen in the logs). Please could you check your BIOS settings if VT-x is disabled?

comment:12 Changed 6 years ago by EduardoYC

I also have this problem. No solution yet?

comment:13 Changed 6 years ago by frank

Did you actually read the last comments? You should be fine if you are able to enable VT-x/AMD-V for that VM.

comment:14 Changed 6 years ago by greggh

Okay ... I did a bit of research. It looks like although my Laptop bios allows me to set this in the bios, it is still disabled. So it looks like I shall not get it right no matter not. I am using an HP nc6400. I shall have to do the installation of Asterisk manually ... install bit by bit myself :-(

thanks

comment:15 Changed 6 years ago by frank

  • Component changed from other to VMM
  • Guest type changed from other to Linux

comment:16 Changed 6 years ago by vezult

I'd like to confirm that this is still an issue for me. I'm running Virtualbox v1.6.2 OSE, _with_ VT-x/AMD-V enabled according to the virtualbox interface.

Host:

david@gorilla:~$ uname -r 2.6.25-2-amd64 david@gorilla:~$ aptitude search '~i' |grep virtualbox i virtualbox-ose - x86 virtualization solution - binaries i virtualbox-ose-modules-2.6-amd6 - PC virtualization solution modules for Lin i A virtualbox-ose-modules-2.6.25-2 - PC virtualization solution modules for Lin

Changed 6 years ago by vezult

failure using version 1.6.2 OSE with AMD-V enabled.

Changed 6 years ago by vezult

AMD-V enabled, according to GUI

comment:17 Changed 6 years ago by vezult

More host information. Processor has support for virtualization extensions:

david@gorilla:/vm/VirtualBox/Machines/AsteriskNOW/Logs$ cat /proc/cpuinfo 
processor	: 0
vendor_id	: AuthenticAMD
cpu family	: 15
model		: 107
model name	: AMD Athlon(tm) 64 X2 Dual Core Processor 4200+
stepping	: 1
cpu MHz		: 1000.000
cache size	: 512 KB
physical id	: 0
siblings	: 2
core id		: 0
cpu cores	: 2
fpu		: yes
fpu_exception	: yes
cpuid level	: 1
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow rep_good pni cx16 lahf_lm cmp_legacy svm extapic cr8_legacy 3dnowprefetch
bogomips	: 2006.21
TLB size	: 1024 4K pages
clflush size	: 64
cache_alignment	: 64
address sizes	: 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc 100mhzsteps

processor	: 1
vendor_id	: AuthenticAMD
cpu family	: 15
model		: 107
model name	: AMD Athlon(tm) 64 X2 Dual Core Processor 4200+
stepping	: 1
cpu MHz		: 1000.000
cache size	: 512 KB
physical id	: 0
siblings	: 2
core id		: 1
cpu cores	: 2
fpu		: yes
fpu_exception	: yes
cpuid level	: 1
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow rep_good pni cx16 lahf_lm cmp_legacy svm extapic cr8_legacy 3dnowprefetch
bogomips	: 2006.21
TLB size	: 1024 4K pages
clflush size	: 64
cache_alignment	: 64
address sizes	: 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc 100mhzsteps

comment:18 Changed 6 years ago by frank

vezult, please attach the VBox.log file of your VM session here.

comment:19 Changed 6 years ago by vezult

I attached the log along with my report. Please refer to the attachment named AsteriskNOW-2008-07-11-15-54-35.log

comment:20 Changed 6 years ago by frank

vezult, sorry, I somehow missed your log file the first time. Unfortunately, your host CPU is a Pentium 4 which lacks of support for VT-x and AMD-V. The VM info dialog only shows the desired setting for that VM. But during startup it was detected that your host CPU actually does not have a VT-x / AMD-V capable CPU and therefore such support was not activated. Silently not enabling VT-x / AMD-V is a bug which has to be fixed. AsteriskNOW currently requires support for hardware virtualization. We will try to make it work in the normal mode as well but again, this will currently not work with 1.6.2.

comment:21 Changed 6 years ago by vezult

Um...Perhaps you'll want to reread the document I referred you to; the lines 399 to 453 inclusively. You may even find the /proc/cpuinfo dump that I posted to be instructive.

I do apreciate that someone is monitoring this issue, but am beginning to feel as if effort to provide useful information is being wasted. I'm quite certain that I am running a dual-core, 64 bit AMD processor with AMD-V, and am even pretty sure that it is enabled, according to the VM session log that I posted.

comment:22 Changed 6 years ago by frank

Next try. You provided four log files, I investigated the first two (AsteriskNOW-2008-02-25-11-51-20.log and AsteriskNOW-2008-02-29-17-30-35.log) which indeed show a Pentium 4. The third and the fourth log, AsteriskNOW-2008-04-11-15-39-13.log show the log for and AMD processor. However, AMD-V is not enabled as one can clearly seen:

00:00:07.258 HWACCM: No VMX or SVM CPU extension found. Reason VERR_SVM_DISABLED
00:00:07.258 HWACCM: VMX MSR_IA32_FEATURE_CONTROL=0

So AMD-V is either disabled in your BIOS, by your Linux host or VirtualBox is not able to enable AMD-V for some other reason. Please make 100% sure that you didn't disable AMD-V in the BIOS.

comment:23 Changed 6 years ago by frank

  • Component changed from VMM to VMM/RAW

Changed 6 years ago by phasemaster

Crash log with VB 2.0.0 while installing AsteriskNOW-1.0.2.1-x86 on Vista

Changed 6 years ago by phasemaster

Crash log with VB 2.0.0 while installing AsteriskNOW-1.0.2.1-x86 on Vista

comment:24 Changed 6 years ago by phasemaster

Installing of AsteriskNOW (1.0.2.1-x86 on Vista) still crashes with VB 2.0.0. Crash log is attached.

comment:25 Changed 6 years ago by frank

phasemaster, the priority for improving the support for VT-x / AMD-V is currently higher than fixing the raw mode (VT-x/AMD-V disabled). You should be able to run Asterisk if you enable the VT-x mode for that VM, your processor is capable of this mode. Enable VT-x in the VM settings check if it is actually used when the VM is running (check the session information dialog, HostKey+N).

comment:26 Changed 6 years ago by phasemaster

Frank, thank you for that tip. It works indeed if VT-x/AMD-V is enabled!

I am a laymen with respect to VM, but if VT-x/AMD-V mode is your priority, I wonder why VT-x/AMD-V is not enabled by default in case a CPU supporting that mode is detected? Anyhow, I am happy now. This is a great piece of software!

comment:27 Changed 5 years ago by sandervl73

  • Version changed from VirtualBox 1.6.0 to VirtualBox 2.1.0

comment:28 Changed 5 years ago by sandervl73

  • Summary changed from VM crash while installing AsteriskNOW to VM crash while installing AsteriskNOW -> fixed in SVN

comment:29 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use