VirtualBox

Ticket #12346 (closed defect: fixed)

Opened 5 months ago

Last modified 5 months ago

Error executing script by guest control after guest system restart => Fixed in SVN

Reported by: Dronsky Owned by:
Priority: major Component: guest control
Version: VirtualBox 4.3.2 Keywords:
Cc: Guest type: other
Host type: other

Description

I'm doing automated building of my system in different OS. For Linux systems I use scripts in guest system (Ubuntu) and execute it from script in host system - Windows 7. Everything works ok until I restart the guest system. After that I get an error message on my command:

"c:\Program Files\Oracle\VirtualBox\VBoxManage.exe" guestcontrol "CentOS" exec --image "/opt/myinstaller/prepare.sh " --username 
user1 --password user1 --wait-stderr --wait-stdout --verbose

Opening guest session as user 'user1' ...
Waiting for guest session to start ...
VBoxManage.exe: error: Error starting guest session (current status is: terminated)
Closing guest session ...

After that I install Guest Additions once more, and everything is OK again. So it looks like something doesn't start on system restart. Guest additions seems to work somekind - shared folders work ok. But guest control needs them to be reinstalled after each guest system restart.

One more experiment. I installed Guest Additions. Guest control works. I logged out in guest system. Guest control works. I logged in to guest system. Guest control doesn't work. But the error message is a little different:

Opening guest session as user 'user1' ...
Waiting for guest session to start ...
VBoxManage.exe: error: Error starting guest session (current status is: starting)
Closing guest session ...

This error is reproducable on guest systems: Ubuntu 10.04, Ubuntu 12.04, CentOs 6.4.

Change History

comment:1 Changed 5 months ago by frank

  • Summary changed from Error executing script by guest control after guest system restart to Error executing script by guest control after guest system restart => Fixed in SVN

Thank you for this report. The problem will be fixed in the next maintenance release.

comment:2 Changed 5 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in 4.3.4.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use