VirtualBox

Ticket #12345 (closed defect: fixed)

Opened 21 months ago

Last modified 14 months ago

OVF 0.9 import fails => Fixed in SVN

Reported by: Akenine Owned by:
Priority: critical Component: OVF
Version: VirtualBox 4.3.2 Keywords: ovf 0.9
Cc: Guest type: other
Host type: other

Description

Tried importing icinga image:

 http://sourceforge.net/projects/icinga/files/icinga-virtual-image/1.8.1/virtualbox-icinga-1.8.1-0.3-demo-centos6.ova/download

Error Message:
Failed to import appliance C:\...\virtualbox-icinga-1.8.1-0.3-demo-centos6.ova.

Error reading "C:\...\virtualbox-icinga-1.8.1-0.3-demo-centos6.ova": element "Section" has no "type" attribute, line 18.

Result Code: VBOX_E_FILE_ERROR (0x80BB0004)
Component: Appliance
Interface: IAppliance {3059cf9e-25c7-4f0b-9fa5-3c42e441670b}

Attachments

envelope.xml Download (30.2 KB) - added by Akenine 21 months ago.
OVF Envelope extracted from image
Fortigate-VM64.hw07_vmxnet2.ovf Download (26.4 KB) - added by ak2766 14 months ago.

Change History

Changed 21 months ago by Akenine

OVF Envelope extracted from image

comment:1 Changed 21 months ago by GabrieleV

Even if I export a native Virtualbox Virtual MAchine as OVF 0.9, I can't import it back. Same error:

  • Create a virtual machine in virtualbox
  • Export it as ovf 0.9
  • Try to import

comment:2 Changed 20 months ago by Akenine

There is a thread about this problem in the forum:

 https://forums.virtualbox.org/viewtopic.php?f=8&t=57889

It looks like xml-parsing just fails for OVF 0.9, even if the envelopes conform to the standard

comment:3 Changed 20 months ago by GabrieleV

Any news abot this ?

comment:4 Changed 18 months ago by frank

Finally found and fixed the problem. The fix will be part of the next maintenance release. Thanks for the report!

comment:5 Changed 18 months ago by frank

  • Summary changed from OVF 0.9 import fails to OVF 0.9 import fails => Fixed in SVN

comment:6 Changed 17 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 4.3.8.

comment:7 Changed 14 months ago by ak2766

I've recently tried to import an appliance (Fortigate) but I'm getting the error listed above, but with Virtualbox 4.3.12 - is there a regression?

Failed to import appliance /vmachs/fortinet/fortigate1-64bit/Fortigate-VM64.hw07_vmxnet2.ovf.

Could not open the medium storage unit '/vmachs/fortinet/fortigate1-64bit/fortios.vmdk'.

VD: error VERR_INTERNAL_ERROR opening image file '/vmachs/fortinet/fortigate1-64bit/fortios.vmdk' (VERR_INTERNAL_ERROR).

Details:
Result Code: 
VBOX_E_FILE_ERROR (0x80BB0004)
Component: 
Appliance
Interface: 
IAppliance {3059cf9e-25c7-4f0b-9fa5-3c42e441670b}

Changed 14 months ago by ak2766

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use