VirtualBox

Ticket #1233 (closed defect: duplicate)

Opened 6 years ago

Last modified 5 years ago

Virtual Box Eats up CPU when guest idle

Reported by: bundabrg Owned by:
Priority: major Component: other
Version: VirtualBox 1.5.6 Keywords:
Cc: Guest type: other
Host type: other

Description

Host: Ubuntu X86_64 'Gutsy Gibbon' 7.10 running Virtualbox 1.5.6 Supports AMD-V. 64bit processor Dual core CPU, 8Gb Ram, 4Tb HDD

Guest: Windows 2003 Server Standard Running with 512Mb of Memory

When the guest is idling, the host shows a contant 15-25% CPU usage on one core. This happens if I run it headless using VRDP or when I run it under the GUI.

I have tried enabling and disabling AMD-V and it makes no difference. Actually I can't really tell a difference in speed between these two modes. Without it enabled, it seems to boot faster which supports the claim in the FAQ that Virtualbox's own 'tricks' are less expensive than hardware virtualization.

I have disabled clipboard sharing as well.

Guest Additions have been installed.

I even dropped host to 4Gb of ram (I've had machines where if you put more than 4Gb, even though they say they support it AND I run a 64bit os, weird things happen like the raid controller stopping or the network card not working!).

This means if I run 4 guests, both cores use up huge amounts of cpu for idle guests.

This particular image is one I converted from a qcow2 image which I ran under KVM. If I run it (I sitll have the original image) under kvm, the host cpu is about 1-2% during guest idle (and in fact it drops off top completely so probably even less).

Let me know if theres anything else I can provide.

I've chosen priority of Major because it limits the amount of guests that one can run. I actually ran 13 guests with KVM and I don't think I'm going to be able to achieve that with Virtualbox.

Brendan Grieve

Change History

comment:1 Changed 6 years ago by the4thchild

I see similar behavior with a WinXP guest on a Linux host. I think this issue might be related to ticket #894.

comment:2 Changed 6 years ago by dirkgently

I've seen similar behaviour on a Windows host with a Linux guest on a dual core system. I'm running a CentOS 4.6 guest with no package updates on a WindowsXP SP2 host running Virtual Box 1.5.6. I have a dual core Intel Core 2 6600 CPU. The kernel versions I'm running are:

  • CentOS 4.6 SMP kernel is 2.6.9-67.EL
  • CentOS 4.6 non-SMP kernel is 2.6.9-67.EL
  • vmware.xaox.net non-SMP kernel is 2.6.9-67.0.7.plus.c4.VMware

I've found the following things:

  1. CentOS 4.6 SMP kernel gets stuck on boot and never gets past "Ok, booting the kernel."
  1. CentOS 4.6 non-SMP kernel boots and consumes all of one core while idling in X windows. top within the CentOS guest shows it is idle as far as it's concerned.
  1. Using the CentOS 4.6 non-SMP kernel and setting the affinity of the VirtualBox process in Windows Task Manager to CPU0 changes the situation dramatically. CPU usage goes to ~25% of one core.
  1. Using the CentOS 4.6 non-SMP kernel from  http://vmware.xaox.net/centos/4.6/i386/ AND setting affinity to CPU0 changes the situation dramatically again. There is now virtually no CPU usage on the Windows host when the CentOS guest is idling.
  1. Using the CentOS 4.6 non-SMP kernel from vmware.xaox.net and NOT setting affinity, CPU usage goes up again to consume all of one core.

The optimal solution for me has been setting affinity to CPU0 and using the latest non-SMP kernel from vmware.xaox.net. I've not yet tried an SMP kernel from vmware.xaox.net. It may have a similar problem to the CentOS 4.6 SMP kernel.

I should also note all of this testing has been with VT-x turned off in the virtual machine settings. I haven't gone through any of the above iterations with VT-x turned on.

My problems at least seem to stem from the combination of running Virtual Box on a dual core system and using a high hertz kernel. Using a low hertz kernel and setting the process affinity to one core or the other dramatically improves things.

See:  http://forums.virtualbox.org/viewtopic.php?t=5511

Perhaps in the case of Windows guests, there's a specific application or process that is causing the high CPU usage? Apparently the Delphi 2007 IDE creates this effect:

 http://blogs.remobjects.com/blogs/donald/2008/04/08/delphi_incompatible_with_virtualbox

comment:3 Changed 6 years ago by frank

Please check 1.6.0, there were many improvements for idle guests. Note that activating the OHCI+UHCI controller in the guest causes an additional load (we will fix this later). So please at first check if the USB controller is disabled.

comment:4 Changed 6 years ago by wphilips1

I checked VirtualBox 1.6.0. While the client is idle cpu usage is still around 20%. It never drops below 17%. This is exactly the same as in VirtualBox 1.5.6

Host OS: Fedora core 8. kernel 2.6.23.15-137.fc8 #1 SMP Sun Feb 10 17:48:34 EST 2008 i686 athlon i386 GNU/Linux

cat /proc/cmdline ro root=LABEL=/ rhgb quiet

cat /proc/cpuinfo processor : 0 vendor_id : AuthenticAMD cpu family : 6 model : 8 model name : AMD Athlon(TM) XP 2600+ stepping : 1 cpu MHz : 2083.200 cache size : 256 KB fdiv_bug : no hlt_bug : no f00f_bug : no coma_bug : no fpu : yes fpu_exception : yes cpuid level : 1 wp : yes flags : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 mmx fxsr sse syscall mmxext 3dnowext 3dnow up ts bogomips : 4168.56 clflush size : 32

Guest OS: windows XP (converted from vmware and then used under virtualbox 1.5).

Usb controller: off

comment:5 Changed 6 years ago by AmigoNico

I just installed 1.6.2 on Vista SP1, and then created a virtual machine into which I installed Ubuntu 8.04.1 from CD and the guest additions for Linux. It consumes 50% CPU while idle. Setting processor affinity did not help, so the VM is essentially unusable.

comment:6 Changed 6 years ago by AmigoNico

Sorry, I should have mentioned that that was on a Gateway E-295C laptop with a 2.2 GHz T7500 Core2Duo processor and 2GB RAM. Not using virtualization ops (T7500 doesn't have them in any case).

comment:7 Changed 6 years ago by AmigoNico

Hmmm, interesting. I shut down the VM and restarted it; now it is only taking 2-5% of the CPU when idle.

comment:8 Changed 6 years ago by michael

AmigoNico: this may be a problem with one component of the Guest Additions (the userspace application VBoxClient), which reportedly gets stuck on occasion and consumes large amounts of CPU. So far we have not been able to reproduce this. However, I suspect that it is not related to the original issue.

comment:9 Changed 5 years ago by wendall911

As detailed on this page:  https://help.ubuntu.com/community/VirtualBox

Starting VirtualBox with the following puts a bandage on the issue: taskset -c 1

It now only consumes 12-15% cpu consistently on one of the cores.

This occurs with any version of windows being virtualized.

I'm considering VirtualBox completely unusable on dual core systems. This is a critical show stopper bug, being treated like a minor issue. Please take notice of the issue. You will need a core2duo box to test with to reproduce the error. This is a critical issue, and well documented on many distro sites.

I am currently running 2.0.6. This is an issue for me with all versions of VirtualBox from 1.6.5 - 2.0.6

comment:10 Changed 5 years ago by gbell12

I second the above concerns regarding this bug and its priority.

I'm running FC10 as a host, and XP SP3 as a guest on an AMD 64 X2 Dual Core Processor 3800. Guest doing nothing peg a CPU at 100%.

Google searches on "virtualbox 100 cpu" and similar yield a lot of people having the problem and no solid solutions.

taskset -c 1 hasn't yielded any difference. Nice'ing the vbox process hasn't either. Nor has increasing video memory over 32MB, disabling USB or the clipboard.

comment:11 Changed 5 years ago by gbell12

This appears to be a dupe of  http://www.virtualbox.org/ticket/1946 I attached a Vbox.log to that ticket.

comment:12 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use