VirtualBox

Ticket #1232 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

NAT don't work

Reported by: gomeje Owned by:
Priority: major Component: other
Version: VirtualBox 1.5.6 Keywords: Network
Cc: Guest type: other
Host type: other

Description

After upgrade to VirtualBox 1.5.6 my guests don't have networking using NAT. My host is Kubuntu 7.10 and my guest are Windows 2003, Windows XP and SuseLinux 10.3. I tried the proposed solution in other trouble ticket: downloading the last binaries, however I still have the error. This is a serious problem because the guests don't have Internet Access and cannot download updates.

Attachments

VBox.log Download (26.7 KB) - added by peterj 6 years ago.

Change History

comment:1 Changed 6 years ago by frank

We don't received other reports about non-working NAT and it works fine here. How did you check if NAT works or not?

Btw, if NAT does not work for you then you could try a bridged host interface which is the better choice anyway as host interface networking gains a better performance.

comment:2 Changed 6 years ago by peterj

I would like to confirm this Bug. Using also Kubuntu 7.10 as host and Windows XP as guest. Up until virtualbox_1.5.6-28241_Ubuntu_gutsy_i386 the internet over NAT was working fine.

However, after installing the latest version virtualbox_1.5.6-28266_Ubuntu_gutsy_i386.deb I cannot get to the internet with a browser from the guest.

I left all settings as they where after the installation (default NAT settings).

comment:3 follow-up: ↓ 10 Changed 6 years ago by frank

Please could you attach the VBox.log file of the session which is trying to do NAT.

Changed 6 years ago by peterj

comment:4 Changed 6 years ago by peterj

I attached the VBox.log Network Settings are: Only Adapter 0 ist on, Attached to NAT and Adapter Type: PCnet-Fast III. This is the default Network Setting, which stopped working once I upgraded to the most recent deb file.

comment:5 Changed 6 years ago by frank

Thanks, the log file seems ok. Could you try to disable + enable the network adapter in the WinXP guest? Does this change anything? No idea so far about your problem.

comment:6 Changed 6 years ago by biot

I have the exact same problem. Disabling and re-enabling the network adapter in the Windows XP guest didn't change anything at all. Let me know if there's anything else I can try.

comment:7 in reply to: ↑ description ; follow-up: ↓ 9 Changed 6 years ago by drachenstern

Replying to gomeje:

After upgrade to VirtualBox 1.5.6 my guests don't have networking using NAT. My host is Kubuntu 7.10 and my guest are Windows 2003, Windows XP and SuseLinux 10.3. I tried the proposed solution in other trouble ticket: downloading the last binaries, however I still have the error. This is a serious problem because the guests don't have Internet Access and cannot download updates.

Try this, goto Synaptic on Ubuntu and do a search for Virtualbox, then goto the menu "Package", choose configure, and click next through the reconfigure. I suppose you could also use dpkg-reconfigure...

Next, try using your VM to go online. I was going to add to this post, and did that on a whim. It works now. For the past week, however, I haven't had networking in my VM, even though the IP matched before and after the update, and before and after my reconfigure. Let me know your success... Hope it works for you too!

comment:8 Changed 6 years ago by frank

peterj, please note that we replaced the package virtualbox_1.5.6-28241_Ubuntu_gutsy_i386 some hours after the release of 1.5.6 due to a last-minute regression in the hostif networking. This should not have relation to NAT but please update your package anyway.

comment:9 in reply to: ↑ 7 Changed 6 years ago by gomeje

Replying to drachenstern:

Replying to gomeje:

After upgrade to VirtualBox 1.5.6 my guests don't have networking using NAT. My host is Kubuntu 7.10 and my guest are Windows 2003, Windows XP and SuseLinux 10.3. I tried the proposed solution in other trouble ticket: downloading the last binaries, however I still have the error. This is a serious problem because the guests don't have Internet Access and cannot download updates.

Try this, goto Synaptic on Ubuntu and do a search for Virtualbox, then goto the menu "Package", choose configure, and click next through the reconfigure. I suppose you could also use dpkg-reconfigure...

Next, try using your VM to go online. I was going to add to this post, and did that on a whim. It works now. For the past week, however, I haven't had networking in my VM, even though the IP matched before and after the update, and before and after my reconfigure. Let me know your success... Hope it works for you too!

I tried it... but it didn't work. The same. However I had a strange behaviour last day. In other network it worked fine but in my house not. My host computer have Internet access but not my guest. I excuted dpkg-reconfigure virtualbox and /etc/init.d/vboxdrv setup. May be the problem it's related with WI-FI, May it?

comment:10 in reply to: ↑ 3 Changed 6 years ago by gomeje

Replying to frank:

Please could you attach the VBox.log file of the session which is trying to do NAT.

This is exactly my configuration: 1.5.6-28266_Ubuntu_gutsy.

Do you recommend to downgrade my installation?

comment:11 Changed 6 years ago by peterj

Internet over NAT works again for me. I had to run "reconfigure" in synaptic as well as dpkg-reconfigure the virtualbox deb package multiple times. After that, the internet connection works again in the Win XP guest for me.

comment:12 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Actually there is a small bug in all VirtualBox versions until 1.5.6. The builtin slirp engine does not support the DHCPNAK package. So if you switch from host interface to NAT your Windows guest will not be notified that the old IP address is not valid anymore. We've implemented this and the fix will be included in 1.6 which is expected shortly. I will close this bug now, reopen if there are still issues after 1.6.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use