VirtualBox

Ticket #12319 (closed defect: fixed)

Opened 6 months ago

Last modified 5 months ago

4.3.2 does not login to Gnome desktop (regression) -> fixed in 4.1.x and later as of 12 Nov 2013

Reported by: mooninite Owned by:
Priority: major Component: 3D support
Version: VirtualBox 4.3.2 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

Host: Fedora 19 x86_64

Graphics: NVIDIA 9600 GT

Driver: Proprietary NVIDIA driver - 325.15

Guest: Fedora 18 x86_64

3D support worked well under VBox 4.3.0. I was able to log into a Gnome desktop session and use the system normally. After the upgrade to 4.3.2 (and upgrading the additions) I get a "Oops something as gone wrong" message from Gnome and I cannot login to a desktop session.

Downgrading VBox (and the additions) allows me to log in again.

I am attaching the VM log files for 4.3.0 and 4.3.2.

Attachments

guest-logs.tar.xz Download (24.4 KB) - added by mooninite 6 months ago.
4.3.0 and 4.3.2 guest log files

Change History

Changed 6 months ago by mooninite

4.3.0 and 4.3.2 guest log files

comment:1 Changed 6 months ago by michael

Is this reproducible, including with a freshly installed Fedora 18 guest? I was unable to reproduce it locally.

comment:2 Changed 5 months ago by mooninite

It was reproducible at the time. Since opening this ticket there has been a NVIDIA driver update (331.20). I updated the host to the latest kernel (3.11.7), NVIDIA driver, and VBox 4.3.2. The guest now works normally. This ticket may be closed.

comment:3 Changed 5 months ago by mooninite

Of course now that I said it was working it is now not working.

I updated the guest while it was working and after rebooting it, I can no longer log in and suffer the same problem as before. After login the session will hang for about 30 seconds at a blank screen and either present "Oh no! Something has gone wrong." or hang indefinitely. This is happening on every login attempt now. The guest went from kernel 3.10.13 to 3.11.4.

Rebooting into the 3.10.13 kernel lets me login without a problem. I verified that the additions were re-built when the kernel was updated.

Rebooting back into 3.11.4 results in no login ("Oh no! Something has gone wrong.").

comment:4 Changed 5 months ago by mooninite

It seems to be a race condition of some sort. Now neither kernel works. I cannot login at all.

comment:5 Changed 5 months ago by michael

I was able to reproduce the issue and think I was able to fix it. Could you please give this Additions build a try? Note that what I fixed was present in previous versions of VirtualBox too, but perhaps you just didn't hit the right timing.

 http://www.virtualbox.org/download/testcase/VBoxGuestAdditions_4.3.3-90604.iso

comment:6 Changed 5 months ago by mooninite

The new additions seem to fix it. I've rebooted several times and was able to login each time. Thanks!

I do remember an issue in the past like this but it hadn't happened in a while.

comment:7 Changed 5 months ago by michael

  • Summary changed from 4.3.2 does not login to Gnome desktop (regression) to 4.3.2 does not login to Gnome desktop (regression) -> fixed in 4.1.x and later as of 12 Nov 2013

Thanks for the feedback.

comment:8 Changed 5 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in 4.3.4.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use