VirtualBox

Ticket #12315 (closed defect: duplicate)

Opened 7 years ago

Last modified 7 years ago

Terminal scrolling lag in Ubuntu guest

Reported by: myitcv Owned by:
Component: other Version: VirtualBox 4.3.2
Keywords: Cc:
Guest type: Linux Host type: Mac OS X

Description

I have just upgraded to one of the new MacBook Pros. Upgraded VirtualBox to the latest version (4.3.2) and retained my previous Ubuntu guest (13.04 with awesome window manager) on top of Mavericks host. Upped the hardware settings to take advantage of the improved laptop hardware.

Everything runs blindingly fast, except one bizarre thing: scrolling in a terminal. Whether it's xterm, gnome-terminal, running either vim/less, pressing and holding the down arrow (or 'j' in vim) and then releasing causing the scrolling to continue after the key has been pressed for anything up to a second.

This obviously gives a massively laggy feel to what is otherwise a superquick setup (recompile of vim takes no time for example)

A quick glance a 'top' whilst scrolling shows the X server's CPU usage jump to ~3% on scrolling... but I don't have any idea whether this is normal.

Log file attached.

Seems very strange given that everything else is so fast.

Any help much appreciated.

Attachments

VBox.log Download (94.6 KB) - added by myitcv 7 years ago.
VBox log file

Change History

Changed 7 years ago by myitcv

VBox log file

comment:1 Changed 7 years ago by myitcv

Just did another test. In gnome-terminal, scrolling within less sends the CPU to 15%

comment:2 Changed 7 years ago by myitcv

Further testing has shown that things improve markedly if keyboard repeat is turned off completed in the OS X System Prefs. But still scrolling remains sluggish compared to every other operation in the guest.

comment:3 Changed 7 years ago by myitcv

Apologies - another post to self.

But this appears to be related to the graphics cards in the new MacBook pro. There are in fact two:

Chipset Model:	Intel Iris Pro
  Type:	GPU
  Bus:	Built-In
  VRAM (Total):	1024 MB
  Vendor:	Intel (0x8086)
  Device ID:	0x0d26
  Revision ID:	0x0008
  gMux Version:	4.0.8 [3.2.8]

Chipset Model:	NVIDIA GeForce GT 750M
  Type:	GPU
  Bus:	PCIe
  PCIe Lane Width:	x8
  VRAM (Total):	2048 MB
  Vendor:	NVIDIA (0x10de)
  Device ID:	0x0fe9
  Revision ID:	0x00a2
  ROM Revision:	3765
  gMux Version:	4.0.8 [3.2.8]

Is there a recommended configuration for host+guest to get this working optimally?

comment:4 Changed 7 years ago by myitcv

Me again. This is not an issue when the guest is shown on an external display. Hence I would suggest marking this a duplicate of #11606

comment:5 Changed 7 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

I agree.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use