VirtualBox

Ticket #12292 (closed defect: fixed)

Opened 22 months ago

Last modified 17 months ago

Fullscreen does not work on secondary monitor under 10.9 Mavericks host

Reported by: elliott balsley Owned by:
Priority: major Component: other
Version: VirtualBox 4.3.0 Keywords:
Cc: Guest type: Windows
Host type: Mac OS X

Description

I'm using Windows 7 guest inside a OS X 10.9 host, running VirtualBox 4.3, and full screen is not working on secondary monitor. After following Mark's advice above, the screen is the correct size, but shifted down by the width of the OS X menu bar. Probably has something to do with how Mavericks puts a menu bar on both screens.

Attachments

Screen Shot 2013-11-02 at 10.18.40 AM (2).jpg Download (302.8 KB) - added by elliott balsley 22 months ago.

Change History

Changed 22 months ago by elliott balsley

comment:1 Changed 21 months ago by Govind

+1 , this is annoying after upgrading to VirtualBox 4.3.4 , I am also facing the exact issue. This was not the issue in the previous release.

Probably to do with the hot corners fix in this release.

comment:2 Changed 21 months ago by dmac

+1 - Would love to see this fixed. Really annoying. Running VirtualBox 4.3.4 on OSX 10.9

comment:3 Changed 21 months ago by Michael Abboud

+1, very annoying since VirtualBox 4.3.4 and also persists in v4.3.6

comment:4 Changed 20 months ago by Govind

Any updates??

comment:5 Changed 20 months ago by johannesdr

I experience the same problem in version 4.3.6. Any progress?

comment:6 Changed 20 months ago by dmac

If you have a second display you can get around this by disabeling the menu bar on the second dispaly. See:  http://www.mactrast.com/2013/10/disable-second-menu-bar-os-x-mavericks/

comment:7 Changed 20 months ago by Timbuktu

The workaround mentioned in the above link fixes the fullscreen issue in VirtualBox. However, it breaks one important thing that Apple fixed in Mavericks - being able to use apps in fullscreen mode in a dual monitor setup. For example, after unchecking the "Displays have separate spaces" option, if I make Mail fullscreen on one monitor the second monitor pretty much becomes useless. Hopefully, this issue gets fixed soon.

comment:8 Changed 19 months ago by Govind

The above workaround disables other features which are desirable too.

Why cant the Virtualbox take the entire screen, like other applications do. This is certainly fixable from virtual box. where we can have Mac OS on one screen and Virtual box on the the other screen.

comment:9 Changed 19 months ago by blaze

I was extremely annoyed at this issue but I wanted to keep the "Displays have separate spaces" option because it fixes some serious issues with fullscreen apps (especially video players). I also noticed that VirtualBox 4.3 was a lot slower than 4.2.18. Oddly enough, rolling back the VirtualBox version somehow miraculous FIXED this silly menu bar issue.

Here are the steps I followed to go back from VirtualBox 4.3.6 to 4.2.18 that seem to have fixed the issue for me:

  1. Uninstall VirtualBox 4.3 using script provided in the original install package
  2. Install VirtualBox 4.2.18 + extension pack 4.2.18
  3. Do not roll back the Guest additions in the Windows 7 VM (leave at 4.3.6)

Voila! Hope this helps everyone else who is facing this issue and hope this is not just a fluke that will go away after a reboot or something.

comment:10 follow-up: ↓ 11 Changed 18 months ago by Germi

I had the same problem and found a perfectly working solution WITHOUT disabling Mavericks 'Displays have separate spaces' functionality or the need to go back to a previous version (which btw didn't work for me).

Got into terminal and change the LSUIPresentationMode for the vmstarter.app and VirtualBoxVM.app as follows:

sudo defaults write /Applications/VirtualBox.app/Contents/Resources/vmstarter.app/Contents/Info.plist LSUIPresentationMode -int 4
sudo defaults write /Applications/VirtualBox.app/Contents/Resources/VirtualBoxVM.app/Contents/Info.plist LSUIPresentationMode -int 4
sudo chmod 644 /Applications/VirtualBox.app/Contents/Resources/VirtualBoxVM.app/Contents/Info.plist
sudo chmod 644 /Applications/VirtualBox.app/Contents/Resources/vmstarter.app/Contents/Info.plist

Restart Virtualbox and the problem is fixed.

Last edited 18 months ago by Germi (previous) (diff)

comment:11 in reply to: ↑ 10 Changed 18 months ago by Timbuktu

Thank you Germi! Those commands did the trick for me.

sudo defaults write /Applications/VirtualBox.app/Contents/Resources/vmstarter.app/Contents/Info.plist LSUIPresentationMode -int 4
sudo defaults write /Applications/VirtualBox.app/Contents/Resources/VirtualBoxVM.app/Contents/Info.plist LSUIPresentationMode -int 4
sudo chmod 644 /Applications/VirtualBox.app/Contents/Resources/VirtualBoxVM.app/Contents/Info.plist
sudo chmod 644 /Applications/VirtualBox.app/Contents/Resources/vmstarter.app/Contents/Info.plist

Restart Virtualbox and the problem is fixed.

comment:12 Changed 18 months ago by Govind

Tried the above workaround, it helps, but once you do cmd+F and try to make it full screen again, it looses the full screen..

So, this does looks like issue in the virtual box.. anybody looking at the issue????

comment:13 Changed 18 months ago by dirq

I applied the fix above but it didn't do anything for me. I still have the same problem where fullscreen is keeping space for the mac menu at the top and pushing the guest OS down off the screen.

Host: Mac OS 10.9.2 Guest: Win 7 64bit Virtual Box: 4.3.8 r92456 Monitors: 3 (including my MacBook Pro 15in Retina)

Version 0, edited 18 months ago by dirq (next)

comment:14 follow-up: ↓ 15 Changed 17 months ago by frank

Please check VBox 4.3.10.

comment:15 in reply to: ↑ 14 Changed 17 months ago by zoeker

Replying to frank:

Please check VBox 4.3.10.

Kudos for fixing this issue in 4.3.10!

comment:16 Changed 17 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

I will close this ticket. Please open separate tickets for related problems.

comment:17 Changed 17 months ago by dirq

Works for me! Awesome! THANK YOU

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use