VirtualBox

Ticket #12273 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

VirtualBox guest with >1 vCPU cannot access USB device

Reported by: hanxue Owned by:
Priority: major Component: USB
Version: VirtualBox 4.3.0 Keywords: usb filter port
Cc: hanxue.developer@… Guest type: Linux
Host type: Mac OS X

Description

On a Mac OS X 10.9 host with VirtualBox 4.3.0, the Linux guest cannot access any attached USB device.

This is the guest's configuration

USB device filtering is enabled. To be sure, an additional USB filter with Seagate's manufacturer code is used.

Even though the USB device - Seagate external hard disk- shows up in Virtualbox, the item is disabled and I cannot click on it.

The problem is only solved when I use 1 vCPU for the Linux guest.

I have seen https://www.virtualbox.org/ticket/7462, but the issue is still unsolved. For further reference:  http://davidoluwatimi.wordpress.com/2012/07/06/macosx-vbox-host-fix-ubuntu-usb-access/

Attachments

Linux_guest_3vCPU.png Download (56.4 KB) - added by hanxue 4 years ago.
Linux_guest_USB_filter.png Download (61.1 KB) - added by hanxue 4 years ago.
Seagate_disabled.png Download (105.8 KB) - added by hanxue 4 years ago.

Change History

Changed 4 years ago by hanxue

Changed 4 years ago by hanxue

Changed 4 years ago by hanxue

comment:1 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

This was fixed with VBox 4.3.12.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use