VirtualBox

Ticket #12224 (closed defect: fixed)

Opened 6 months ago

Last modified 7 weeks ago

Missing MSR_EBL_CR_POWERON(0x2A) caused GPU-Z BSOD => Fixed in SVN

Reported by: llyzs Owned by:
Priority: major Component: VMM
Version: VirtualBox 4.3.0 Keywords:
Cc: Guest type: Windows
Host type: all

Description

This BSOD is easy to reproduce by just download and run GPU-Z. However it's also very easy to fix by adding MSR_EBL_CR_POWERON(0x2A) in cpumQueryGuestMsrInt() function. Please consider fixing it.

Thanks.

Attachments

Screen shot 2014-01-09 at 9.01.40 pm VB display control panel.png Download (99.4 KB) - added by blueytoo 3 months ago.

Change History

comment:1 Changed 3 months ago by blueytoo

VB 4.3.6 on MacOS 10.6.8 Windows 7 Pro Guest.

I can confirm that running GPU-Z will crash VB and cause Windows to restart.

(There is also a problem with VRAM detection, which is why I wanted to run GPU-Z to start with. Will post on that separately when I figure where to put it.)

comment:2 Changed 3 months ago by frank

Many MSR fixes after 4.3.6, therefore could you check if this test build fixes the problem for you?

comment:3 Changed 3 months ago by blueytoo

Do you have extension pack too? (tried making up a url but it didn't work)

Last edited 3 months ago by blueytoo (previous) (diff)

comment:4 Changed 3 months ago by blueytoo

Current error message running GPU-Z could be due to lack of extensions/guest additions: "Could not start driver: The service cannot be started, either because it is disabled or because it has no enabled devices associated with it."

comment:5 Changed 3 months ago by frank

Just use the 4.3.6 Guest Additions. Where did you see this message?

comment:6 Changed 3 months ago by blueytoo

The message was from GPU-Z trying to install prior to updating the guest additions.

Installed guest additions (didn't realise they aren't part of extpack). GPU-Z installs and runs. No graphics card reported. Is that what it's meant to be?? (see screenshot)

comment:7 Changed 3 months ago by frank

Likely. The graphics adapter ("VirtualBox Graphics Adapter for Windows Vista and 7") is apparently successfully installed in your guest. The "unavailable" strings in your screenshot are probably the result of CPU-Z not knowing the VBox graphics adapter. To me it looks like your issue with the MSR is fixed with the 4.3.7 test build.

comment:8 Changed 3 months ago by blueytoo

OK. Thanks.

comment:9 Changed 3 months ago by frank

  • Summary changed from Missing MSR_EBL_CR_POWERON(0x2A) caused GPU-Z BSOD to Missing MSR_EBL_CR_POWERON(0x2A) caused GPU-Z BSOD => Fixed in SVN

comment:10 Changed 8 weeks ago by frank

Could you test  VBox 4.3.8 RC1?

comment:11 Changed 8 weeks ago by blueytoo

Seems to work fine as far as this bug goes, same as test build. Will run GPU-Z without crash. GPU-Z can't detect video adapter as before.

comment:12 Changed 8 weeks ago by blueytoo

I know it probably belongs somewhere else, but GPU-Z did detect VirtualBox Graphics Adapter for someone using VBox 3.x. See  http://www.geeks3d.com/20090621/quick-test-virtualbox-3-0-and-opengl-2-0/.

comment:13 Changed 7 weeks ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

The MSR issue is fixed in 4.3.8. GPU-Z not being able to detect the display adapter is most likely not a bug because VirtualBox emulates its own graphics card with some 3D extensions. If you don't agree, please open a separate ticket.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use