VirtualBox

Ticket #1221 (closed defect: fixed)

Opened 6 years ago

Last modified 4 years ago

Unreachable host interaface under gentoo host and windows xp guest -> fixed in SVN/1.6.2

Reported by: zabivator Owned by:
Priority: critical Component: other
Version: VirtualBox 1.5.6 Keywords:
Cc: Guest type: other
Host type: other

Description

I install virtualbox binary 1.5.6 under gentoo 2007.0 stable.

tsarev ~ # uname -a

Linux tsarev 2.6.23-gentoo-r8 #1 SMP Thu Feb 21 07:35:32 MSK 2008 i686 Intel(R) Pentium(R) 4 CPU 3.20GHz GenuineIntel GNU/Linux

tsarev ~ # brctl --version bridge-utils, 1.2

tsarev ~ # cat /etc/conf.d/net bridge_br0="eth0" config_eth0=( "null" ) config_br0=( "dhcp" ) tsarev ~ # ifconfig br0 Link encap:Ethernet HWaddr 00:18:F3:80:74:63

inet addr:192.168.19.210 Bcast:192.168.19.255 Mask:255.255.255.0 inet6 addr: fe80::218:f3ff:fe80:7463/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:1775179 errors:0 dropped:0 overruns:0 frame:0 TX packets:2192436 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:533221882 (508.5 Mb) TX bytes:1811075264 (1727.1 Mb)

eth0 Link encap:Ethernet HWaddr 00:18:F3:80:74:63

inet6 addr: fe80::218:f3ff:fe80:7463/64 Scope:Link UP BROADCAST RUNNING PROMISC MULTICAST MTU:1500 Metric:1 RX packets:847739 errors:0 dropped:0 overruns:0 frame:0 TX packets:1011709 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:510595453 (486.9 Mb) TX bytes:938385717 (894.9 Mb) Interrupt:18

lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0 inet6 addr: ::1/128 Scope:Host UP LOOPBACK RUNNING MTU:16436 Metric:1 RX packets:112 errors:0 dropped:0 overruns:0 frame:0 TX packets:112 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:6720 (6.5 Kb) TX bytes:6720 (6.5 Kb)

vbox0 Link encap:Ethernet HWaddr 00:FF:D3:AE:A4:40

inet6 addr: fe80::2ff:d3ff:feae:a440/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:1670371 errors:0 dropped:0 overruns:0 frame:0 TX packets:1954698 errors:0 dropped:4130 overruns:0 carrier:0 collisions:0 txqueuelen:500 RX bytes:721835127 (688.3 Mb) TX bytes:1547636525 (1475.9 Mb)

This configuration (permanent bridge) and Tun/Tap birdge work good on VirtualBox 1.5.2, VirtualBox 1.5.4, but on VirtualBox 1.5.6 guest os windows xp can't discovery network and send error "limited or no connectivity connection".

Change History

comment:1 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

This was a last-minute regression of 1.5.6. We updated all packages, please download a new package from our webserver.

comment:2 Changed 6 years ago by zabivator

Thanks! Great and quick work - i check now, it's work

comment:3 Changed 6 years ago by zabivator

  • Status changed from closed to reopened
  • Resolution fixed deleted

Reopen on 1.6.0 same enviroment (the same way for reproduce)

comment:4 Changed 6 years ago by hkottmann

Same problem here on openSuSE 10.3 host with Virtualbox 1.6.0, NAT is working, Host interface networking is not working anymore since I've upgraded from 1.5.6. The interfaces vbox0 - vbox4 are all there, they were listed by invoking the command "brctl show" as bridged to br0. The configuration is done as described in the user manual. Sometime the host interface can be brought up by reload the Virtualbox network (/etc/init.d/vboxnet restart) when the guest is started. Only that particular interface that belongs to the started guest will be active, the other ones (when I start a second guest afterwards) will not work.

comment:5 Changed 6 years ago by sandervl73

  • Summary changed from Unreachable host interaface under gentoo host and windows xp guest to Unreachable host interaface under gentoo host and windows xp guest -> fixed in SVN/1.6.2

Fixed already in SVN. Check 1.6.2 when it's out.

comment:6 Changed 6 years ago by sandervl73

  • Status changed from reopened to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use