VirtualBox

Ticket #12145 (closed defect: obsolete)

Opened 5 years ago

Last modified 3 months ago

CO_E_SERVER_EXEC_FAILURE (0x80080005)

Reported by: Mr_Inc Owned by:
Priority: major Component: VM control
Version: VirtualBox 4.2.18 Keywords: savestate headless
Cc: Guest type: Windows
Host type: Windows

Description

I start and run the VM (Guest Windows Home Server v1) using VMBoxManage in headless mode. When I attempt to savestate using (either in a CMD file or direct in a command line) I get this error.

VBoxManage.exe: error: Failed to create the VirtualBox object! VBoxManage.exe: error: Code CO_E_SERVER_EXEC_FAILURE (0x80080005) - Server execution failed (extended info not available) VBoxManage.exe: error: Most likely, the VirtualBox COM server is not running or failed to start.

I can reproduce this 100%.

If I run the VM from the GUI, the savestate from command line works fine. As sson as the VM is launched headless, savestate won't work,

Change History

comment:1 Changed 5 years ago by Mr_Inc

Forgot to add: Host is Windows 7 64 Bit. 16GB Memory.

comment:2 Changed 5 years ago by Mr_Inc

Also forgot mention that the same error occurs should I try to start the GUI whilst a headless VM is running.

Failed to create the VirtualBox COM object.

The application will now terminate.

Callee RC: CO_E_SERVER_EXEC_FAILURE (0x80080005)

Last edited 5 years ago by Mr_Inc (previous) (diff)

comment:3 Changed 4 years ago by operator error

I have same issue. Running a headless VM as a Windows Service on startup by VBoxVmService, which is set to log on as Administrator. Windows 7 Ultimate x64 host, Windows Server 2003 guest. Headless VM starts fine, I can Remote Desktop into it. When attempting to start VirtualBox GUI however, same error message appears:

Failed to create the VirtualBox COM object.

The application will now terminate.

Callee RC: CO_E_SERVER_EXEC_FAILURE (0x80080005)


Very little software on host machine, building it to run VBox only. I already ran into software interference during this build tho, so hopefully if it's another application we can narrow that down quick.

Through more testing I see this error is 100% reproducible. If I change the VBoxVmService startup type from Automatic to Manual and reboot (so that the headless VM is no longer started), I can bring up the VirtualBox GUI fine. If I change the service startup type back to Automatic and reboot, same error occurs.


For me personally, this issue is not a high priority. I plan on running this host off-site, I want the headless VM to run as a service, and I don't really need VBox GUI for anything anymore anyway (I already have the VM setup the way I wanted).

Last edited 4 years ago by operator error (previous) (diff)

comment:4 Changed 21 months ago by aeichner

  • Status changed from new to closed
  • Resolution set to obsolete

Please reopen if still relevant with a recent VirtualBox release.

comment:5 Changed 3 months ago by gregko

Don't understand why this was closed without giving any solution. I have an identical problem on Windows 10 64-bit [Version 10.0.16299.192], after installing VirtualBox 5.2.6, the latest at the moment.

Failed to acquire the VirtualBox COM object. The application will now terminate. Completely failed to instantiate CLSID_VirtualBox: CO_E_SERVER_EXEC_FAILURE. Result Code: CO_E_SERVER_EXEC_FAILURE (0x80080005) Component: VirtualBoxClientWrap Interface: IVirtualBoxClient {d2937a8e-cb8d-4382-90ba-b7da78a74573}

NONE of the answers given so far in this forum helped. I did try uninstalling/reinstalling many time, run as administrator, run in different compatibility modes (Windows 8, Windows 7...), tried editing VirtualBox.xml - none were found in .VirtualBox directory, so copied and edited from a "healthy" machine... Tried also built-in Windows 10 "Program Compatibility Troubleshooter", it said: "Issues found: Incompatible Program - Not fixed".

Any idea what else could be tried? Also, Hyper-V is disabled on this machine, VMware 10 works fine and runs virtual machines in it.

comment:6 Changed 3 months ago by socratis

@gregko

A couple of answers/observations:

  1. The ticket was closed because it was way too old (4 years old) and things change really fast in the software world. Hence, it was closed as "Obsolete".
  1. Not everything that has the same error code means that is the same problem, I'll give you a small example; File_Not_Found means that the file is not where it's supposed to be. It could have been deleted, moved, renamed or became unavailable. Four different actions resulting in the same error message. Generally, it's a good idea to expand the "Me too" message with the exact conditions that lead to the error.
  1. As I told you on the forums, reinstalling Windows seems like the best idea. And it actually was, since  you reported that everything is now working! :)

So, I guess the ticket can be be put to rest once again and closed as "Obsolete".

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use