VirtualBox

Ticket #12072 (closed defect: fixed)

Opened 7 months ago

Last modified 6 months ago

VBoxService.exe slowly eats up RAM => Fixed in SVN

Reported by: ada101 Owned by:
Priority: major Component: guest additions
Version: VirtualBox 4.2.6 Keywords:
Cc: Guest type: Windows
Host type: other

Description

I have a Windows 2000 virtual machine that I use as a server for a couple things and I find that the executable "VBoxService.exe" slowly rises in RAM usage. As you can see in the attached screenshot, "VBoxService.exe" has been running for nearly 19 days (due to the fact that I had to restart the VM after 25 days for the same issue) and VBoxService is using 386mb! I only have 512mb of RAM allocated to the VM so, as you can imagine, the last time it was up, the server was running quite slowly. My guess is that Shared Folders may be caching to the process and not being released as I use Shared Folders for the FTP on this machine.

A dodgy fix for this problem is to just go to Control Panel>Administrative Tools>Services and right-click "VBoxService.exe" and choose "Restart", but this is an inconvenience.

Attachments

ram.jpg Download (60.9 KB) - added by ada101 7 months ago.
A screenshot that shows RAM usage
2013-06-28-10-27-28.log Download (56.3 KB) - added by ada101 7 months ago.
The latest log i have so far
vbox-afterupdate.jpg Download (19.1 KB) - added by ada101 7 months ago.
RAM leak still persists after update
Screenshot.png Download (7.2 KB) - added by ada101 7 months ago.
Proof that VBoxService isn't eating RAM
memfixed.png Download (9.2 KB) - added by ada101 7 months ago.
10 Hours with no memory change

Change History

Changed 7 months ago by ada101

A screenshot that shows RAM usage

Changed 7 months ago by ada101

The latest log i have so far

comment:1 follow-up: ↓ 2 Changed 7 months ago by frank

Could you check the latest available version please (4.2.16)? Make sure to install the update the Guest Additions as well. Thank you!

comment:2 in reply to: ↑ 1 Changed 7 months ago by ada101

Replying to frank:

Could you check the latest available version please (4.2.16)? Make sure to install the update the Guest Additions as well. Thank you!

I will install now, you may need to wait a few days for RAM usage to rise tho, will report back then :)

comment:3 Changed 7 months ago by ada101

Virtualbox, Extension Pack and Guest Additions updated to 4.2.16. VM back up as well. Now we'll just have to wait and see...

Changed 7 months ago by ada101

RAM leak still persists after update

comment:4 Changed 7 months ago by ada101

If you look at the attachment I just posted, it looks like the RAM leak still exists, unless VBoxService is supposed to use 24mb of ram (which in all the years of using VirtualBox, the service usually uses 2-5mb.) Thank You.

I just found out you can embed images:

https://www.virtualbox.org/raw-attachment/ticket/12072/vbox-afterupdate.jpg

comment:5 Changed 7 months ago by ada101

is bumping allowed (Please don't kill me if it isn't)? It's nearing a week since a response :)

comment:6 follow-up: ↓ 7 Changed 7 months ago by frank

Yes, bumping is allowed and no, we wouldn't kill you :) Had no time to investigate further, you are probably aware of all the other tickets. But your problem wouldn't get lost. The problem is also that reproducing takes a lot of time.

comment:7 in reply to: ↑ 6 Changed 7 months ago by ada101

Replying to frank:

Yes, bumping is allowed and no, we wouldn't kill you :) Had no time to investigate further, you are probably aware of all the other tickets. But your problem wouldn't get lost. The problem is also that reproducing takes a lot of time.

Thank you! I did find a couple of tickets/forum threads about this issue, but they were using ~VitrualBox 3 and were only having the issue with the headless edition of VirtualBox. My problem seems to be different as i'm using normal VirtualBox and Windows 2000. I do understand that it takes a while to reproduced, tho :).

comment:8 follow-ups: ↓ 9 ↓ 10 Changed 7 months ago by sunlover

ada101, please try the following:

In the W2K guest, open regedit.exe and edit the following key: HKLM\SYSTEM\CurrentControlSet\Services\VBoxService\ImagePath = "system32\VBoxService.exe --disable-vminfo"

Reboot the guest and check if VBoxService.exe still leaks memory. Thanks.

comment:9 in reply to: ↑ 8 Changed 7 months ago by ada101

Replying to sunlover:

ada101, please try the following:

In the W2K guest, open regedit.exe and edit the following key: HKLM\SYSTEM\CurrentControlSet\Services\VBoxService\ImagePath = "system32\VBoxService.exe --disable-vminfo"

Reboot the guest and check if VBoxService.exe still leaks memory. Thanks.

The original was just "system32\VBoxService.exe". I have changed it to your value and rebooted. Will just have to wait and see what happens. VBoxService is at 2.7mb after reboot, by the way :) .

comment:10 in reply to: ↑ 8 Changed 7 months ago by ada101

Replying to sunlover:

ada101, please try the following:

In the W2K guest, open regedit.exe and edit the following key: HKLM\SYSTEM\CurrentControlSet\Services\VBoxService\ImagePath = "system32\VBoxService.exe --disable-vminfo"

Reboot the guest and check if VBoxService.exe still leaks memory. Thanks.

This seems to have worked! The RAM usage is staying at 2.7mb! Now we just need to work out why this component is leaking RAM?

comment:11 follow-up: ↓ 12 Changed 7 months ago by frank

Great finding, thanks for testing! We are analyzing ...

comment:12 in reply to: ↑ 11 Changed 7 months ago by ada101

Replying to frank:

Great finding, thanks for testing! We are analyzing ...

Great to hear! I can always test more out in the VM if you need!

*Unfortunately the server that hosts the VMs will be down for 2 weeks starting next wednesday tho, so I won't be able do 24/7 uptime (very unfortunate).

comment:13 follow-up: ↓ 14 Changed 7 months ago by pentagonik

Could you please download and install a test build of the 4.2 Guest Additions from here:  http://www.virtualbox.org/download/testcase/VBoxGuestAdditions_4.2.19-89250.iso

This should fix the memory leak you reported. Please let me know if this new test build works for you or not. Thanks!

comment:14 in reply to: ↑ 13 ; follow-up: ↓ 15 Changed 7 months ago by ada101

Replying to pentagonik:

Could you please download and install a test build of the 4.2 Guest Additions from here:  http://www.virtualbox.org/download/testcase/VBoxGuestAdditions_4.2.19-89250.iso

This should fix the memory leak you reported. Please let me know if this new test build works for you or not. Thanks!

I am making a clone of the VM and will update the additions on that. Remember that the server is going down tomorrow so I can only do limited testing, but I will try to test from my PC instead :)

comment:15 in reply to: ↑ 14 Changed 7 months ago by ada101

The VM has been up for 10min now with no issues yet! I'm pretty sure it is fixed, but i'll leave it on for a few more hours for confirmation! Thanks!

Changed 7 months ago by ada101

Proof that VBoxService isn't eating RAM

Changed 7 months ago by ada101

10 Hours with no memory change

comment:16 Changed 7 months ago by ada101

After 10 hours uptime with no memory change, i'm classing as fixed!

https://www.virtualbox.org/raw-attachment/ticket/12072/memfixed.png

comment:17 Changed 7 months ago by frank

  • Summary changed from VBoxService.exe slowly eats up RAM to VBoxService.exe slowly eats up RAM => Fixed in SVN

Thank you for your report and for your feedback!

comment:18 Changed 6 months ago by ulogic

I also had a virtual machine running Windows 2000. This machine had 1 GB of RAM allocated to it. About a week ago, I noticed VBoxService was using over 750 MB. It had been running version 4.2.10. The VirtualBox change log showed a fix for a memory leak in VBoxService in 4.2.8, but nothing since. I upgraded to 4.2.18 which was the latest at the time, but VBoxService was still consuming memory at a rate of 22 MB per day, or just under 1 MB per hour. Using the link for the ISO file above, I installed the 4.2.19 guest additions 31 hours ago, and the memory usage has only gone up by 16 KB to 3836 KB.

Thank you for the update.

comment:19 Changed 6 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in VBox 4.3. The next VBox 4.2.x release will contain this fix as well.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use