VirtualBox

Ticket #12063 (new defect)

Opened 4 years ago

Last modified 3 years ago

Using Windows 8.1 RTM and Virtualbox 4.2.16 with bridge networking component installed results in shutdown and sleep problems

Reported by: Immunologist Owned by:
Priority: critical Component: network
Version: VirtualBox 4.2.16 Keywords: network bridge, sleep, widowns 8.1
Cc: Guest type: Windows
Host type: Windows

Description

Using Windows 8.1 RTM single language (English, activated with serial provided with PC) and Virtualbox 4.2.16 with bridge networking component installed results in shutdown and sleep problems. The display becomes dim and HDD spins down (on notebook) but the power led is on and coolers continue to work. Changing drivers for network cards, video, motherboard, etc doesn't help. Reinstalling Virtualbox with bridge networking switched off (NAT is on) helps to completely resolve the issue. Devices used: HP envy 4 touchsmart, Acer iconia tab w700.

Change History

comment:1 Changed 4 years ago by BeardedOnion

I am also experiencing this on a Lenovo ThinkPad T410. The problem is only with Windows 8.1 RTM host (Win8 host worked fine). Both VB 4.2.16 and VB 4.2.18 have the problem and I've tried with a clean Win8.1 install and an upgrade from Win8 to 8.1. As soon as VBox is installed with Bridged Networking capabilities I lose the ability to sleep or hibernate my host, regardless of guest or guest status. The display goes dark and the drive status goes dark, but the PC does not hibernate or sleep.

comment:2 Changed 4 years ago by NunoRelvao

After upgrading to 8.1 RTM i also had this problem, seems that by removing Bridge Network and using only NAT solves the problem...

But there are other problems similar to this reported in ticket : #11948

https://www.virtualbox.org/ticket/11948

comment:3 Changed 4 years ago by Maakuth

I can confirm that this also happens with on Asus Zenbook UX32VD with Win8.1 RTM x64 and VirtualBox 4.2.18. Forced poweroff is required to bring the host back up. Works fine when VBox is installed without bridge adapter.

comment:4 Changed 4 years ago by jwyckoff

also issue with Dell e4310

comment:5 Changed 4 years ago by Th14g0

I can confirm.. this issue with Lenovo T430

comment:6 Changed 4 years ago by zollverein

Same here on lenovo T430s running 8.1

comment:7 Changed 4 years ago by PaulD

Confirm too on Lenovo X201 / windows 8.1

comment:8 Changed 4 years ago by SnoRider

Confirm on Acer Aspire S7-392-9890 running 8.1 and VB 4.2.18. Works fine without virtual bridged networking adaptor.

comment:9 Changed 4 years ago by rubinho76

Same issue here on Fujitsu Lifebook S760 / Host OS: Windows 8.1 Pro x64 RTM / VBox Version 4.2.18 and 4.3 RC1 / Reason: Vbox Bridget Network Driver

Last edited 4 years ago by rubinho76 (previous) (diff)

comment:10 Changed 4 years ago by bobs

This could be a similar problem to what I'm seeing - I've just updated #11608 with a memory dump using a checked build of ndis.sys, in the hope this will help solve it.

comment:11 Changed 4 years ago by JBourne

Confirm on Lenovo Y580 running Windows 8.1. VBox version 4.2.18

comment:12 Changed 4 years ago by Atmis

Same problem with VBox version 4.3 on a Dell E6220 and Windows 8.1 x64 RTM FR.

comment:13 Changed 4 years ago by klaus

We're working on it... it's the reason why none of the recent VirtualBox releases are officially supported on Windows 8.1 (and Server 2012 R2) hosts.

comment:14 Changed 4 years ago by chuckja

I just applied the updates Microsoft made available today for Windows 8.1 RTM and this problem seems to have disappear.

comment:15 Changed 4 years ago by chuckja

I forgot to add I am running Virtualbox 4.3.

comment:16 Changed 4 years ago by Atmis

I confirm that the problem seems to have diseappeared after I applied the patches made available by Microsoft today (KB2884846, KB2883200, KB2895219)

comment:17 Changed 4 years ago by followingsun

Solved with Windows 8.1 update.

Last edited 4 years ago by followingsun (previous) (diff)

comment:18 Changed 4 years ago by klaus

We also observed that the problems disappear after installing KB2883200, even though the description doesn't hint it will address such an issue.

comment:19 Changed 4 years ago by zburns

My host - Windows 8.1 RTM - on a Lenovo Yoga Pro 2 - with all drivers and updates as of 10-28-2013 will suspend and sleep properly, however when I attempt to log back into to Windows after a sleep, the keyboard (physical, virtual or on screen keyboard) doesn't work - the CTRL and ALT keys work, but no letters, so impossible to log in.

comment:20 Changed 4 years ago by NathanM

Lenove ThinkPad Edge 15, Windows 8.1, same issue.

comment:21 Changed 4 years ago by Greg L

Same issue for me before installing windows updates Brand new Lenovo y510p, Windows 8.1 VirtualBox 4.2.16 and 4.3.4 both exhibit the issue with Sleep and Hibernate...

Then I installed All Windows updates (through 2013-12-17) and sleep/hibernate work again.

UPDATE: yes, sleep and hibernate work, but Virtualbox (4.3.4) crashes about 50% of the time now with "Failed to create the VirtualBox COM object"

Last edited 4 years ago by Greg L (previous) (diff)

comment:22 Changed 3 years ago by amilanadeera

Thanks everyone... It works fine when VBox is installed without bridge adapter

comment:23 Changed 3 years ago by bulrush

Same problem here. Resume from sleep allows internet to work, resume from hibernate = no internet.

This problem still exists in Virtualbox 4.3.12. Vbox 4.3.14 doesn't run the guest (Ubuntu) at all.

Host: Windows 8.0 on HP Envy 700-074, 12GB ram, 1TB hard drive, Avast antivirus

Graphics

AL1716 (1280x1024@60Hz) Intel HD Graphics 4600 (HP)

Guest: Ubuntu 14.04.1 server

Detailed specs via Speccy available on request.

Steps:

  • Install Virtualbox 4.3.14 on Windows 8. Then installed Ubuntu 14.04.1 desktop.
  • Found it does not run the guest OS (Ubuntu) at all.
  • I was also getting an error about piix4.
  • Uninstalled Vbox, rebooted PC.
  • Installed Vbox 4.3.12. Installed Ubuntu 14.04.1 server this time (it's smaller and does not include the desktop)
  • My keyboard puts PC into suspend mode, where the memory is written to disk, and the PC is turned off. When I come out of suspend, there is no network connection to the internet, even after waiting 5 minutes.
  • Reboot PC and internet works fine.
  • Try "sleep" mode, which doesn't completely power down PC, come out of sleep mode, and internet works fine.
  • I never had a problem before installing Virtualbox.

If you need bios settings, it would be handy to have a Win 8 util to dump those to a text file.

Don't I need the bridge adapter so my guest (Ubuntu) can reach the internet? I'd like to update some packages and install some Perl modules on the Ubuntu guest.

Last edited 3 years ago by bulrush (previous) (diff)

comment:24 Changed 3 years ago by vipiny35

obviously removing V-Box Networking Bridge Driver helps, but what about accessing internet on guests?

comment:25 Changed 3 years ago by jmfm

After migrating to 4.3.20 the bridged networking stop working (using wireless or wired connection). My guest is WINXP SP3 and my host is WIN 8.1 64 bits

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use