VirtualBox

Ticket #11977 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

Freebsd 9.1 Guest on OSX Mountain Lion NAT - wrong source IP

Reported by: b2jrock Owned by:
Priority: major Component: network/NAT
Version: VirtualBox 4.2.16 Keywords:
Cc: Guest type: BSD
Host type: other

Description

I am using a FreeBSD 9.1 Guest on an OSX Mountain Lion Host. I have a NAT interface configured:

192.168.168.1 - Host's vboxnet0 IP address. 192.168.168.18 - Guest's NAT IP.

When I make any tcp connection from the guest to the host, the source IP of the connection is the host's vboxnet0 IP (192.168.168.1). My expectation is that the source IP for the connection should be the guest's NAT IP, which indeed it is on other non-bsd guest OSs (linux tested).

This causes problems with services that need to allow particular IPs, such as NFS

This also happens with OSX guests, as noted here: https://www.virtualbox.org/ticket/11965

Change History

comment:1 Changed 4 years ago by klaus

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #11965, and I have a hard time believing that this is different with Linux guest. Please provide more details in ticket #11965.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use