VirtualBox

Ticket #11946 (closed defect: fixed)

Opened 10 months ago

Last modified 7 months ago

guest additions do not build with 3.11 kernel

Reported by: robatino Owned by:
Priority: major Component: other
Version: VirtualBox 4.2.16 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

Error from Fedora Rawhide x86_64 guest with the first 3.11 kernel:

depmod: WARNING: /lib/modules/3.11.0-0.rc0.git2.1.fc20.x86_64/kernel/drivers/char/crash.ko needs unknown symbol page_is_ram
Error! Bad return status for module build on kernel: 3.11.0-0.rc0.git2.1.fc20.x86_64 (x86_64)
Consult /var/lib/dkms/vboxguest/4.2.16/build/make.log for more information.

Attachments

make.log Download (9.1 KB) - added by robatino 10 months ago.
/var/lib/dkms/vboxguest/4.2.16/build/make.log
VBox.log Download (93.0 KB) - added by robatino 10 months ago.
VBox.log

Change History

Changed 10 months ago by robatino

/var/lib/dkms/vboxguest/4.2.16/build/make.log

Changed 10 months ago by robatino

VBox.log

comment:1 Changed 9 months ago by smo

The problem is due to the removal of readdir from struct file in linux 3.11 in favour of a new field - iterate.

For inspiration on how to fix, perhaps one could look at the patch for the equivalent VMWare functionality shown at  http://mysticalzero.blogspot.dk/2013/07/vmblock-patch-for-linux-311-rc1-vmware.html.

comment:3 Changed 8 months ago by robatino

With VirtualBox 4.2.18, the guest additions build successfully both for 3.11 and the early 3.12 kernels, so hopefully there will be no additional problems with 3.12. Unfortunately, after installing the GA, X no longer comes up properly - I just get a black screen of the expected resolution. I can get to a VT, though.

comment:4 Changed 8 months ago by robatino

Although the guest additions were building with the earlier 3.12 kernels, they don't with the latest (kernel-3.12.0-0.rc0.git14.2.fc21). Filed https://www.virtualbox.org/ticket/12083 .

comment:5 Changed 7 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use