VirtualBox

Ticket #11861 (closed defect: duplicate)

Opened 9 years ago

Last modified 8 years ago

problem starting VirtualBox, deleting a HDD file or deleting a snapshot

Reported by: Cosmin Owned by:
Component: VMM Version: VirtualBox 4.2.12
Keywords: Cc:
Guest type: all Host type: Windows

Description

In 1/10 starts I have to wait minutes and it finally shows the message "Failed to create the VirtualBox Com object. The application will now terminate. Details: Callee RC: CO_E_SERVER_EXEC_FAILURE (0x80080005)". The problem has the same cause as the error I sometimes receive when I try to delete something in "Virtual media manager". It says that "is still attached to 1 virtual machines" even if the virtual machine is closed. And when I'm trying to delete a snapshot - same problem. It doesn't happen very often (about 1 in 10 starts) but it is annoying. Could you please fix it...? Thank you.

Regards, Cosmin

Attachments

VBoxSVC log.zip Download (997 bytes) - added by Cosmin 9 years ago.

Change History

Changed 9 years ago by Cosmin

comment:1 Changed 9 years ago by paul.tiplady

I am hitting the same issue; the key logs in my VBoxSVC.log file are:

VirtualBox COM Server 4.2.16 r86992 win.amd64 (Jul 4 2013 15:51:44) release log ... 00:01:42.118000 main ERROR [COM]: aRC=VBOX_E_OBJECT_IN_USE (0x80bb000c) aIID={29989373-b111-4654-8493-2e1176cba890} aComponent={Medium} aText={Medium 'F:\VMs\devbox\devbox.vdi' cannot be closed because it is still attached to 1 virtual machines}, preserve=false 00:01:42.134000 Watcher ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={3b2f08eb-b810-4715-bee0-bb06b9880ad2} aComponent={VirtualBox} aText={The object is not ready}, preserve=false

I've tried reinstalling VirtualBox, (removing the .VirtualBox directory before reinstalling), and this problem resurfaced after a few hours of using the VM. I've seen this on 4.2.10 and 4.2.16.

Looks like some sort of permissions issue, because if I run VirtualBox as administrator the GUI starts up correctly.

comment:2 Changed 9 years ago by paul.tiplady

I should just add that running VirtualBox as Administrator has completely shafted the permissions on my host machine's repo -- many of the folders that I shared with the guest now have owner=Admin on the host. I'd strongly advise against using the workaround that I suggested above.

comment:3 Changed 8 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

This is most likely a duplicate of #12509. Please continue the discussion there. Could you try the test build posted there?

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use