VirtualBox

Ticket #11804 (closed defect: obsolete)

Opened 9 years ago

Last modified 6 years ago

Guests on OSX 10.8.3 hosts bridged tagged-vlan interface only see arp & udp traffic ( no tcp )

Reported by: feralandabberrant Owned by:
Component: network Version: VirtualBox 4.2.12
Keywords: OSX VLAN BRIDGED TAGGED 802.1q Cc:
Guest type: all Host type: Mac OS X

Description

I have a few OS X 10.8.3 machines ( 2x MacBookPro + 1xMacPro ) running VirtualBox 4.2.12 r84980. The host has access to 3 networks via en0. Untagged vlan 10 & tagged vlan 20 & 30. I've created two virtual interfaces off of the tagged vlans ( vlan0 = 20 & vlan1 = 30 ).

When I set a guests network access to 'bridged' on vlan0 or vlan1 - they guest is able to get an IP, and see the dhcp settings - but unable to connect to any of the other devices off of the host. Guests can ping other devices on the host - and the host, if the host has an ip on that network - but not the dhcp server, the gateway or the dns servers.

TCP dump on the guests shows ARP & UDP traffic - but not TCP.

Guests tested include:

  • Windows 7 Ultimate 64bit
  • Windows 8 Pro 64bit
  • Debian wheezy 64bit
  • Ubuntu ( BT5r3 ) 32bit
  • OS X 10.8.3 64bit
  • OS X 10.6.3 32bit
  • OpenBSD 5.3 64bit

All available NIC combinations were tried ( except on the OSX guests - they're a bit princess like )

Change History

comment:1 Changed 6 years ago by aeichner

  • Status changed from new to closed
  • Resolution set to obsolete

Please reopen if still relevant with a recent VirtualBox release.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use