VirtualBox

Ticket #11719 (closed defect: fixed)

Opened 12 months ago

Last modified 10 months ago

guestproperty set does not persist => Fixed in SVN

Reported by: PassinThru Owned by:
Priority: major Component: guest control
Version: VirtualBox 4.2.12 Keywords: guestproperty
Cc: Guest type: Linux
Host type: Windows

Description

Setting a guestproperty does not persist between boots. This is a regression.

The Host is Windows 7. The Guest is Ubuntu 13.04 beta.

With the guest booted, I run

VBoxManage guestproperty set "<VM name>" /VirtualBox/GuestAdd/SharedFolders/MountDir <guest mount path>

I verify it has been set with "enumerate". I shutdown the VM.

After shutdown, the VM's vbox file contains a single line for guest properties:

<GuestProperties/>

unaltered by my set command. On booting, enumerate does not show the property.

This is a relatively new VM. On an older VM, whose vbox file shows a lits of GuestProperties, they are not updated. For example, /VirtualBox/GuestAdd/Version shows as 4.2.10 in the vbox file, but 4.2.12 when the guest is running and enumerate is run.

Attachments

Ubuntu 13.04 64-bit beta.vbox Download (7.6 KB) - added by PassinThru 12 months ago.
vbox file after running getproperty set command
VBox.log Download (103.5 KB) - added by PassinThru 12 months ago.
Log file for the VM

Change History

Changed 12 months ago by PassinThru

vbox file after running getproperty set command

Changed 12 months ago by PassinThru

Log file for the VM

comment:1 follow-up: ↓ 2 Changed 12 months ago by michael

Do other operations on the machines change the XML configuration files?

comment:2 in reply to: ↑ 1 Changed 12 months ago by PassinThru

Replying to michael:

Do other operations on the machines change the XML configuration files?

Yes - if I add a directory to the Share Folders, for example, it is reflected in the XML file. I've only seen this problem with guest properties - only they seem to be unsaved.

comment:3 Changed 11 months ago by frank

I cannot reproduce this. I assume that your VM or the VBoxSVC daemon crashes during shutdown. Can you always reproduce this problem?

comment:4 Changed 11 months ago by PassinThru

I can always reproduce this. Neither the VM nor VBoxSVC.exe crash during shutdown.

Is there anything I can provide to help with this?

comment:5 Changed 11 months ago by frank

Sorry for the confusion, now I can reproduce it as well. This problem will be fixed in the next maintenance release. Thank you for the report!

comment:6 Changed 11 months ago by frank

  • Summary changed from guestproperty set does not persist to guestproperty set does not persist => Fixed in SVN

It would be great if you could try  this test build and could confirm that the problem is really fixed. Thank you!

comment:7 Changed 11 months ago by PassinThru

Indeed it does - I now see GuestProperty lists in my .vbox file, and the changes I make persist. Thank you for fixing this!

comment:8 Changed 10 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 4.2.14.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use