VirtualBox

Ticket #117 (closed enhancement: invalid)

Opened 7 years ago

Last modified 7 years ago

[doc-request] Add note that VM must be powered down prior to adding sharedfolder

Reported by: kgs_mvs Owned by:
Priority: minor Component: other
Version: VirtualBox 1.3.4 Keywords:
Cc: Guest type: other
Host type: other

Description

I had saved the state of the virtual machine (xinwp-en) and virtual box was not running at the time. I tried to create a shared folder and got the following error message:

kgsnow@laptop:/etc$ VBoxManage sharedfolder add "winxp-en" -name "hosthome" -hostpath "/home/kgsnow"
VirtualBox Command Line Management Interface Version 1.3.4
(C) 2005-2007 InnoTek Systemberatung GmbH
All rights reserved.

[!] FAILED calling machine->CreateSharedFolder(Bstr(name), Bstr(hostpath)) at line 5529!
[!] Primary RC  = 0x80070005
[!] Full error info present: true , basic error info present: true
[!] Result Code = 0x80070005
[!] Text        = The machine is not mutable
[!] Component   = Machine, Interface: IMachine, {fd443ec1-0009-4f5b-9282-d72760a66916}
[!] Callee      = IMachine, {fd443ec1-0009-4f5b-9282-d72760a66916}
[!] FAILED calling machine->SaveSettings() at line 5532!
[!] Primary RC  = 0x80070005
[!] Full error info present: true , basic error info present: true
[!] Result Code = 0x80070005
[!] Text        = The machine is not mutable
[!] Component   = Machine, Interface: IMachine, {fd443ec1-0009-4f5b-9282-d72760a66916}
[!] Callee      = IMachine, {fd443ec1-0009-4f5b-9282-d72760a66916}

The cause of the error wasn't readily clear to me and I was reading section 5.4 of the user's guide at the time I tried to do this. It would be nice if the user doc had a note that simply mentioned that sharedfolders can only be added to virtual machines when the vm is in a powered down state. Thank you.

Change History

comment:1 Changed 7 years ago by klaus

  • Status changed from new to closed
  • Resolution set to invalid

You can configure a new shared folder while a VM is running, saved etc., just not permanent ones. Specify -transient. It's documented in the manual.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use