VirtualBox

Ticket #11607 (closed defect: duplicate)

Opened 13 months ago

Last modified 12 months ago

VirtualBox crash on guest shutdown when remoted into host.

Reported by: mjm Owned by:
Priority: major Component: other
Version: VirtualBox 4.2.10 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

Windows 7 64b host, Windows XP 32b guest. VirtualBox 4.2.8 & 4.2.10 crashes on guest shutdown when remoted into host via normal RDP. This did not occur on 4.2.4. Only occurs once Guest Additions are installed.

Windows Event Log: Faulting application name: VirtualBox.exe, version: 4.2.10.0, time stamp: 0x51436501 Faulting module name: QtGuiVBox4.dll, version: 4.7.3.0, time stamp: 0x50085ba6 Exception code: 0xc0000005 Fault offset: 0x000000000018c06c Faulting process id: 0xf40 Faulting application start time: 0x01ce23161860a2fe Faulting application path: C:\Program Files\VirtualBox\VirtualBox.exe Faulting module path: C:\Program Files\VirtualBox\QtGuiVBox4.dll Report Id: 62e24002-8f09-11e2-8bd8-50e5493b0b1f

Attachments

VBox.log Download (85.2 KB) - added by mjm 13 months ago.
VBox.log
VBoxSVC.log Download (2.8 KB) - added by mjm 13 months ago.
VBoxSVC.log
VirtualBox_dmp.zip Download (327.1 KB) - added by mjm 12 months ago.
Minidump form Virtualbox.exe app crash.

Change History

Changed 13 months ago by mjm

VBox.log

Changed 13 months ago by mjm

VBoxSVC.log

Changed 12 months ago by mjm

Minidump form Virtualbox.exe app crash.

comment:1 Changed 12 months ago by mjm

Still occurring under 4.2.12. Including a minidumd from 4.2.12.

Faulting application name: VirtualBox.exe, version: 4.2.12.0, time stamp: 0x5167d6dc Faulting module name: QtGuiVBox4.dll, version: 4.7.3.0, time stamp: 0x50085ba6 Exception code: 0xc0000005 Fault offset: 0x000000000018c06c Faulting process id: 0xce0 Faulting application start time: 0x01ce3c994a3fb6d6 Faulting application path: C:\Program Files\VirtualBox\VirtualBox.exe Faulting module path: C:\Program Files\VirtualBox\QtGuiVBox4.dll Report Id: a223dc99-a88c-11e2-84cd-50e5493b0b1f

comment:2 Changed 12 months ago by michael

We have just fixed a crash on shut-down which sounds similar to what you are reporting. If you are able to reproduce it reliably, you might want to give this test build (usual disclaimers<1> apply) a try:

 http://www.virtualbox.org/download/testcase/VirtualBox-4.2.13-85138-OSX.dmg

<1> wiki:Testbuilds

comment:4 Changed 12 months ago by mjm

Unfortunately, 4.2.13-85138 does not fix my issue.

Faulting application name: VirtualBox.exe, version: 4.2.13.0, time stamp: 0x5171038b Faulting module name: QtGuiVBox4.dll, version: 4.7.3.0, time stamp: 0x50085ba6 Exception code: 0xc0000005 Fault offset: 0x000000000018c06c Faulting process id: 0xedc Faulting application start time: 0x01ce3db8e9939423 Faulting application path: C:\Program Files\VirtualBox\VirtualBox.exe Faulting module path: C:\Program Files\VirtualBox\QtGuiVBox4.dll Report Id: 44a1a47a-a9ac-11e2-b1d6-50e5493b0b1f

comment:5 Changed 12 months ago by mjm

This ticket can be closed, this seems to be the same or related to several other tickets, like #11426. In fact, the work-around that the user described in ticket #11426 works for me also.

Last edited 12 months ago by frank (previous) (diff)

comment:6 Changed 12 months ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Thank you. I will close this one as duplicate. We will try to reproduce and fix this problem.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use