VirtualBox

Ticket #1152 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

Virtualbox Closes without warning or error when launching VM

Reported by: thndrchld Owned by:
Priority: major Component: other
Version: VirtualBox 1.5.4 Keywords: ose vboxdrv crash
Cc: Guest type: other
Host type: other

Description

I'm not sure what caused this, but here's the backstory:

Vbox has been installed on my machine for a couple of months. Recently, we had a power failure at the office while virtualbox was running. When the power came back on, vboxdrv had vanished. I attempted to reinstall vboxdrv.ko from the virtualbox archive, and it partially fixed the problem. However, instead of getting an error about a missing kernel driver, the vm simply closes without warning or error message, and the status of the VM shows 'Aborted'. I have check everything I can think of. I have tried removing and reinstalling Vbox, to no avail.

One thing I did notice is that when I attempted to install the vboxdrv.ko file, I accidently obtained it from the regular release of vbox, while I was running the ose version. I don't know if that would be part of the problem. I realized this and attempted to remove the vboxdrv.ko file and replace with the one from the ose archive, but I couldn't find the vboxdrv.ko file in the ose archive.

Any help would be appreciated.

I can submit any files you require. Please contact me if you need more information. My email address is thndrchld at gmail dot com (gotta keep the spam at bay, you know)

Change History

comment:1 follow-up: ↓ 3 Changed 6 years ago by michael

The problem is probably that the version of vboxdrv you installed doesn't install your version of VirtualBox. Perhaps you could try completely reinstalling VirtualBox. This should not affect your virtual machines in any way.

comment:2 Changed 6 years ago by michael

Sorry, I meant "doesn't match your version of VirtualBox" of course.

comment:3 in reply to: ↑ 1 Changed 6 years ago by thndrchld

Replying to michael:

The problem is probably that the version of vboxdrv you installed doesn't install your version of VirtualBox. Perhaps you could try completely reinstalling VirtualBox. This should not affect your virtual machines in any way.

I've tried that several times. I've gone so far as to sudo apt-get autoremove virtualbox-ose and all it's dependencies. That didn't seem to help any.

comment:4 follow-up: ↓ 5 Changed 6 years ago by michael

Did you install VirtualBox from our website (or at least our .deb repository) or from your distribution? If it was from your distribution, perhaps you could try installing the version from VirtualBox.org? I'm afraid that (for obvious reasons!) we can't help much with installation problems to do with packages which we didn't create ourselves.

comment:5 in reply to: ↑ 4 Changed 6 years ago by thndrchld

Replying to michael:

Did you install VirtualBox from our website (or at least our .deb repository) or from your distribution? If it was from your distribution, perhaps you could try installing the version from VirtualBox.org? I'm afraid that (for obvious reasons!) we can't help much with installation problems to do with packages which we didn't create ourselves.

Originally, I installed the (ose) version from the canonical apt-get repository. During my repair efforts, however, I attempted to remove the ose version and install the official 1.5.4 non-ose version from the vbox website. It failed also, citing an inability to overwrite the vboxdrv.ko file that was used by package virtualbox-something-ose.deb. The file in question, however, did not exist. I tried clearing the apt cache, autoremoving all traces of vbox, etc. Nothing helped, however, and I always got the same error.

comment:6 in reply to: ↑ description Changed 6 years ago by thndrchld

OK, I have managed to resolve the problem. I had to run sudo dpkg --force-overwrite -iB virtualbox_package.deb

That seemed to fix the problem, as my VMs will launch now. I'm still having a problem with my networking (everything on the windows network is disgustingly slow), but I think that's unrelated and caused by a network glitch the other day.

I'm not sure how to close this ticket, so if there's a mod or admin handy, please close this ticket and mark it resolved.

Thanks for the help.

comment:7 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use