Opened 11 years ago

Last modified 5 years ago

#11517 new defect

VBoxSDL error before launching VM

Reported by: Max D Owned by:
Component: other Version: VirtualBox 4.2.6
Keywords: vboxsdl Cc:
Guest type: all Host type: Windows


In version 4.2.6 under Windows 7 SP1 x64, when trying to start a VM using VBoxSDL, I get the following error (regardless of the VM) :

SDL Error: 'DirectInputDevice::SetDataFormat: Invalid parameters'

It also happens from a freshly created VM :

C:\Program Files\Oracle\VirtualBox>vboxmanage createvm --name test --ostype Debian_64 --register
Virtual machine 'test' is created and registered.
UUID: 2cbfe35a-fd26-44e3-90a3-9a6e31f406f3
Settings file: 'D:\VMs\VirtualBox\test\test.vbox'

C:\Program Files\Oracle\VirtualBox>vboxsdl --startvm test
Oracle VM VirtualBox SDL GUI version 4.2.6
(C) 2005-2012 Oracle Corporation
All rights reserved.

SDL Error: 'DirectInputDevice::SetDataFormat: Invalid parameters'

No VBox.log is generated and nothing appears in the VBoxSVC.log.

Attachments (3)

VBox.log (68.9 KB ) - added by H.Hopper 10 years ago.
vboxsdl ose log on x64 windows host
VBox-ose.log (92.1 KB ) - added by H.Hopper 10 years ago.
second log x64 guest but ose build of most files
VBox-1.log (68.6 KB ) - added by H.Hopper 10 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 by Max D, 11 years ago

Same in 4.2.12

comment:2 by JoakimS, 11 years ago

I'm still experiencing this in 4.2.16 r86992.

Is there any workaround for this, or plans to fix it?

comment:3 by Frank Mehnert, 11 years ago

VBoxSDL is not actively maintained anymore. We suggest you to switch to the normal VirtualBox GUI. You should be able to configure it to meet your requirements.

comment:4 by H.Hopper, 10 years ago

Does that mean VBoxSDL will be removed in future versions? Or will we get SDL2?

Just to add some extra findings on this:

The same error happens on 4.3.12 (and 4.3.14...).

I've compiled 4.3.12 OSE using SDL 1.2.15 (current the latest 1.2) on x64 Windows 7. Building SDL with VS2010 will fix the msvcr80.dll missing and things like that.


It's confirmed: vboxsdl OSE 4.3.12 works in command line on Windows x64. Here is a link with the proof:

Sorry, I didn't run windows with full ose in 'windows test mode' I've replaced the official Windows x64 VBox sdl version with the built OSE binary to run on x64 Windows, and VMs work fine.

I don't consider it a clean fix but it works. Please make VboxSDL work in the official Windows release of VirtualBox, as it works in Linux.

I'll try to provide some logs later.

Regards, H.

by H.Hopper, 10 years ago

Attachment: VBox.log added

vboxsdl ose log on x64 windows host

by H.Hopper, 10 years ago

Attachment: VBox-ose.log added

second log x64 guest but ose build of most files

by H.Hopper, 10 years ago

Attachment: VBox-1.log added

comment:5 by H.Hopper, 9 years ago

It seems this issue is irrelevant.

Can someone confirm my assumptions that the provided SDL.dll on Windows is broken?

It has a missing dependency to msvcr80.dll (can be available on the system) but with or without that file the program always launches giving the SDL Error: 'DirectInputDevice::SetDataFormat: Invalid parameters' no matter what.

But if nobody reads this ticket, why bother?

The only way to confirm this is to provide a test build with: -updated SDL to 1.2.15 (built with vs2010 instead of vs2005 - msvcr80.dll)

Last edited 9 years ago by H.Hopper (previous) (diff)

comment:6 by Mihai Hanor, 9 years ago

Set SDL_VIDEODRIVER to windib in the Windows environment variables and try again. Why do you need to use VBoxSDL?

Last edited 9 years ago by Mihai Hanor (previous) (diff)

comment:7 by H.Hopper, 9 years ago

Thank you mhanor!

Confirmed: created environment variable SDL_VIDEODRIVER with a value of windib and it works fine. For me this one is solved then.

I'm using VBoxSDL --fullscreen --fullscreenresize to test fullscreen apps and some games where resolution needs to stretch entirely (mouse at edges). I find it works better that scale mode in this case.

I was looking in the wrong places for a fix so far.

comment:8 by H.Hopper, 5 years ago

Note: this is officially solved as of v6.1.0. Confirmed to work on Windows hosts without adding SDL_VIDEODRIVER windib to launch command.


VBoxSDL frontend: Fixed running on Windows hosts

Last edited 5 years ago by H.Hopper (previous) (diff)
Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use