VirtualBox

Ticket #11456 (closed defect: fixed)

Opened 15 months ago

Last modified 10 months ago

Cannot power on a virtual machine: NS_ERROR_CALL_FAILED (0x800706BE)/IProgress {c20238e4-3221-4d3f-8891-81ce92d9f913} => Fixed in SVN

Reported by: birdie Owned by:
Priority: critical Component: EFI
Version: VirtualBox 4.2.6 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

Whenever I try to power on my Windows 8 64 bit UEFI guest I get this error.

00:00:00.531823 VMSetError: /home/vbox/vbox-4.2.6/src/VBox/Devices/EFI/DevOVMF.cpp(1343) int efiConstruct(PDMDEVINS*, int, CFGMNODE*); rc=VERR_CFGM_INTEGER_TOO_BIG
00:00:00.531832 VMSetError: Can't attach Nvram Storage driver
00:00:00.531846 PDM: Failed to construct 'efi'/0! VERR_CFGM_INTEGER_TOO_BIG (-2100) - The integer value was too big for the requested representation.

Host: Linux 3.7.6 vanilla x86 PAE
Guest: Windows 8 64 UEFI

Attachments

VBox.log Download (27.3 KB) - added by birdie 15 months ago.

Change History

Changed 15 months ago by birdie

comment:1 Changed 15 months ago by birdie

BTW:

[   86.512091] warning: `VirtualBox' uses 32-bit capabilities (legacy support in use)
[  130.102804] EMT-0[2582]: segfault at 0 ip ad2d0861 sp b04d2050 error 4 in VBoxDD.so[ad1e3000+249000]
[  161.781979] EMT-0[2805]: segfault at 0 ip ad24f861 sp b04d0050 error 4 in VBoxDD.so[ad162000+249000]
[  290.632236] EMT-0[3185]: segfault at 0 ip ad24f861 sp b04d0050 error 4 in VBoxDD.so[ad162000+249000]
[  575.259626] EMT-0[3399]: segfault at 0 ip ad24f861 sp b04d2050 error 4 in VBoxDD.so[ad162000+249000]
[  599.943258] EMT-0[3491]: segfault at 0 ip ad8d0861 sp b04d0050 error 4 in VBoxDD.so[ad7e3000+249000]
[  703.561530] EMT-0[3613]: segfault at 0 ip ad9d0861 sp b05d0050 error 4 in VBoxDD.so[ad8e3000+249000]
[  717.700479] EMT-0[3706]: segfault at 0 ip ad94f861 sp b0551050 error 4 in VBoxDD.so[ad862000+249000]
[  726.335562] EMT-0[3792]: segfault at 0 ip ad94f861 sp b04d0050 error 4 in VBoxDD.so[ad862000+249000]

comment:2 Changed 15 months ago by frank

UEFI is not (yet) supported by VirtualBox. But I agree that this is a strange error message and VBox should also not crash.

comment:3 Changed 10 months ago by birdie

This bug affects only CentOS 6.4 host.

And I still can reproduce it in VBox 4.2.14 (regardless a guest OS type or VM settings):

Failed to open a session for the virtual machine Test PC.

No error info.

Result Code: NS_ERROR_CALL_FAILED (0x800706BE)
Component: ProgressProxy
Interface: IProgress {c20238e4-3221-4d3f-8891-81ce92d9f913}

dmesg:

EMT[22435]: segfault at 0 ip adf51e81 sp b01890d0 error 4 in VBoxDD.so[ade64000+24a000]

comment:4 Changed 10 months ago by frank

Can you provide a core dump together with a VBox.log file for VBox 4.2.14?

comment:5 Changed 10 months ago by birdie

Strangely I cannot reproduce this bug today (maybe stars are aligned differently).

I will provide the necessary information when I'm able to reproduce it again.

comment:6 Changed 10 months ago by birdie

This bug manifests itself only when I add storage (HDD) to a VM. Otherwise it doesn't trigger.

My highly compressed core dump weighs 10MB (7z compression: ultra, dictionary: 128MB), where can I upload it?

comment:7 Changed 10 months ago by birdie

OK, get it here:  http://www.sendmyway.com/y9248u51h7gu

$ sha1sum Windows 2012.7z
99225bbc4a0b5cf7fb2ce459023f1646cbf89b15  Windows 2012.7z

comment:8 follow-up: ↓ 9 Changed 10 months ago by frank

Sorry, your download link does not work. It offers me to download an .exe file which I wouldn't download. Please upload the core dump to ftp.oracle.com:/appsdev/incoming and tell me the name of the file. That server is write-only for public users. Thank you!

comment:9 in reply to: ↑ 8 Changed 10 months ago by birdie

Replying to frank:

Sorry, your download link does not work. It offers me to download an .exe file which I wouldn't download. Please upload the core dump to ftp.oracle.com:/appsdev/incoming and tell me the name of the file. That server is write-only for public users. Thank you!

The filename is "Windows 2012.7z".

comment:10 Changed 10 months ago by frank

  • Summary changed from Cannot power on a virtual machine: NS_ERROR_CALL_FAILED (0x800706BE)/IProgress {c20238e4-3221-4d3f-8891-81ce92d9f913} to Cannot power on a virtual machine: NS_ERROR_CALL_FAILED (0x800706BE)/IProgress {c20238e4-3221-4d3f-8891-81ce92d9f913} => Fixed in SVN

Thanks for the core dump. Actually this happens with 64-bit EFI guests on 32-bit hosts. This problem will be fixed in the next maintenance release.  Here is a test build which includes the fix.

comment:11 Changed 10 months ago by birdie

Yep, this build has fixed the problem for me.

Thank you!

comment:12 Changed 10 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix included in 4.2.16.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use