VirtualBox

Ticket #11425 (closed defect: duplicate)

Opened 15 months ago

Last modified 14 months ago

VirtualBox 4.2.6 crashes on OS X host when host OS wakes up from sleep

Reported by: tsuna Owned by:
Priority: major Component: other
Version: VirtualBox 4.2.6 Keywords:
Cc: Guest type: Linux
Host type: Mac OS X

Description

Since I upgraded to 4.2.6, VirtualBox regularly (but not always) crashes when the host OS wakes up from sleep. This was also reported on the forum ( Random crashes - WinXP 32bit guest since 4.2.6).

Host OS: OS X 10.8.2 Guest OS: Linux 2.6.38 (Fedora 14, 64 bit) Guest additions v4.2.6 installed

Signature of the crash:

Crashed Thread:  4  TIMER

Exception Type:  EXC_ARITHMETIC (SIGFPE)
Exception Codes: EXC_I386_DIV (divide by zero)

Thread 4 Crashed:: TIMER
0   VBoxC.dylib                         0x000000010d89a82b 0x10d800000 + 632875
1   VBoxRT.dylib                        0x00000001002728aa RTTimerLRDestroy + 442
2   VBoxRT.dylib                        0x000000010023fdaf RTThreadCreateF + 271
3   VBoxRT.dylib                        0x000000010029219c RTThreadPoke + 540
4   libsystem_c.dylib                   0x00007fff87fde742 _pthread_start + 327
5   libsystem_c.dylib                   0x00007fff87fcb181 thread_start + 13

Attachments

VirtualBoxVM_2013-01-25-121042_damogran.crash Download (78.5 KB) - added by tsuna 15 months ago.
Crash report generated by OS X
VBox.log Download (80.7 KB) - added by tsuna 15 months ago.
VirtualBox log
VirtualBoxVM_2013-01-25-185728_renata.crash Download (57.3 KB) - added by Zoltan Szasz 15 months ago.
Crash log of VirtualBox
VBox.log.1 Download (67.0 KB) - added by ctopri 15 months ago.
Another XP guest log file

Change History

Changed 15 months ago by tsuna

Crash report generated by OS X

Changed 15 months ago by tsuna

comment:1 Changed 15 months ago by echristopherson

I also get this sometimes when waking from sleep on my 2.0GHz Core Duo MacBook 13" (the original, 32-bit one), running OS X 10.6. I'm running 32-bit Xubuntu 12.10 as guest.

I notice there is an interlacing-like pattern on the VM's display after waking the host system, so apparently VB sees when suspension happens and acts on it. I wonder if it would be possible to make host suspension transparent to VB and the guest, in case that could serve as a workaround.

Changed 15 months ago by Zoltan Szasz

Crash log of VirtualBox

comment:2 Changed 15 months ago by Zoltan Szasz

Unfortunately i can confirm this symptoms.

comment:3 Changed 15 months ago by ctopri

I have also seen this, although in my case the guest OS had crashed without explanation after wakeup, and VirtualBox showed the VM as "Aborted".

Host: OS X 10.8.2, Guest: Windows XP SP3 with guest additions

Last edited 15 months ago by ctopri (previous) (diff)

Changed 15 months ago by ctopri

Another XP guest log file

comment:4 Changed 14 months ago by RichardBarran

Same issue as ticket #11351?

comment:5 Changed 14 months ago by pup

Same issue here on an Early 2011 15" MacBook Pro running OS X 10.8.2 (12C60) and VirtualBox 4.2.6.

However, I've noticed that it only happens after I've awoken the computer in a different network. That is:

  1. Bring up Ubuntu 10.10 in a VM
  2. Close laptop
  3. Open laptop in a different network attaching to a new WiFi - VM is still running.
  4. Close laptop
  5. Open laptop in the original network - VM gone.

As long as I wake up the laptop in the network in which I original attached the VM, it's still there and runs fine.

comment:6 Changed 14 months ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

I'm not sure about #11351 but it's most likely a duplicate of #11444.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use