Ticket #11357 (new defect)

Opened 5 years ago

Last modified 18 months ago

Mouse Lag in Age of Empires 2

Reported by: BryceSteiner Owned by:
Priority: minor Component: other
Version: VirtualBox 4.2.6 Keywords: mouse lag age of empires 2d
Cc: Guest type: Windows
Host type: Mac OS X


I had this problem several years ago on virtualbox but it was fixed. In the last two public releases 4.18 4.20. The problem seems to have reappeared, and that is the mouse lags on Age of Empires II AOE2 during game play no matter which computer I use. Several months ago it was working fine. I've tried it on 4 different machines some are better, but none are right.

Host MacOSX Mountain Lion 10.8 Guest Windows XP SP3 DirectX 9c

It's only in game play that the mouse lags by .5 to 1 second. The game menu is fine. Network versus standalone is exactly the same.

Medal of Honor Breakthrough runs perfect. I've never had it run on a real PC as well as it does on Virtualbox

the latest 4.2.6 still has the mouse lag in Age of Empires 2 in Windows XP. Same problem in both SP3 and SP2. I also did a clean install with no better results. Because it runs so well with 3d it makes me think it's in the 2d part of the directX video driver or something with the mouse driver

BUT I think I figured out what is going on. The video driver appears to have gained a bug in 4.18 or thereabouts and forward.

If I turn off all acceleration on the slide bar in troubleshooting in Windows XP advanced settings (even keeping Enable Write combining checked) it will play without any lag. I don't know how to address the issue though. It's not smooth anymore, but the lag is gone and makes it useable.

I don't have a log, but I could get one if needed. It doesn't crash at all or give any errors so I'm not sure what I would send.


XPGaming-2013-01-03-18-02-01.log Download (62.3 KB) - added by BryceSteiner 5 years ago.
This is the Virtualbox log that I was able to save.

Change History

Changed 5 years ago by BryceSteiner

This is the Virtualbox log that I was able to save.

comment:1 Changed 5 years ago by scojjac

Same issue, same guest, though I am running VB 4.2.10. If there's anything I can offer to help, let me know.

comment:2 Changed 4 years ago by StevenJ99

I also have this problem running Age of Empires 2 in Win XP in VB 4.3.6 in OSx 10.9.1 Mavericks.

The same Win XP guest machine ran AOE 2 perfectly in VB 4.2.10 in a OSx 10.7 Lion host.

Launching AOE 2 from Voobly reduces the mouse lag but does not eliminate it. Windows acceleration settings had no effect for me.

comment:3 Changed 4 years ago by BryceSteiner

The problem still exists with the latest Virtualbox 4.3.8 and I also use Mac OS 10.9.2. I have new information though. The problem happens to be with a resolution problem in the Virtualbox video driver or the handling between it and AOE2. If the video is set to 800x600 (in the game) there is absolutely no lag whatsoever. Switch it back to 1024x768 and its all back and repeatable. Let me know if there is anything I need to do, such as uploading a log file.

comment:4 Changed 4 years ago by DaniT

Exactly the same bug for me. OSX 10.9, WinXP 32bit guest. Mouse is lagging a lot and the game turns unplayable.

comment:5 Changed 3 years ago by DaniT

Same issue for me using vbox 4.2 and 4.3.

THE BUG DOES NOT EXIST IN VBox 4.1. Sadly, Ubuntu 15.04 is not compatible with 4.1 (you can download but install, but can't create a virtual machine because memory settings are grayed out).

As a workaround i created the machines on 4.3 with the sets i need, and then downgraded to 4.1. Odd, because sometimes i need to change network settings when playing on LAN with my friends and I'm not able to do so because of the incompatibility issue (can't save settings).

comment:6 Changed 21 months ago by Darwood

I'm still getting this bug in VirtualBox v5.0.26. Has it still not been resolved?

comment:7 Changed 18 months ago by pixelou

Confirmed on vbox 5.1.12 with 64bits linux host and 32bits windows XP guest.

Note: See TracTickets for help on using tickets.
ContactPrivacy policyTerms of Use