VirtualBox

Ticket #11309 (closed defect: fixed)

Opened 2 years ago

Last modified 10 months ago

VirtualBox lingers in memory as the existing VBoxSVC process just exited

Reported by: mhanor Owned by:
Priority: minor Component: other
Version: VirtualBox 4.2.6 Keywords:
Cc: Guest type: all
Host type: Windows

Description

This is not particular to 4.2.6. Host: Windows 7 SP1 x64

Starting VirtualBox.exe as the existing VBoxSVC process is just exiting (normal termination a few seconds after the previous VirtualBox instance exited), the new VirtualBox process does nothing. It just lingers in memory. The issue can be reproduced if you correctly time your launch of the VirtualBox program, paying attention to the existing VBoxSVC process, taking into account how long ago the previous VirtualBox instance exited.

Attachments

Clipboard01.png Download (9.6 KB) - added by JustTryingToHelp 10 months ago.

Change History

comment:1 Changed 2 years ago by mhanor

VB 4.2.8 has the same problem.

comment:2 Changed 11 months ago by mhanor

It's the same problem with VB 4.3.11 rev93259. The VirtualBox process actually returns an error, after some time:

Callee RC: 
CO_E_SERVER_EXEC_FAILURE (0x80080005)

To rephrase the issue: when launching VirtualBox, just when the VirtualBox COM service (VBoxSVC) is about to close (normal termination, after the previous, last instance of VirtualBox, was closed), the new VirtualBox process fails to syncronize with the existing (about to be closed) VBoxSVC process. In the end, it fails with the above error.

Last edited 11 months ago by mhanor (previous) (diff)

comment:3 Changed 10 months ago by frank

Could you test this build? This build contains fixes which hopefully fix your problem.

comment:4 Changed 10 months ago by mhanor

I will test it, but it's difficult to reproduce the issue at will, because I can't control the timing. A small note: the setup you provided, manages to crash one of the msiexec process that are launched during the installation process. It crashes every time I install, using that setup. I've never seen such an event, until now.

comment:5 Changed 10 months ago by mhanor

I think it's fine now. At least, during the critical time interval, I now see two VBoxSVC processes, the exiting one and the newly launched service. The old service terminates, while the VM is successfully started. Before this, I think I've never seen two VBoxSVC processes, running at the same time.

Last edited 10 months ago by mhanor (previous) (diff)

comment:6 Changed 10 months ago by frank

Thanks for the feedback! I now have another test build which should also fix the installation problems you have, just in case you still have problems with installing this build.

comment:7 Changed 10 months ago by mhanor

The 4.3.11-93549 setup also triggers a crash in a msiexec process. It doesn't crash if I allow the installation of the Bridged Networking drivers. The crash occurs in the module described by this MSI log line:

Invoking remote custom action. DLL: C:\windows\Installer\MSIA9F5.tmp, Entrypoint: InstallNetFlt

The older test build, 4.3.11-93259, doesn't have this problem.

Last edited 10 months ago by mhanor (previous) (diff)

comment:8 Changed 10 months ago by frank

mhanor, we think that we also fixed this crash. Could you download + install this package and test again? Thank you!

comment:9 Changed 10 months ago by mhanor

Indeed, it's ok now.

comment:10 Changed 10 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks again for the feedback! Fix is part of VBox 4.3.12.

comment:11 Changed 10 months ago by JustTryingToHelp

Sorry to reopen this ticket but I have the same crash installing 4.3.12-93733 (official download version).

comment:12 Changed 10 months ago by JustTryingToHelp

  • Status changed from closed to reopened
  • Resolution fixed deleted

Changed 10 months ago by JustTryingToHelp

comment:13 Changed 10 months ago by mhanor

Please open a new ticket. You also need to give details about your OS and if you customized the VirtualBox installation. You might want to redownload the setup and try to reinstall it.

Last edited 10 months ago by mhanor (previous) (diff)

comment:14 Changed 10 months ago by JustTryingToHelp

You could be right, maybe I should of opened a new ticket. That's why I said "sorry" in the first place. But why haven't you followed your own advice by opening a new ticket when you noticed the same problem? Oh, wait, this is YOUR ticket and they were YOUR time and energy to waste opening a new ticket; but, obviously, you have no problem asking others to do the same thing you didn't.

Just so you know, I posted here ONLY because you posted about this problem too.

comment:15 Changed 10 months ago by mhanor

I wasn't criticizing you. The original issue was different, indeed, but I considered important to mention the crash with the test build. And I wasn't going to open a ticket for something that's not a final build.

comment:16 Changed 10 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use