VirtualBox

Ticket #11250 (closed defect: obsolete)

Opened 7 years ago

Last modified 3 years ago

Wrong display of non-ASCII characters (umlauts) in file and folder names shared from windows host to linux guest

Reported by: FrankSt Owned by:
Component: shared folders Version: VirtualBox 4.2.4
Keywords: non-ASCII characters, umlauts Cc:
Guest type: Linux Host type: Windows

Description

Host: VB 4.2.4, Windows 7 Guest: Linux (ROSA 2012 Marathon) with Additions 4.2.4

When I share a folder from Windows host to Linux guest, files and folders containing German umlauts (and probably other non-ASCII characters) are displayed incorrectly. E. g. "Antikörper" becomes "Antik�rper". This happens in the KDE filemanager (Dolphin) as well as on the konsole. The affected files and folders are inaccessible from the guest, even after manually replacing � with the correct character. This seems to be a regression introduced with guest additions 4.2.0 (I confirmed this for 4.2.0, 4.2.2, and 4.2.4), since it does not happen when I use guest additions 4.1.22 or previous with my 4.2.4 host.

Attachments

ROSA 2012 LTS-2012-11-30-16-25-00.log Download (60.2 KB) - added by FrankSt 7 years ago.
VBox.log

Change History

Changed 7 years ago by FrankSt

VBox.log

comment:1 Changed 3 years ago by aeichner

  • Status changed from new to closed
  • Resolution set to obsolete

Please reopen if still relevant with a recent VirtualBox release.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use