VirtualBox

Ticket #11233 (reopened defect)

Opened 2 years ago

Last modified 9 months ago

the vboxdrv service is not started

Reported by: stephdl Owned by:
Priority: major Component: other
Version: VirtualBox 4.2.4 Keywords:
Cc: Guest type: other
Host type: other

Description

I found that the binaries installed virtualbox from oracle repositories causing malfunction on my debian wheezy.

Every time I run virtualbox, the prompt asked them to return this command although the DKMS package is installed

"/etc/init.d/vboxdrv setup"

we can see that the service vboxdrv is not started at boot the machine because there is no runlevel assigned to this service.

I have to manually assign it level with the startup command

"update-rc.d vboxdrv defaults"

I can reproduce this bug on two debian wheezy when I want to use the packages virtualbox 4.1 and 4.2

here are the error messages that I get when I want to start virtualbox

Failed to open a session for the virtual machine ...

"The virtual machine '..' has terminated unexpectedly falling on startup with exit code 1."

and also that the

"Kernel driver not installed (rc = -1908)

The VirtualBox Linux kernel driver (vboxdrv) is not loaded or there Either is a permission problem with / dev / vboxdrv. Please reinstall the kernel module by executing

'/etc/init.d/vboxdrv setup'

as root. If it is available in your distribution, you install the DKMS package shoulds first. This package keeps track of Linux kernel and recompiled exchange the vboxdrv kernel module if Necessary. "

Change History

comment:1 Changed 2 years ago by frank

This sounds strange and I cannot reproduce the problem. The postinst script of these packages contains the line update-rc.d vboxdrv defaults. I have no idea why it does not work on your box. Was the package correctly installed (including the configuration step)?

comment:2 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

No response, closing.

comment:3 Changed 21 months ago by alfredx

I have this issue on my box. I think it is because I have an 4.1 insalled before I installed 4.2.

comment:4 Changed 9 months ago by ron_h

  • Status changed from closed to reopened
  • Resolution worksforme deleted

I installed Virtual 4.3.12 from the deb package on Virtualbox website on my Linux Mint Debian Edition Cinnamon 201403 64bit system and I have the same symptom. Vboxdrv setup needs to be run every time I boot the host.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use