VirtualBox

Ticket #11209 (closed defect: fixed)

Opened 17 months ago

Last modified 16 months ago

storageattach: Invalid UUID or filename

Reported by: rschmied Owned by:
Priority: major Component: VM control
Version: VirtualBox 4.2.2 Keywords:
Cc: Guest type: other
Host type: all

Description

Using VB 4.2.2 r81494

when using VBoxManage to attach disk images (in this case a DVD image) to machines my script uses of UUIDs. Essentially, it grabbed the UUID of the DVD from the list of DVDs and attached it to the controller of the machine. This was working with 4.1.

With 4.2, the following error is given:

bleh$ /usr/bin/VBoxManage storageattach xpsp3 --storagectl 'IDE Controller' --type dvddrive --port 1 --device 0 --medium c4777f0f-bbfb-4157-a6d0-1e8519b505d6
VBoxManage: error: The given path 'c4777f0f-bbfb-4157-a6d0-1e8519b505d6' is not fully qualified
VBoxManage: error: Details: code VBOX_E_FILE_ERROR (0x80bb0004), component Medium, interface IMedium, callee nsISupports
VBoxManage: error: Context: "OpenMedium(Bstr(pszFilenameOrUuid).raw(), enmDevType, enmAccessMode, fForceNewUuidOnOpen, pMedium.asOutParam())" at line 220 of file VBoxManageDisk.cpp
VBoxManage: error: Invalid UUID or filename "c4777f0f-bbfb-4157-a6d0-1e8519b505d6"
bleh$ 

However:

UUID:        c4777f0f-bbfb-4157-a6d0-1e8519b505d6
Format:      RAW
Location:    /usr/share/virtualbox/VBoxGuestAdditions.iso
State:       created
Type:        readonly

When using the Location / fully qualified path name instead of the UUID it works as expected:

bleh$ /usr/bin/VBoxManage storageattach xpsp3 --storagectl 'IDE Controller' --type dvddrive --port 1 --device 0 --medium /usr/share/virtualbox/VBoxGuestAdditions.iso
bleh$ 

However, I don't see a reason why the UUID should not work.

This bug is really bad when you realize you can't delete iSCSI targets because it won't recognize the UUID... Even though the target is clearly there.

See for additional comments  https://forums.virtualbox.org/viewtopic.php?f=1&t=52270

Change History

comment:1 Changed 17 months ago by aeichner

Issue confirmed, will be fixed in the next maintenance release. Thanks for the report!

comment:2 Changed 17 months ago by MarekSal

bug confirmed in 4.2.4.

comment:3 Changed 16 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in VBox 4.2.6.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use