VirtualBox

Ticket #11154 (closed defect: duplicate)

Opened 18 months ago

Last modified 18 months ago

Bad VM to Host Network Performance with Intel NIC or virtio

Reported by: Gevatter Gaul Owned by:
Priority: minor Component: network/hostif
Version: VirtualBox 4.2.4 Keywords: nic intel ping latency bug performance
Cc: Guest type: Linux
Host type: Linux

Description

I'm running VirtualBox 4.2 on a Ubuntu 12.04 LTS 64bit. The machine is a Xeon E1230 Quadcore with 32G ECC RAM. The VM, running Ubuntu 12.04 LTS 64bit, is connected via a Host Adapter. When running a ping from the Host to the VM, everything seems fine and I get an average latency of around 0.2ms. But in the other direction, depending on the configured VM NIC, I get very high ping results. Strangely enough, the problem only exists, when configuring more than one virtual CPU. Here are my measurements:

Average Ping:

VCPUs PCnet-PCI II PCnet-FAST III Intel PRO/1000 MT Desktop Intel PRO/1000 T Server Intel PRO/1000 MT Server Paravirtualized Network 1 0.168 0.183 0.209 0.191 0.206 0.399 2 0.193 0.182 15.987 12.157 10.349 5.327 3 0.179 0.167 12.032 14.052 9.657 5.337 4 0.174 0.176 12.929 13.680 13.627 5.482

mdev:

VCPUs PCnet-PCI II PCnet-FAST III Intel PRO/1000 MT Desktop Intel PRO/1000 T Server Intel PRO/1000 MT Server Paravirtualized Network 1 0.043 0.046 0.040 0.061 0.039 0.055 2 0.085 0.085 16.036 16.390 14.946 4.638 3 0.045 0.046 14.575 16.903 13.330 5.252 4 0.045 0.044 16.286 16.033 16.148 4.881

We see, as soon as I configure more than one VCPU, latency goes through the roof.

vbox guest log and showvminfo output are attached.

Attachments

VBox.log Download (98.6 KB) - added by Gevatter Gaul 18 months ago.
showvminfo.txt Download (4.9 KB) - added by Gevatter Gaul 18 months ago.
vm_to_host_ping.txt Download (1.1 KB) - added by Gevatter Gaul 18 months ago.

Change History

Changed 18 months ago by Gevatter Gaul

Changed 18 months ago by Gevatter Gaul

Changed 18 months ago by Gevatter Gaul

comment:1 Changed 18 months ago by Gevatter Gaul

Added a file with measurements, as formatting in Bug description is crappy.

comment:2 Changed 18 months ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #10157, please continue the discussion there.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use