VirtualBox

Ticket #11149 (closed defect: duplicate)

Opened 18 months ago

Last modified 18 months ago

Constant disk read

Reported by: gaborca Owned by:
Priority: minor Component: other
Version: VirtualBox 4.2.4 Keywords: disk_read
Cc: Guest type: all
Host type: Windows

Description

I have got a relatively old harddrive in my PC, and recently I noticed that it keeps constant disk reading (or writing) when I run particular programs, because it has got audible seek sounds. After investigating a bit (stopping all my software, and starting them one by one) it turned out that VirtualBox is making that noise.

To prove it, I downloaded and ran ProcMon from Microsoft ( http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx), chose Filter (ctrl+L), and added two rules: "Operation is ReadFile" and "Operation is WriteFile". VBoxSVC.exe and VirtualBox.exe make together about 300 disk reads in the ProcMon process reading refresh period (in 2 or 3 seconds). The weird thing is that both processes keep reading the same file, C:\Program Files\Oracle\VirtualBox\VBoxC.dll, about 100-200 bytes, and they start it over and over again. You can see that on the attached screenshot of ProcMon, and I also  upload that onto my website.

My host is: Windows XP SP3 This bug is present in 4.2.0 and also in 4.2.4 (the newest one) The bug is present in all guest I started (Windows XP, Debian, OpenBSD) The bug doesn't generate visible CPU load, but I fear it wears the disk

Attachments

virtualbox_bug.png Download (48.1 KB) - added by gaborca 18 months ago.
Screenshot of Process Monitor showing VirtualBox constant disk reads

Change History

Changed 18 months ago by gaborca

Screenshot of Process Monitor showing VirtualBox constant disk reads

comment:1 Changed 18 months ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #8298. Please continue the discussion there.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use